summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-12-16 12:43:38 +0000
committerMarek Szuba <marecki@gentoo.org>2021-12-16 15:48:28 +0000
commit8fe8f6e6ece7aa0c3fc949fa0759ba15f3610d34 (patch)
tree2f0d4e06b6a59b0d391dcce3a3e47b07da2fcf23 /net-libs/xrootd-ceph/xrootd-ceph-5.4.0.ebuild
parentnet-libs/xrootd: drop 5.1.1-r1, 5.2.0-r1 (diff)
downloadgentoo-8fe8f6e6ece7aa0c3fc949fa0759ba15f3610d34.tar.gz
gentoo-8fe8f6e6ece7aa0c3fc949fa0759ba15f3610d34.tar.bz2
gentoo-8fe8f6e6ece7aa0c3fc949fa0759ba15f3610d34.zip
net-libs/xrootd-ceph: add 5.4.0
Closes: https://bugs.gentoo.org/747445 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/xrootd-ceph/xrootd-ceph-5.4.0.ebuild')
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-5.4.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-5.4.0.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-5.4.0.ebuild
new file mode 100644
index 000000000000..9267d0cbd7b8
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-5.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=net-libs/xrootd-5.0.0
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.4.0_no-werror.patch
+)
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrdCeph.*-$(ver_cut 1)\.so
+ /usr/lib.*/libXrdCephTests\.so"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}