summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-03 14:02:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-03 14:11:06 +0200
commit238eca462939df9a7d97ebf6a80352f2f06c0efd (patch)
tree616a276aabdee97b1caa7ba8c529957f13f8a74d /net-libs
parentnet-irc/hexchat: Synced live ebuild. (diff)
downloadgentoo-238eca462939df9a7d97ebf6a80352f2f06c0efd.tar.gz
gentoo-238eca462939df9a7d97ebf6a80352f2f06c0efd.tar.bz2
gentoo-238eca462939df9a7d97ebf6a80352f2f06c0efd.zip
net-libs/libssh: Bump to version 0.8.2
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh/Manifest1
-rw-r--r--net-libs/libssh/libssh-0.8.2.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index dbbf852c2782..ac53341e4884 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,3 +1,4 @@
DIST libssh-0.7.4.tar.xz 351892 BLAKE2B 5427faa04eac7b57f73909f113d933daf667f8311c30364bbf06d4f01121a58f5b560e0a1d9071655ce9b310fa3f3f801e11e880ca3eacde66efa0f49dc51b2b SHA512 94b8183e5c83e339303c1a160c92ccff6159471ac7d189ab66cf6d606d2e803fd616519f079aef1577c947d3a14e315332b05ea08e44d0ab550edbcb768dbea7
DIST libssh-0.7.5.tar.xz 351632 BLAKE2B b41cccb6215c5b7e66742171d91e1081d3c1bf44455b65a5992093d31b28db7a6375e815303e115e02b2458c734d9c61e4b1528ba905bf8a421ca2bbb7221ce6 SHA512 6c7f539899caaedf13d66fa2e0fac1a475ecdfe389131abcbdf908bdebc50a0b9e6b0d43e67e52aea85c32f6aa68e46ca2f50695992f82ded83489f445a8e775
DIST libssh-0.8.1.tar.xz 409572 BLAKE2B 65bf38c5bba803a588ff4a1cc5f774cacc43c500bf0aaa77674f9120eccda26027e446aeb9e61a2418eb81077fdb0aa55d8e014f6d466877a9cd96b665c5e7ce SHA512 6630d0b101dc109116ba7a6cffb00db1bc9b5bc6004c843c5361d3d97c6cf4c323129ebf3bbf25ab2fc1961b74520490d7a16999504849c07b26a25679724b93
+DIST libssh-0.8.2.tar.xz 408412 BLAKE2B bbd531ed511baa84d40c2e156cc63fca09345196e24e485930d8f42fed451529ea6ec2ce6f50276dfa56d5523062bbc45774891ad47ce7c748e8b95bc28b9f8c SHA512 ef9877d2a35f1871139c12452c917a3888172ea29f71d880e824de182695e5a8786bb39ca2f4874a160e156648d52065a8b2e7c040220badf65eee35dcfddeb9
diff --git a/net-libs/libssh/libssh-0.8.2.ebuild b/net-libs/libssh/libssh-0.8.2.ebuild
new file mode 100644
index 000000000000..641c1853e986
--- /dev/null
+++ b/net-libs/libssh/libssh-0.8.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-${PV/_rc/rc}"
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ inherit eapi7-ver
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
+"
+
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+
+DOCS=( AUTHORS README ChangeLog )
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.0-tests.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # just install the examples do not compile them
+ sed -i \
+ -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
+ CMakeLists.txt || die
+
+ # keyfile torture test is currently broken
+ sed -i \
+ -e '/torture_keyfiles/d' \
+ tests/unittests/CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING="$(usex test)"
+ -DWITH_DEBUG_CALLTRACE="$(usex debug)"
+ -DWITH_DEBUG_CRYPTO="$(usex debug)"
+ -DWITH_GCRYPT="$(usex gcrypt)"
+ -DWITH_GSSAPI="$(usex gssapi)"
+ -DWITH_MBEDTLS="$(usex mbedtls)"
+ -DWITH_NACL=no
+ -DWITH_PCAP="$(usex pcap)"
+ -DWITH_SERVER="$(usex server)"
+ -DWITH_SFTP="$(usex sftp)"
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STATIC_LIB="$(usex static-libs)"
+ -DWITH_STATIC_LIB="$(usex test)"
+ -DWITH_ZLIB="$(usex zlib)"
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+ multilib_is_native_abi && use doc && cmake-utils_src_compile doc
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ if multilib_is_native_abi && use doc ; then
+ docinto html
+ dodoc -r doc/html/.
+ fi
+
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/libssh.a
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}