summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-01-08 20:42:18 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-01-08 20:42:31 -0500
commit37bd823f08a8c8f4d38d0c45201723ffec407b23 (patch)
tree457f0abd03929cd7333ef291e95170af43996af2 /net-libs
parentwww-client/epiphany: x86 stable (bug #674870) (diff)
downloadgentoo-37bd823f08a8c8f4d38d0c45201723ffec407b23.tar.gz
gentoo-37bd823f08a8c8f4d38d0c45201723ffec407b23.tar.bz2
gentoo-37bd823f08a8c8f4d38d0c45201723ffec407b23.zip
net-libs/stem: version bump to 1.7.1
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/stem/Manifest1
-rw-r--r--net-libs/stem/stem-1.7.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
index 5471a984b993..59f5e04b4e21 100644
--- a/net-libs/stem/Manifest
+++ b/net-libs/stem/Manifest
@@ -1,3 +1,4 @@
DIST stem-1.5.4.tar.gz 1915722 BLAKE2B 37c278eab0d7c7c305d7fcb498ff39460921ff59ea16cbe97d985c742290b8ca938218cbc7d5e4d1106ffc9f6a20461a4692afd14565698abbdfbd8015cb6f18 SHA512 1ea74341a1013f1f98d3d5ed1d552e79277cf54a6337d1a8b66bda0baae022d70c4c0c9ce35c843222d183a716466d93e1df3ee55ae6cd16cf10c6cf415d3cf7
DIST stem-1.6.0.tar.gz 2049999 BLAKE2B 10846dbd20f22b489fa885e8f100eb2ba4053aca46db140463882cbc1f5701893e6a4a28820100e05e3ed4fa5ff76135a3b20ec1af917a63f63b3abdf5361df6 SHA512 499a15b1cbd12d75865c93e253e797507564d5b5f2a9a0f021107d89c85db040e050944a9ac69b629f74e265d350467bef9d36ec52f7ef2e6a97180a7b93e94c
DIST stem-1.7.0.tar.gz 2196759 BLAKE2B 2f4bf8a65e5e89b01e6d1054a9d7fe01d4775dc31f1846c300190320361e15a312ce35867fd7d6af2d0cb315894aa5f69f7e8a47cf184e1d9018342028ba1484 SHA512 10750266860f4f90df5d4a3bf24ec68e28d12c84c136c35d2f168f767f4facae3d02cc62dc972a08666689695ea17337a7a6b80ec1c5ed8b9e5035d7417b07f5
+DIST stem-1.7.1.tar.gz 2196854 BLAKE2B 318b762390ad5f1b8a7ad49bd442841d4552cf3d6782c7c912ca8251a076baa6d01bd6f60ea2d79f96994f7c29775c09b815ee41177c638c7e4089e5f4b1b1e4 SHA512 a275f59bba650cb5bb151cf53fb1dd820334f9abbeae1a25e64502adc854c7f54c51bc3d6c1656b595d142fc0695ffad53aab3c57bc285421c1f4f10c9c3db4c
diff --git a/net-libs/stem/stem-1.7.1.ebuild b/net-libs/stem/stem-1.7.1.ebuild
new file mode 100644
index 000000000000..9a38c64d97dd
--- /dev/null
+++ b/net-libs/stem/stem-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6,3_7})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-vpn/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-vpn/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_parsing_with_example/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_parsing_with_unknown_options/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_saving_manual/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_sdist_matches_git/a \
+ \ \ \ \ return" test/integ/installation.py || die
+ sed -i -e "/test_connections_by_ss/a \
+ \ \ \ \ return" test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}