summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-12 11:37:36 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-12 11:56:45 -0700
commit6c95887964743f14f9af8b75929408df60691fc7 (patch)
tree6d40511fc40a89711b45cb92ba9f6394e41bd201 /net-libs
parentnet-analyzer/icinga2: revbump for mysql changes (diff)
downloadgentoo-6c95887964743f14f9af8b75929408df60691fc7.tar.gz
gentoo-6c95887964743f14f9af8b75929408df60691fc7.tar.bz2
gentoo-6c95887964743f14f9af8b75929408df60691fc7.zip
net-libs/grpc: version bump to 1.14.2
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/grpc/Manifest1
-rw-r--r--net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch83
-rw-r--r--net-libs/grpc/grpc-1.14.2.ebuild173
3 files changed, 257 insertions, 0 deletions
diff --git a/net-libs/grpc/Manifest b/net-libs/grpc/Manifest
index c694829ef8a3..2f11312e5db9 100644
--- a/net-libs/grpc/Manifest
+++ b/net-libs/grpc/Manifest
@@ -2,4 +2,5 @@ DIST grpc-1.12.0.tar.gz 13692310 BLAKE2B 86b9063416140453718c51df4f238bb3d5ac854
DIST grpc-1.12.1.tar.gz 13692045 BLAKE2B d35706b553917d0f27e4474509f361ec7962b738031f11ca814d7ec33429f848b3b3356cae9a28b9a0cb376df5a6348d312c80ed4eeb51b81e68b317584a2e4a SHA512 9dd6d8c4b4e2713cf27ed55b1e97fdf5ed6d80f43b798b83f08e2f4646387dfd0696b21d4f44dbd99a061d388790dc15da49ac5afb0bb06116cfd6f07b7d6962
DIST grpc-1.13.0.tar.gz 13755973 BLAKE2B 533f0a7d4eb606b8a55f12aade503285dbff2cfa29ff2af71d407e3df25f3ec4b7572335c455d5dd0069eb343f18f8641a4f9326065cc118922942f77d2d2403 SHA512 25a489cd67d12219696c397afa75282eb702bd0af418381990b2eeb4b56483a46276d05314710582dd17be04c80aaf9bb16e01e2c1729d9a59d84ff273baa254
DIST grpc-1.13.1.tar.gz 13757818 BLAKE2B 9387efb980a0cff20c36d7653f24fb7982809428f7f35af0819786753d6cf380a581af81bde72f3682fcdfb3f41c71d628e5ef3b6b83663c8d3d182b4fdb6272 SHA512 f44028299d47865814ada2b8b93dc98dc51c8729bedc9c30dd79c04f6ecc3789ff06bbe7555e5d3512d9aec027751761ae10a80a09a94cf85bbd3260d651b356
+DIST grpc-1.14.2.tar.gz 13891112 BLAKE2B 2d8baa2d248fb9e319ac6f1a9cb1eb0c4f7ce20cfaa51254cb6d43db8d101fd4df03779b24e52a2cd00d7e14a415d928d51039c31cdde2c3272feee664861ea1 SHA512 1fca05a01fcae3bcaa8aeb57fb8e4a69d92d4d4d42e0612e9a7b3652a3f4e1b006a7559aea95cadae614479f4ac6ed14876b81fca0365967d246a5b7888a8385
DIST protobuf-3.5.2.tar.gz 4584659 BLAKE2B f582212169d802a5844574eb900c9f8cbb343b7e73f2074e5ff0bfc544ebd13f4bc2b78271fb70f4465d78fdc39972ed68339f453c0d3ffe98d8564fbf520544 SHA512 09d10cf0c07a0ba249428bbf20f5dbed840965fa06b3c09682f286a4dee9d84bb96f3b5b50e993d48ef1f20440531255ce7d0e60a648bf3fe536a5f2b0b74181
diff --git a/net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch b/net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch
new file mode 100644
index 000000000000..cb61b5f26fee
--- /dev/null
+++ b/net-libs/grpc/files/grpc-1.14.2-gcc8-fixes.patch
@@ -0,0 +1,83 @@
+From 9c7db45da9a6ddc5d65cd19704539579eb31d2ce Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Wed, 12 Sep 2018 10:35:45 -0700
+Subject: [PATCH] Fix failures with gcc-8
+
+Based on this PR https://github.com/grpc/grpc/pull/15443
+---
+ src/core/ext/filters/client_channel/client_channel.cc | 2 +-
+ .../client_channel/lb_policy/grpclb/load_balancer_api.cc | 3 ++-
+ src/core/ext/transport/chttp2/transport/flow_control.cc | 2 +-
+ src/core/lib/surface/channel.cc | 2 +-
+ src/core/tsi/alts_transport_security.cc | 2 +-
+ 5 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/src/core/ext/filters/client_channel/client_channel.cc b/src/core/ext/filters/client_channel/client_channel.cc
+index d2bf4f388d..503fb1ac87 100644
+--- a/src/core/ext/filters/client_channel/client_channel.cc
++++ b/src/core/ext/filters/client_channel/client_channel.cc
+@@ -457,7 +457,7 @@ get_service_config_from_resolver_result_locked(channel_data* chand) {
+ grpc_uri* uri = grpc_uri_parse(server_uri, true);
+ GPR_ASSERT(uri->path[0] != '\0');
+ service_config_parsing_state parsing_state;
+- memset(&parsing_state, 0, sizeof(parsing_state));
++ memset(reinterpret_cast<void *>(&parsing_state), 0, sizeof(parsing_state));
+ parsing_state.server_name =
+ uri->path[0] == '/' ? uri->path + 1 : uri->path;
+ service_config->ParseGlobalParams(parse_retry_throttle_params,
+diff --git a/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc b/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
+index f24281a5bf..74baf430f1 100644
+--- a/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
++++ b/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
+@@ -68,7 +68,8 @@ grpc_grpclb_request* grpc_grpclb_request_create(const char* lb_service_name) {
+ req->has_initial_request = true;
+ req->initial_request.has_name = true;
+ strncpy(req->initial_request.name, lb_service_name,
+- GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH);
++ GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH-1);
++ req->initial_request.name[GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH] = '\0';
+ return req;
+ }
+
+diff --git a/src/core/ext/transport/chttp2/transport/flow_control.cc b/src/core/ext/transport/chttp2/transport/flow_control.cc
+index 53932bcb7f..4b1862735d 100644
+--- a/src/core/ext/transport/chttp2/transport/flow_control.cc
++++ b/src/core/ext/transport/chttp2/transport/flow_control.cc
+@@ -190,7 +190,7 @@ TransportFlowControl::TransportFlowControl(const grpc_chttp2_transport* t,
+ uint32_t TransportFlowControl::MaybeSendUpdate(bool writing_anyway) {
+ FlowControlTrace trace("t updt sent", this, nullptr);
+ const uint32_t target_announced_window =
+- static_cast<const uint32_t>(target_window());
++ static_cast<uint32_t>(target_window());
+ if ((writing_anyway || announced_window_ <= target_announced_window / 2) &&
+ announced_window_ != target_announced_window) {
+ const uint32_t announce = static_cast<uint32_t> GPR_CLAMP(
+diff --git a/src/core/lib/surface/channel.cc b/src/core/lib/surface/channel.cc
+index 82635d3c21..f9d89657b3 100644
+--- a/src/core/lib/surface/channel.cc
++++ b/src/core/lib/surface/channel.cc
+@@ -100,7 +100,7 @@ grpc_channel* grpc_channel_create_with_builder(
+ return channel;
+ }
+
+- memset(channel, 0, sizeof(*channel));
++ memset(reinterpret_cast<void *>(channel), 0, sizeof(*channel));
+ channel->target = target;
+ channel->is_client = grpc_channel_stack_type_is_client(channel_stack_type);
+ size_t channel_tracer_max_nodes = 0; // default to off
+diff --git a/src/core/tsi/alts_transport_security.cc b/src/core/tsi/alts_transport_security.cc
+index 2fd408103b..51f9e9e85b 100644
+--- a/src/core/tsi/alts_transport_security.cc
++++ b/src/core/tsi/alts_transport_security.cc
+@@ -45,7 +45,7 @@ void grpc_tsi_alts_signal_for_cq_destroy() {
+ }
+
+ void grpc_tsi_alts_init() {
+- memset(&g_alts_resource, 0, sizeof(alts_shared_resource));
++ memset(reinterpret_cast<void *>(&g_alts_resource), 0, sizeof(alts_shared_resource));
+ gpr_mu_init(&g_alts_resource.mu);
+ gpr_cv_init(&g_alts_resource.cv);
+ }
+--
+2.18.0
+
diff --git a/net-libs/grpc/grpc-1.14.2.ebuild b/net-libs/grpc/grpc-1.14.2.ebuild
new file mode 100644
index 000000000000..f7ac68eea649
--- /dev/null
+++ b/net-libs/grpc/grpc-1.14.2.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 flag-o-matic toolchain-funcs
+
+# should match pinned git submodule version of third_party/protobuf
+# look it up here https://github.com/grpc/grpc/tree/v"${PV}"/third_party
+# also should >=depend on same version of dev-libs/protobuf below
+PROTOBUF_VERSION="3.5.2"
+
+DESCRIPTION="Modern open source high performance RPC framework"
+HOMEPAGE="http://www.grpc.io"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ tools? ( https://github.com/google/protobuf/archive/v${PROTOBUF_VERSION}.tar.gz -> protobuf-${PROTOBUF_VERSION}.tar.gz )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples doc python systemtap static-libs tools"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tools? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-libs/protobuf-${PROTOBUF_VERSION}:=
+ dev-util/google-perftools
+ net-dns/c-ares:=
+ sys-libs/zlib:=
+ python? ( ${PYTHON_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ tools? ( >=dev-python/protobuf-python-${PROTOBUF_VERSION}:=[${PYTHON_USEDEP}] )
+ )
+ systemtap? ( dev-util/systemtap )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ python? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-grpc-1.13.0-fix-host-ar-handling.patch"
+ "${FILESDIR}/0002-grpc-1.3.0-Fix-unsecure-.pc-files.patch"
+ "${FILESDIR}/0003-grpc-1.3.0-Don-t-run-ldconfig.patch"
+ "${FILESDIR}/0004-grpc-1.11.0-fix-cpp-so-version.patch"
+ "${FILESDIR}/0005-grpc-1.11.0-pkgconfig-libdir.patch"
+ "${FILESDIR}/grpc-1.14.2-gcc8-fixes.patch"
+)
+
+src_prepare() {
+ sed -i 's@$(prefix)/lib@$(prefix)/$(INSTALL_LIBDIR)@g' Makefile || die "fix libdir"
+ default
+ use python && distutils-r1_src_prepare
+}
+
+python_prepare() {
+ if use tools; then
+ rm -r third_party/protobuf || die "removing empty protobuf dir failed"
+ ln -s "${S}"/../protobuf-"${PROTOBUF_VERSION}" third_party/protobuf || die
+ pushd tools/distrib/python/grpcio_tools >/dev/null || die
+ # absolute symlinks will fail
+ # ./src -> ${S}/src
+ ln -s ../../../../src ./ || die
+ # ./third_party -> ${S}/third_party
+ ln -s ../../../../third_party ./ || die
+ # ./grpc_root -> ${S}
+ ln -s ../../../../ ./grpc_root || die
+ # prevent above symlinks creating huge SOURCES.TXT files, bug #661244
+ echo "prune grpc_root/tools/distrib/python/grpcio_tools" >> MANIFEST.in
+ popd >/dev/null || die
+ fi
+}
+
+src_compile() {
+ tc-export CC CXX PKG_CONFIG
+
+ emake \
+ V=1 \
+ prefix=/usr \
+ INSTALL_LIBDIR="$(get_libdir)" \
+ AR="$(tc-getAR)" \
+ AROPTS="rcs" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LD="${CC}" \
+ LDXX="${CXX}" \
+ STRIP=/bin/true \
+ HOST_CC="$(tc-getBUILD_CC)" \
+ HOST_CXX="$(tc-getBUILD_CXX)" \
+ HOST_LD="$(tc-getBUILD_CC)" \
+ HOST_LDXX="$(tc-getBUILD_CXX)" \
+ HOST_AR="$(tc-getBUILD_AR)" \
+ HAS_SYSTEMTAP="$(usex systemtap true false)"
+
+ use python && distutils-r1_src_compile
+}
+
+python_compile() {
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ distutils-r1_python_compile
+
+ if use tools; then
+ pushd tools/distrib/python/grpcio_tools >/dev/null || die
+ distutils-r1_python_compile
+ popd >/dev/null || die
+ fi
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py doc
+ mv doc/build doc/html || die
+ fi
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ INSTALL_LIBDIR="$(get_libdir)" \
+ STRIP=/bin/true \
+ install
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+
+ if use examples; then
+ find examples -name '.gitignore' -delete || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ # only define DOCS array if requested, otherwise portage default is fine
+ if use doc; then
+ find doc -name '.gitignore' -delete || die
+ local DOCS=( AUTHORS README.md TROUBLESHOOTING.md doc/. )
+ fi
+
+ einstalldocs
+
+ use python && distutils-r1_src_install
+
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if use tools; then
+ pushd tools/distrib/python/grpcio_tools >/dev/null || die
+ distutils-r1_python_install
+ popd >/dev/null || die
+ fi
+}