summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 21:27:07 +0000
committerSam James <sam@gentoo.org>2020-09-15 21:46:12 +0000
commit6d9fc682eff90b90fcbe5363d71b16d7564e661f (patch)
tree000a220a21e6c8e17ddc2521bb78c635c5f63e75 /net-libs
parentnet-misc/gsasl: bump to EAPI 7 (diff)
downloadgentoo-6d9fc682eff90b90fcbe5363d71b16d7564e661f.tar.gz
gentoo-6d9fc682eff90b90fcbe5363d71b16d7564e661f.tar.bz2
gentoo-6d9fc682eff90b90fcbe5363d71b16d7564e661f.zip
net-libs/libgsasl: bump to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgsasl/files/libgsasl-1.8.0-gss-extra.patch (renamed from net-libs/libgsasl/files/libgsasl-gss-extra.patch)0
-rw-r--r--net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild24
2 files changed, 17 insertions, 7 deletions
diff --git a/net-libs/libgsasl/files/libgsasl-gss-extra.patch b/net-libs/libgsasl/files/libgsasl-1.8.0-gss-extra.patch
index e9ec10d183c4..e9ec10d183c4 100644
--- a/net-libs/libgsasl/files/libgsasl-gss-extra.patch
+++ b/net-libs/libgsasl/files/libgsasl-1.8.0-gss-extra.patch
diff --git a/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild b/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
index 5b146866adc3..7550115ea3ff 100644
--- a/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
+++ b/net-libs/libgsasl/libgsasl-1.8.0-r1.ebuild
@@ -1,20 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="The GNU SASL library"
HOMEPAGE="https://www.gnu.org/software/gsasl/"
SRC_URI="mirror://gnu/${PN/lib}/${P}.tar.gz"
+
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="idn gcrypt kerberos nls ntlm static-libs"
+
DEPEND="
- gcrypt? ( dev-libs/libgcrypt:0 )
- idn? ( net-dns/libidn )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ idn? ( net-dns/libidn:= )
kerberos? ( virtual/krb5 )
nls? ( >=sys-devel/gettext-0.18.1 )
ntlm? ( net-libs/libntlm )
@@ -23,11 +25,12 @@ RDEPEND="${DEPEND}
!net-misc/gsasl"
PATCHES=(
- "${FILESDIR}/${PN}-gss-extra.patch"
+ "${FILESDIR}/${PN}-1.8.0-gss-extra.patch"
)
src_prepare() {
default
+
sed -i -e 's/ -Werror//' configure.ac || die
eautoreconf
}
@@ -36,8 +39,14 @@ src_configure() {
local krb5_impl
if use kerberos; then
krb5_impl="--with-gssapi-impl="
- krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
+ # These are the two providers of virtual/krb5
+ if has_version app-crypt/mit-krb5; then
+ krb5_impl+="mit"
+ else
+ krb5_impl+="heimdal"
+ fi
fi
+
local myeconfargs=(
$(use_with gcrypt libgcrypt)
$(use_with idn stringprep)
@@ -47,6 +56,7 @@ src_configure() {
$(use_enable ntlm)
$(use_enable static-libs static)
)
+
econf "${myeconfargs[@]}"
}
@@ -54,6 +64,6 @@ src_install() {
default
if ! use static-libs; then
- rm -f "${D}"/usr/lib*/lib*.la
+ rm -f "${ED}"/usr/lib*/lib*.la || die
fi
}