summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-03-27 09:38:30 -0400
committerCraig Andrews <candrews@gentoo.org>2023-03-27 09:38:30 -0400
commit73a10013f50891535302182ddb73f8fbb0861abe (patch)
treee8b54518ece1b74e68bd356149b2082f912a97a0 /net-libs
parentnet-libs/ngtcp2: drop 0.13.1 (diff)
downloadgentoo-73a10013f50891535302182ddb73f8fbb0861abe.tar.gz
gentoo-73a10013f50891535302182ddb73f8fbb0861abe.tar.bz2
gentoo-73a10013f50891535302182ddb73f8fbb0861abe.zip
net-libs/nghttp3: add 0.10.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-0.10.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index d1664e675897..0ab735f72fa7 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,2 +1,3 @@
+DIST nghttp3-0.10.0.tar.xz 367700 BLAKE2B 9f2a68d245d5b09eea3eeee1a3dd88fd1a88d44bb33e2d69fbf44d3e7a7edbd24de28ca974a64ee5351338cb790de2a6f6dba38a520a64196ec85264eebafbd3 SHA512 8854bb213c5ef5907260b087e192847d6a0be7421207092497842cf014026426f2e184ae2a1d5575774592d7e29dcbd509d06eff54c52b9aa7451d33b23a3270
DIST nghttp3-0.8.0.tar.xz 365072 BLAKE2B 132332f785f015a5e62e751ad6fe6d1dae49911837ef26cb24453245ca2cd5a80c92092db4b712f1fb515caa900ac190c2fa586fbf7314df9e60928595791679 SHA512 dab545aff7f85ee10c0f43985cb7f937e33a793c4bb0ca8e7878652f8d0b2500497cdd435256f401bf35a0c7af21aec08cd821beddff3e96b4810efb4c798591
DIST nghttp3-0.9.0.tar.xz 365884 BLAKE2B 92365e268d7644154f9a400ff0de9e153bdc4acad3a23d2c70936dc4c1105edb2866b81aaad35806ab25992f22501afdb7ddf5d41fa17963183e92c2548c72cb SHA512 68b57f62128dca0d4ced1c63c2c8cdda65a62fdca7bacc2aa3e8826863dad8c7e0d6d715df2bcb09da737fad8ae24c9365e01c07e066d6fd33f4b94190d252ed
diff --git a/net-libs/nghttp3/nghttp3-0.10.0.ebuild b/net-libs/nghttp3/nghttp3-0.10.0.ebuild
new file mode 100644
index 000000000000..719966f4eab6
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}