summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-09 19:49:30 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-09 19:49:30 +0100
commitc1380ebd1a7e6545a9c870ccbdb490719158d832 (patch)
treeaa169b67bcee9f6a94af17a1d55198692552a9ae /net-libs
parentnet-libs/sofia-sip: Port to EAPI 7 (diff)
downloadgentoo-c1380ebd1a7e6545a9c870ccbdb490719158d832.tar.gz
gentoo-c1380ebd1a7e6545a9c870ccbdb490719158d832.tar.bz2
gentoo-c1380ebd1a7e6545a9c870ccbdb490719158d832.zip
net-libs/libnfnetlink: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
index 7f4eb46d560e..26088b852aa0 100644
--- a/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
+++ b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit linux-info eutils
+EAPI=7
+
+inherit linux-info
-DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
-HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
PATCH_BLOB=04aef8a4dedf267dd5744afb134ef8046e77f613
PATCH_FN=${PATCH_BLOB}-musl-fix-includes.patch
-SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2
- https://git.alpinelinux.org/cgit/aports/plain/main/libnfnetlink/musl-fix-includes.patch -> ${PATCH_FN}"
+
+DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
+HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
+SRC_URI="
+ http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2
+ https://git.alpinelinux.org/cgit/aports/plain/main/libnfnetlink/musl-fix-includes.patch -> ${PATCH_FN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
-IUSE="static-libs"
-DOCS=( README )
PATCHES=( "${DISTDIR}/${PATCH_FN}" )
-src_prepare() {
- epatch "${PATCHES[@]}"
-}
-
pkg_setup() {
linux-info_pkg_setup
@@ -44,10 +41,12 @@ pkg_setup() {
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf --disable-static
}
src_install() {
default
- prune_libtool_files
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}