summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-29 14:17:57 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-29 14:41:36 +0200
commitc4d523a1814e9f8aa9ef5be0080288eabb85ea01 (patch)
tree09b1b13d06ba26394de8bdb9c9afa033e99c2996 /net-libs
parentmedia-gfx/gphoto2: Version bump (diff)
downloadgentoo-c4d523a1814e9f8aa9ef5be0080288eabb85ea01.tar.gz
gentoo-c4d523a1814e9f8aa9ef5be0080288eabb85ea01.tar.bz2
gentoo-c4d523a1814e9f8aa9ef5be0080288eabb85ea01.zip
net-libs/farstream: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/farstream/Manifest1
-rw-r--r--net-libs/farstream/farstream-0.2.8.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-libs/farstream/Manifest b/net-libs/farstream/Manifest
index e0a26e7dd3f4..a9f35b031957 100644
--- a/net-libs/farstream/Manifest
+++ b/net-libs/farstream/Manifest
@@ -1,2 +1,3 @@
DIST farstream-0.1.2.tar.gz 1265972 SHA256 fa5a40597b47b59d124f7fd57f66704b030d576cdc0d90e107c7a592f05e73d9 SHA512 7d9ddde5d17205752a17298fb90cf855a828b2ae58746fbdc7e47749cee5e5eac4fd56f97f58251a5d253901cdd555e9cfade6016b6d92df99daefbe850e2910 WHIRLPOOL 273d20082152ff09adf8e64481b1b7c7ba7e6a24fc09addc219880fbee7f1e6b9845ce727c032fa3c364e8d2440736fd0324015426591b7e9766f11054828294
DIST farstream-0.2.7.tar.gz 1309470 SHA256 dad0ed43cf94e71df558c23825abe57db59d1ee8d970ffaec5e2dbc2e7acbf7d SHA512 98c72eb9045bf7d0ee7d38fc1d7eea0b8ad942fc39843df075bf6f61bc0bed619aafb36ae08d55a6e61265bd47137ec75ffbfc2846c7cbcb4cbef187844426d8 WHIRLPOOL 515901c25aab04c5c7ae91a96285e36095844d730cf38e4f4f9aabfaeb7ed09a0a4ba5eddbfcb1b7c8ff52ed7f7f16cb7a7a2814d29953d8d5097bb06dd95abc
+DIST farstream-0.2.8.tar.gz 1315548 SHA256 2b3b9c6b4f64ace8c83e03d1da5c5a2884c1cae10b35471072b574201ab38908 SHA512 7ec5c57f8778f4107cb628dbf411e38b726152cf78920127dff4423239ff7e4980b6b4f938abba2aa21ab984b1e3053e7e648611322a0ce94df0af576df99a7e WHIRLPOOL 70772016e9c6fcdf64dc2ec32cafe074ef7fa193cae7114625ab0c2501fcdd1f8eccc4e98a31bb0d69ee58047602951259970797183d5dba065f28fe920dbf71
diff --git a/net-libs/farstream/farstream-0.2.8.ebuild b/net-libs/farstream/farstream-0.2.8.ebuild
new file mode 100644
index 000000000000..c5b84a995283
--- /dev/null
+++ b/net-libs/farstream/farstream-0.2.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="https://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection test upnp"
+SLOT="0.2/5" # .so version
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-1.4:1.0
+ >=media-libs/gst-plugins-base-1.4:1.0
+ >=dev-libs/glib-2.32:2
+ >=net-libs/libnice-0.1.8
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11:= )
+ upnp? ( >=net-libs/gupnp-igd-0.2:= )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-1.4:1.0
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ media-plugins/gst-plugins-libnice:1.0
+"
+DEPEND="${COMMONDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.18
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-base:1.0[vorbis]
+ media-libs/gst-plugins-good:1.0 )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #539224
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}