summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-12 15:25:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-12 15:34:39 +0200
commite3cd027b947f515127d4af43fd3ce602699f8068 (patch)
tree32e6e3efd43e406c3bd9a41fbbeacf597efc510d /net-libs
parentnet-libs/ignition-transport: bump to 8.1.0 (diff)
downloadgentoo-e3cd027b947f515127d4af43fd3ce602699f8068.tar.gz
gentoo-e3cd027b947f515127d4af43fd3ce602699f8068.tar.bz2
gentoo-e3cd027b947f515127d4af43fd3ce602699f8068.zip
net-libs/ignition-transport: rm unneeded patch
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ignition-transport/files/zmq.patch31
-rw-r--r--net-libs/ignition-transport/ignition-transport-8.1.0.ebuild1
2 files changed, 0 insertions, 32 deletions
diff --git a/net-libs/ignition-transport/files/zmq.patch b/net-libs/ignition-transport/files/zmq.patch
deleted file mode 100644
index ddbf8f113064..000000000000
--- a/net-libs/ignition-transport/files/zmq.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: ignition-transport4-4.0.0/src/NodeShared.cc
-===================================================================
---- ignition-transport4-4.0.0.orig/src/NodeShared.cc
-+++ ignition-transport4-4.0.0/src/NodeShared.cc
-@@ -92,7 +92,8 @@ bool userPass(std::string &_user, std::s
- // Helper to send messages
- int sendHelper(zmq::socket_t &_pub, const std::string &_data, int _type)
- {
-- zmq::message_t msg(_data.data(), _data.size());
-+ zmq::message_t msg(_data.size());
-+ memcpy(msg.data(), _data.data(), _data.size());
- return _pub.send(msg, _type);
- }
-
-@@ -278,10 +279,13 @@ bool NodeShared::Publish(
- {
- // Create the messages.
- // Note that we use zero copy for passing the message data (msg2).
-- zmq::message_t msg0(_topic.data(), _topic.size()),
-- msg1(this->myAddress.data(), this->myAddress.size()),
-+ zmq::message_t msg0(_topic.size()),
-+ msg1(this->myAddress.size()),
- msg2(_data, _dataSize, _ffn, nullptr),
-- msg3(_msgType.data(), _msgType.size());
-+ msg3(_msgType.size());
-+ memcpy(msg0.data(), _topic.data(), _topic.size());
-+ memcpy(msg1.data(), this->myAddress.data(), this->myAddress.size());
-+ memcpy(msg3.data(), _msgType.data(), _msgType.size());
-
- // Send the messages
- std::lock_guard<std::recursive_mutex> lock(this->mutex);
diff --git a/net-libs/ignition-transport/ignition-transport-8.1.0.ebuild b/net-libs/ignition-transport/ignition-transport-8.1.0.ebuild
index e97e11283c41..22dfd215af7e 100644
--- a/net-libs/ignition-transport/ignition-transport-8.1.0.ebuild
+++ b/net-libs/ignition-transport/ignition-transport-8.1.0.ebuild
@@ -30,4 +30,3 @@ BDEPEND="
virtual/pkgconfig"
CMAKE_BUILD_TYPE=RelWithDebInfo
S="${WORKDIR}/ign-transport-${PN}8_${PV}"
-PATCHES=( "${FILESDIR}/zmq.patch" )