summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-03 14:53:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-03 15:00:58 +0100
commitee9f45ac28c6ca69c972704b4d8eb850e81d15b3 (patch)
treea715eb59d3ac7221ae3dd78c05cf456569fb15f1 /net-libs
parentnet-libs/qxmpp: Simplify src_configure (diff)
downloadgentoo-ee9f45ac28c6ca69c972704b4d8eb850e81d15b3.tar.gz
gentoo-ee9f45ac28c6ca69c972704b4d8eb850e81d15b3.tar.bz2
gentoo-ee9f45ac28c6ca69c972704b4d8eb850e81d15b3.zip
net-libs/qxmpp: Disable failing test
Also cleanup src_prepare. Maintainer timeout. Closes: https://bugs.gentoo.org/623708 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild22
-rw-r--r--net-libs/qxmpp/qxmpp-9999.ebuild22
2 files changed, 26 insertions, 18 deletions
diff --git a/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild b/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
index c8b090dafc18..a8bd6e94ae7d 100644
--- a/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
+++ b/net-libs/qxmpp/qxmpp-0.9.3-r1.ebuild
@@ -27,21 +27,25 @@ DEPEND="${RDEPEND}
test? ( dev-qt/qttest:5 )
"
-src_prepare(){
+src_prepare() {
+ default
+
if ! use doc; then
- sed -i \
- -e '/SUBDIRS/s/doc//' \
+ sed -e '/SUBDIRS/s/doc//' \
-e '/INSTALLS/d' \
- qxmpp.pro || die "sed for removing docs failed"
+ -i qxmpp.pro || die "failed to remove docs"
fi
if ! use test; then
- sed -i -e '/SUBDIRS/s/tests//' \
- qxmpp.pro || die "sed for removing tests failed"
+ sed -e '/SUBDIRS/s/tests//' \
+ -i qxmpp.pro || die "failed to remove tests"
+ else
+ # requires network connection, bug #623708
+ sed -e "/qxmppiceconnection/d" \
+ -i tests/tests.pro || die "failed to drop single test"
fi
# There is no point in building examples. Also, they require dev-qt/qtgui
- sed -i -e '/SUBDIRS/s/examples//' \
- qxmpp.pro || die "sed for removing examples failed"
- default_src_prepare
+ sed -e '/SUBDIRS/s/examples//' \
+ -i qxmpp.pro || die "sed for removing examples failed"
}
src_configure() {
diff --git a/net-libs/qxmpp/qxmpp-9999.ebuild b/net-libs/qxmpp/qxmpp-9999.ebuild
index d9226e906b66..fc67feb3c99a 100644
--- a/net-libs/qxmpp/qxmpp-9999.ebuild
+++ b/net-libs/qxmpp/qxmpp-9999.ebuild
@@ -28,21 +28,25 @@ DEPEND="${RDEPEND}
test? ( dev-qt/qttest:5 )
"
-src_prepare(){
+src_prepare() {
+ default
+
if ! use doc; then
- sed -i \
- -e '/SUBDIRS/s/doc//' \
+ sed -e '/SUBDIRS/s/doc//' \
-e '/INSTALLS/d' \
- qxmpp.pro || die "sed for removing docs failed"
+ -i qxmpp.pro || die "failed to remove docs"
fi
if ! use test; then
- sed -i -e '/SUBDIRS/s/tests//' \
- qxmpp.pro || die "sed for removing tests failed"
+ sed -e '/SUBDIRS/s/tests//' \
+ -i qxmpp.pro || die "failed to remove tests"
+ else
+ # requires network connection, bug #623708
+ sed -e "/qxmppiceconnection/d" \
+ -i tests/tests.pro || die "failed to drop single test"
fi
# There is no point in building examples. Also, they require dev-qt/qtgui
- sed -i -e '/SUBDIRS/s/examples//' \
- qxmpp.pro || die "sed for removing examples failed"
- default_src_prepare
+ sed -e '/SUBDIRS/s/examples//' \
+ -i qxmpp.pro || die "sed for removing examples failed"
}
src_configure() {