summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-10 15:09:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-10 15:10:46 +0100
commitf6d0dc0542aebcc1ea0a31005060c55496014d4b (patch)
tree47ead355c5d3bbd90bc9303eab8cbff3d567b612 /net-libs
parentapp-admin/terraform: cleanup old version 0.11.11 (diff)
downloadgentoo-f6d0dc0542aebcc1ea0a31005060c55496014d4b.tar.gz
gentoo-f6d0dc0542aebcc1ea0a31005060c55496014d4b.tar.bz2
gentoo-f6d0dc0542aebcc1ea0a31005060c55496014d4b.zip
net-libs/nghttp2: Bump to version 1.37.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.37.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index cae2f0177e94..f53a5d8f91d8 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,3 +1,4 @@
DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270bc3079972885a1f707a9cc4ebb053f7347930ce217d2cf4277eab0a3309accb8f9ff18bd8ccc55c86aefa6246c3 SHA512 eeb0bf64fea115444c685c8a01c1017ce96be18adf88ffcdecad067de7012ca61c6b2b6a627b18e2572bba7bd77ec56a3ca4b1109f7a4b21220e8e28687b5b74
DIST nghttp2-1.35.1.tar.xz 1614460 BLAKE2B 86e078cd0fc285f76df5096c34ee3142268772cf690ec7c9abef7cc3d873ac583a1da5e331ec46138e05b5867f56a9a4e98210395d75377ff37956307c7b049f SHA512 fcd3f79f913afbeee1c75003bb39df918e6122bbf728b3ad4192d5849d8fb96705e04f5505465d63f25a565b2f1da6abd8fabdebb6e3347500f7abd31980861d
DIST nghttp2-1.36.0.tar.xz 1629020 BLAKE2B 7c116988c22801688c50d6d514ddb904920cc54d3c3d141137e6ed8b2182ef4e670f0a0fdebaeabfe0df8cdea4cfd1ee3fb083628f035201f104de6f3614dd25 SHA512 4e0d5c5cdb4f1b7e5f12790850237f36649af4aa9596033392725972e4e0e5a33bb78bd1aa0735e35e489b523b7e9a236a7b5847dfca69bd7583fcab36c13c76
+DIST nghttp2-1.37.0.tar.xz 1628248 BLAKE2B ed5cdfda44b4e38a03d92352520eb765cc1da99080e0cd3e9d663efd5ef2ff219c6ccdbc16cfde001a8377afc796acef250913e1eb422ae2cac2eb95b8f98089 SHA512 67a4b9df3f7f0edad719011fa289d9aa9ef04f31ef3ccf826b861c8830ed24e0743a33b54ab66d198fec7edbf723852b38a2007b335d7f566f702f4b02297b0f
diff --git a/net-libs/nghttp2/nghttp2-1.37.0.ebuild b/net-libs/nghttp2/nghttp2-1.37.0.ebuild
new file mode 100644
index 000000000000..20f89187f0fb
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.37.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}