summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-01 08:08:35 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-01 08:08:35 +0100
commitf7a2c4a647ebed76a49f3c68942763d767999b55 (patch)
tree23903b62d89e96fdbe74af6879cf64f906e3ec83 /net-libs
parentdev-python/yarl: keyworded 1.4.2 for ia64 (diff)
downloadgentoo-f7a2c4a647ebed76a49f3c68942763d767999b55.tar.gz
gentoo-f7a2c4a647ebed76a49f3c68942763d767999b55.tar.bz2
gentoo-f7a2c4a647ebed76a49f3c68942763d767999b55.zip
net-libs/libbloom: respect user's AR
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/721238 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libbloom/files/libbloom-1.5-AR.patch11
-rw-r--r--net-libs/libbloom/libbloom-1.5-r2.ebuild30
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/libbloom/files/libbloom-1.5-AR.patch b/net-libs/libbloom/files/libbloom-1.5-AR.patch
new file mode 100644
index 000000000000..5a1b14d76b0c
--- /dev/null
+++ b/net-libs/libbloom/files/libbloom-1.5-AR.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -97,7 +97,7 @@ $(BUILD)/$(SO_VERSIONED): $(BUILD)/murmurhash2.o $(BUILD)/bloom.o
+ rm -f libbloom.$(SO) && ln -s $(BLOOM_SONAME) libbloom.$(SO))
+
+ $(BUILD)/libbloom.a: $(BUILD)/murmurhash2.o $(BUILD)/bloom.o
+- (cd $(BUILD) && ar rcs libbloom.a bloom.o murmurhash2.o)
++ (cd $(BUILD) && $(AR) rcs libbloom.a bloom.o murmurhash2.o)
+
+ $(BUILD)/test-libbloom: $(TESTDIR)/test.c $(BUILD)/$(SO_VERSIONED)
+ $(COM) -I$(TOP) -c $(TESTDIR)/test.c -o $(BUILD)/test.o
diff --git a/net-libs/libbloom/libbloom-1.5-r2.ebuild b/net-libs/libbloom/libbloom-1.5-r2.ebuild
new file mode 100644
index 000000000000..9be6bd8a03a9
--- /dev/null
+++ b/net-libs/libbloom/libbloom-1.5-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple and small bloom filter implementation in plain C."
+HOMEPAGE="https://github.com/jvirkki/libbloom"
+SRC_URI="https://github.com/jvirkki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=("${FILESDIR}"/${PN}-1.5-AR.patch)
+
+src_compile() {
+ tc-export AR CC
+ emake BITS=default OPT=
+}
+
+src_install() {
+ doheader bloom.h
+ dolib.so build/${PN}.so*
+}