summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-18 21:54:02 +0000
committerSam James <sam@gentoo.org>2023-03-18 21:54:38 +0000
commitc56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3 (patch)
treef6eccbe2435e7e3649c461a4de7f893bebf2e8af /net-mail/fdm/fdm-2.2-r1.ebuild
parentnet-mail/fdm: drop 2.0-r1, 2.1 (diff)
downloadgentoo-c56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3.tar.gz
gentoo-c56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3.tar.bz2
gentoo-c56bfb9f4f4b728f0d9e47f1aac0be355ad5e1b3.zip
net-mail/fdm: fix configure w/ clang 16, fix strlcpy check
Closes: https://bugs.gentoo.org/731262 Thanks-to: Markus Peloquin <markus@cs.wisc.edu> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/fdm/fdm-2.2-r1.ebuild')
-rw-r--r--net-mail/fdm/fdm-2.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/fdm/fdm-2.2-r1.ebuild b/net-mail/fdm/fdm-2.2-r1.ebuild
new file mode 100644
index 000000000000..cac36667dc18
--- /dev/null
+++ b/net-mail/fdm/fdm-2.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Fetch, filter and deliver mail"
+HOMEPAGE="https://github.com/nicm/fdm"
+SRC_URI="https://github.com/nicm/fdm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="examples pcre"
+
+DEPEND="
+ dev-libs/openssl:=
+ sys-libs/tdb
+ pcre? ( dev-libs/libpcre2 )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/fdm
+ acct-user/fdm
+"
+
+DOCS=( CHANGES README TODO MANUAL )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-configure-strlcpy.patch
+)
+
+src_prepare() {
+ default
+
+ # Change user '_fdm' to 'fdm'
+ sed -e 's/_fdm/fdm/g' -i fdm.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable pcre pcre2)
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}