summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-02 00:58:43 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-02-02 00:59:02 -0500
commitaccea94b09cc78b46e73e566ff6fff6cfeae530b (patch)
tree893baa6e98f98ec609043e66d3991182b426880a /net-mail/mailbox-count
parentmedia-video/cheese: bump 3.34.0 (diff)
downloadgentoo-accea94b09cc78b46e73e566ff6fff6cfeae530b.tar.gz
gentoo-accea94b09cc78b46e73e566ff6fff6cfeae530b.tar.bz2
gentoo-accea94b09cc78b46e73e566ff6fff6cfeae530b.zip
net-mail/mailbox-count: new version 0.0.3.
This new version attempts to support both the ghc-7.10.1 and ghc-8.x compilers. The newer GHCs require monoid instances to be semigroups, but the semigroups package wasn't bundled with the GHC until then. However, requiring a "redundant" semigroups package seems to not hurt, and should theoretically fix the build with ghc-7.10.1 as well. Bug: https://bugs.gentoo.org/707836 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail/mailbox-count')
-rw-r--r--net-mail/mailbox-count/Manifest2
-rw-r--r--net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch24
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild40
-rw-r--r--net-mail/mailbox-count/mailbox-count-0.0.3.ebuild (renamed from net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild)29
4 files changed, 18 insertions, 77 deletions
diff --git a/net-mail/mailbox-count/Manifest b/net-mail/mailbox-count/Manifest
index f539e1520f1c..6a336c7338f9 100644
--- a/net-mail/mailbox-count/Manifest
+++ b/net-mail/mailbox-count/Manifest
@@ -1 +1 @@
-DIST mailbox-count-0.0.2.tar.gz 20644 BLAKE2B 036d118f9c23d42e21de06405d2703e97017f35d618a90e77561d604441092b543a8ba03b50dee5a7c2a48c2b8c0d6e87c06c2338853d9c508de7b6ea9d86006 SHA512 98e39927382719295260c64bd5888244000dbbb3fbd7f6405dcffe78a4fc5f1dea7f8236542e58eb0118bb421c19225a8be0560b92c7688c0701418c7221d569
+DIST mailbox-count-0.0.3.tar.gz 21358 BLAKE2B f56030876321251637d4d41246ccec767edbc71cbd9547a403a8fab2c4b7fbffbef74205faed5dba6e9f2047a7dd85a82301dae52106b18b19f63daf8d66c478 SHA512 24d79cd122c3c34b61f5f0234f8a6e55c04f9f7ff74d1fb589c3aa7af2e5fb2df7c02960b6cf4fd743edc006214bb788ea9059361f5614c2a47543dbbe8790b4
diff --git a/net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch b/net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch
deleted file mode 100644
index 5257a10a3ac3..000000000000
--- a/net-mail/mailbox-count/files/mailbox-count-0.0.2-ghc84.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/src/OptionalConfiguration.hs
-+++ b/src/OptionalConfiguration.hs
-@@ -27,3 +27,3 @@ import System.FilePath ( (</>) )
- import System.IO.Error ( catchIOError )
--
-+import qualified Data.Semigroup as S
-
-@@ -65,2 +65,16 @@ merge_maybes (Just _) (Just y) = Just y
- --
-+
-+instance S.Semigroup OptionalConfiguration where
-+ -- | Combine @cfg1@ and @cfg2@, giving precedence to @cfg2@.
-+ cfg1 <> cfg2 =
-+ OptionalConfiguration
-+ (merge_maybes (database cfg1) (database cfg2))
-+ (merge_maybes (detail cfg1) (detail cfg2))
-+ (merge_maybes (detail_query cfg1) (detail_query cfg2))
-+ (merge_maybes (host cfg1) (host cfg2))
-+ (merge_maybes (password cfg1) (password cfg2))
-+ (merge_maybes (port cfg1) (port cfg2))
-+ (merge_maybes (summary_query cfg1) (summary_query cfg2))
-+ (merge_maybes (username cfg1) (username cfg2))
-+
- instance Monoid OptionalConfiguration where
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild
deleted file mode 100644
index 275709ed0d99..000000000000
--- a/net-mail/mailbox-count/mailbox-count-0.0.2-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.4.2
-
-CABAL_FEATURES="bin test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Count mailboxes in a SQL database"
-HOMEPAGE="http://hackage.haskell.org/package/mailbox-count"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # Could not find module ‘Paths_mailbox_count’
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.16.0
- >=dev-haskell/cmdargs-0.10
- >=dev-haskell/configurator-0.2
- >=dev-haskell/hdbc-2.4
- >=dev-haskell/hdbc-postgresql-2.3
- >=dev-haskell/hdbc-sqlite3-2.3
- >=dev-haskell/missingh-1.2
- >=dev-haskell/tasty-0.8
- >=dev-haskell/tasty-hunit-0.8
- >=dev-lang/ghc-7.6.1
- test? ( >=dev-haskell/doctest-0.9
- >=dev-haskell/filemanip-0.3.6 )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ghc84.patch
-)
diff --git a/net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild b/net-mail/mailbox-count/mailbox-count-0.0.3.ebuild
index 737684cfbc1f..1da9929cd889 100644
--- a/net-mail/mailbox-count/mailbox-count-0.0.2-r1.ebuild
+++ b/net-mail/mailbox-count/mailbox-count-0.0.3.ebuild
@@ -1,34 +1,39 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# ebuild generated by hackport 0.4.2
-
-CABAL_FEATURES="bin test-suite"
+CABAL_FEATURES="test-suite"
inherit haskell-cabal
DESCRIPTION="Count mailboxes in a SQL database"
HOMEPAGE="http://hackage.haskell.org/package/mailbox-count"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.16.0
+RDEPEND="
>=dev-haskell/cmdargs-0.10
>=dev-haskell/configurator-0.2
>=dev-haskell/hdbc-2.4
>=dev-haskell/hdbc-postgresql-2.3
>=dev-haskell/hdbc-sqlite3-2.3
>=dev-haskell/missingh-1.2
+ >=dev-haskell/semigroups-0.18
>=dev-haskell/tasty-0.8
>=dev-haskell/tasty-hunit-0.8
- >=dev-lang/ghc-7.6.1
- test? ( >=dev-haskell/doctest-0.9
- >=dev-haskell/filemanip-0.3.6 )
+ >=dev-lang/ghc-7.10.1
"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.9
+ >=dev-haskell/filemanip-0.3.6 )"
+
+src_install() {
+ haskell-cabal_src_install
+ dodoc "${S}/doc/${PN}rc.example"
+ doman "${S}/doc/man1/${PN}.1"
+}