summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/mu/mu-0.9.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/mu/mu-0.9.9.ebuild')
-rw-r--r--net-mail/mu/mu-0.9.9.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/net-mail/mu/mu-0.9.9.ebuild b/net-mail/mu/mu-0.9.9.ebuild
new file mode 100644
index 000000000000..2705a19cb82b
--- /dev/null
+++ b/net-mail/mu/mu-0.9.9.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/"
+SRC_URI="http://mu0.googlecode.com/files/${P}.tar.gz
+ doc? ( http://mu0.googlecode.com/files/mu4e-manual-${PV}.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc emacs gui"
+
+# Without webkit-gtk there is no pdf-preview functionality, everything
+# else works as of 0.9.8.5
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+DEPEND="
+ dev-libs/gmime:2.6
+ dev-libs/xapian
+ dev-libs/glib:2
+ gui? (
+ x11-libs/gtk+:3
+ net-libs/webkit-gtk:3 )
+ emacs? ( >=virtual/emacs-23 )
+ !net-mail/mailutils"
+RDEPEND="${DEPEND}"
+
+SITEFILE="70mu-gentoo.el"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc ; then
+ cp "${DISTDIR}"/mu4e-manual-${PV}.pdf "${S}" || die
+ fi
+}
+
+src_configure() {
+ local guiconf
+ if use gui; then
+ guiconf="--with-gui=gtk3"
+ else
+ guiconf="--with-gui=none"
+ fi
+
+ # Todo: Make a guile USE-flag as soon as >=guile-2 is avaiable
+ # Note: --disable-silent-rules is included in EAPI-5
+ econf --disable-guile \
+ --disable-silent-rules \
+ $(use_enable gui webkit) \
+ $(use_enable emacs mu4e) \
+ ${guiconf}
+}
+
+src_install () {
+ base_src_install
+ # Installing the guis is not supported by upstream
+ if use gui; then
+ dobin toys/mug/mug || die
+ fi
+ dodoc AUTHORS HACKING NEWS TODO README ChangeLog INSTALL
+ if use doc; then
+ dodoc mu4e-manual-${PV}.pdf
+ fi
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+src_test () {
+ emake check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/Getting-started.html"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}