summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-21 12:22:41 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-21 12:26:49 +0100
commit46f58b50d48de2d1d751ae1a3e6111cc0d8e0887 (patch)
tree3d1f0ae78152e49c658b9407bbdf1dbffc093a0a /net-mail/notmuch
parentsci-mathematics/singular: Remove call to deprecated elisp-need-emacs. (diff)
downloadgentoo-46f58b50d48de2d1d751ae1a3e6111cc0d8e0887.tar.gz
gentoo-46f58b50d48de2d1d751ae1a3e6111cc0d8e0887.tar.bz2
gentoo-46f58b50d48de2d1d751ae1a3e6111cc0d8e0887.zip
net-mail/notmuch: Update for elisp-common.eclass changes.
Function elisp-need-emacs is deprecated, replace it by assigning NEED_EMACS and calling elisp-check-emacs-version in pkg_setup. Require emacs-24.1 as minimum version, because it is the first version with libxml2 support. Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/notmuch-0.28.4.ebuild9
-rw-r--r--net-mail/notmuch/notmuch-0.29.2.ebuild9
-rw-r--r--net-mail/notmuch/notmuch-0.29.3.ebuild9
3 files changed, 12 insertions, 15 deletions
diff --git a/net-mail/notmuch/notmuch-0.28.4.ebuild b/net-mail/notmuch/notmuch-0.28.4.ebuild
index 2856cf698a2..c43123227e0 100644
--- a/net-mail/notmuch/notmuch-0.28.4.ebuild
+++ b/net-mail/notmuch/notmuch-0.28.4.ebuild
@@ -38,7 +38,7 @@ CDEPEND="
>=sys-libs/zlib-1.2.5.2
sys-libs/talloc
crypt? ( dev-libs/gmime:3.0[crypt] )
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( >=app-editors/emacs-24.1:* )
python? ( ${PYTHON_DEPS} )
"
DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
)
test? (
app-misc/dtach
- || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+ >=app-editors/emacs-24.1:*[libxml2]
sys-devel/gdb
crypt? ( app-crypt/gnupg dev-libs/openssl )
)
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
"
DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
SITEFILE="50${PN}-gentoo.el"
MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
PATCHES=(
@@ -104,9 +105,7 @@ pkg_pretend() {
}
pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
+ use emacs && elisp-check-emacs-version
}
src_unpack() {
diff --git a/net-mail/notmuch/notmuch-0.29.2.ebuild b/net-mail/notmuch/notmuch-0.29.2.ebuild
index f848c35df5e..4ee535926dd 100644
--- a/net-mail/notmuch/notmuch-0.29.2.ebuild
+++ b/net-mail/notmuch/notmuch-0.29.2.ebuild
@@ -38,7 +38,7 @@ CDEPEND="
>=sys-libs/zlib-1.2.5.2
sys-libs/talloc
crypt? ( dev-libs/gmime:3.0[crypt] )
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( >=app-editors/emacs-24.1:* )
python? ( ${PYTHON_DEPS} )
"
DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
)
test? (
app-misc/dtach
- || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+ >=app-editors/emacs-24.1:*[libxml2]
sys-devel/gdb
crypt? ( app-crypt/gnupg dev-libs/openssl )
)
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
"
DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
SITEFILE="50${PN}-gentoo.el"
MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
PATCHES=(
@@ -103,9 +104,7 @@ pkg_pretend() {
}
pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
+ use emacs && elisp-check-emacs-version
}
src_unpack() {
diff --git a/net-mail/notmuch/notmuch-0.29.3.ebuild b/net-mail/notmuch/notmuch-0.29.3.ebuild
index f848c35df5e..4ee535926dd 100644
--- a/net-mail/notmuch/notmuch-0.29.3.ebuild
+++ b/net-mail/notmuch/notmuch-0.29.3.ebuild
@@ -38,7 +38,7 @@ CDEPEND="
>=sys-libs/zlib-1.2.5.2
sys-libs/talloc
crypt? ( dev-libs/gmime:3.0[crypt] )
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( >=app-editors/emacs-24.1:* )
python? ( ${PYTHON_DEPS} )
"
DEPEND="${CDEPEND}
@@ -49,7 +49,7 @@ DEPEND="${CDEPEND}
)
test? (
app-misc/dtach
- || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+ >=app-editors/emacs-24.1:*[libxml2]
sys-devel/gdb
crypt? ( app-crypt/gnupg dev-libs/openssl )
)
@@ -72,6 +72,7 @@ RDEPEND="${CDEPEND}
"
DOCS=( AUTHORS NEWS README )
+NEED_EMACS="24.1"
SITEFILE="50${PN}-gentoo.el"
MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
PATCHES=(
@@ -103,9 +104,7 @@ pkg_pretend() {
}
pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
+ use emacs && elisp-check-emacs-version
}
src_unpack() {