summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2019-07-08 22:36:02 +0100
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2019-07-08 22:36:12 +0100
commitad29d5a7889c2d6312b3aba7ad25a2eb90c27b6f (patch)
tree25b40707363bb0da48ae1c4495790e25ecd16456 /net-mail/notmuch
parentsys-apps/biosdevname-0.7.3: Fix version bump (diff)
downloadgentoo-ad29d5a7889c2d6312b3aba7ad25a2eb90c27b6f.tar.gz
gentoo-ad29d5a7889c2d6312b3aba7ad25a2eb90c27b6f.tar.bz2
gentoo-ad29d5a7889c2d6312b3aba7ad25a2eb90c27b6f.zip
net-mail/notmuch: Remove old testing versions
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org> Gentoo-Bug: https://bugs.gentoo.org/670854
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/Manifest5
-rw-r--r--net-mail/notmuch/notmuch-0.25.3.ebuild208
-rw-r--r--net-mail/notmuch/notmuch-0.26.1.ebuild208
-rw-r--r--net-mail/notmuch/notmuch-0.26.2.ebuild208
-rw-r--r--net-mail/notmuch/notmuch-0.27.ebuild215
-rw-r--r--net-mail/notmuch/notmuch-0.28.3.ebuild231
6 files changed, 0 insertions, 1075 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index 32f46df03f9..2b02ae8e539 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -1,10 +1,5 @@
DIST database-v1.tar.xz 204876 BLAKE2B 846a8d2f17edb61ed1c3d3c655becd1f60b4046772058706f13d516f65421a5105593660f1c556907bb2bb9607a3c2521243d1be07bffb70817ad3b8461680ca SHA512 e2d87373e00b65756d7fea40c54fb236d7a37ce839145c3afd99ab26efdc17796e540c021e2c24e521df2d0a01ccbf918994f87a0d83235ff9b109a51555b3d0
DIST notmuch-0.23.7.tar.gz 692230 BLAKE2B 79e81bde02546589c867d636fd30453beeecfb2a1e16cd512613de96f60674605765d53b52b8ab7479413b38d5db50d684a182139c62888c9dd0551f6eff8dea SHA512 e71da3bd6ce1b344aae79b277b695a4668d4fe1b8838618d6970a0b27df9867bac66a3240473ef31fc30ed8af2b0a558203ed5ffb34da873c991b1ecc6c08522
DIST notmuch-0.24.2.tar.gz 709272 BLAKE2B 25ef9db21a9fb009db89e472e06d871e92efc5223ef3edd91716db2a7edb5b8d39df000f540aa30762fe64e05fff221158040b2869fb618c89f9fa36cbe1757f SHA512 fcdc4ad5a65c57dd3077d93aeb384378f8dee105362fa8c2755daf14bbeb5376f8d1580fd79c8bd8e8d2d88cd44846ca9972b2f942133a447eb99d08ef9056dc
-DIST notmuch-0.25.3.tar.gz 883151 BLAKE2B 511f93c310e8b82f1b629735cbe626ab1ba8eabf23245ba4aa4c936d4c5d868d9e6d5b0d626f16ce6087245a293cf1acd8bb2e2dd0639729af4b92d558c78051 SHA512 1c0fcfdeb7a7eddcd10a8175676679ef6985407732d5bcc15edd327d9985017696cef3287c0398c628a604ae3fbab5d222d71537e37265cf6a594b4914e4599a
-DIST notmuch-0.26.1.tar.gz 906523 BLAKE2B da0b06361d586d84bea5c6e28adf7850dcb119e9f70ae67e06ff1438b9d20f4b04707d3e6ee6e755d569d15b8a720506b4c242c0c84258e8f5c8996caa62fc47 SHA512 f0d95a0f03535495037c73ab18d1251ece505284736efa5a535fe9bc8aea33954b5c87e5dcdfd30670c8df53178294be520a63e5b19beac7d90f166e616d19dd
-DIST notmuch-0.26.2.tar.gz 907187 BLAKE2B 81212555d729bd05be2edfb0f3dfd604de9d5f3e99e79ebd24a195441bd3778c7c72abe0b6b569dc1cf2ad9d94af1cbe3ca3aff77f521888b7be2eb08444dde1 SHA512 ebd8460c5f08cb8c79dabc1bc1bc32e1f2e1f123d304bb20205d4dedb982186336fd43d0e39acf020ea2563278bee0a063ceb3bf276f1251c099d8fcdd5098e7
-DIST notmuch-0.27.tar.gz 912583 BLAKE2B 75bb13e9666bd2898f58e5ecdd6a180d0da21188665f107857e6729f057525bb7c94832d140de8ff7b3fd31b51e33bcbe5b59d3fc09ba9a854c1c05499df762e SHA512 7c58c6fe5c3b43a979c3a439a24106417120726fd688b456d9084388ddd7c88ab1b6d99cd4676101f085d60bb37099631caa286b76588fcb041bb004ff325515
-DIST notmuch-0.28.3.tar.gz 921920 BLAKE2B 9b96a0cac8188bcaf9efab532721449c655fec4dac77c3eb327e576184cb430aa0fffc9ac74af82ad3ad80097afdda5c8accddbee7e5720d180c071d9dd2ef85 SHA512 dd3931b78cc27540e962f1fca5f4ebb1c04b2637a5761cda023f307fd9be4b5ddc2af26010330868c55200fa96b60b2a11b3b22d4c20d2a4a2d3787421ed85cf
DIST notmuch-0.28.4.tar.gz 922364 BLAKE2B f22d52ecc982b086b5d2a67d3b9ae4a379bdcb9e9acf3e77060fd7d97439347e3b4cd767f2c9c3c48657b80f63316f6abc09a653d6791e27b4a8996adccf42a9 SHA512 77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7
DIST notmuch-0.29.1.tar.xz 660352 BLAKE2B d145aba2d1a376e8cbcff3d51f9a7093649912a54273f91cce2a56fb414e222c2bbf0aeb510894278bf7dca8a96412400d55897a4d42281ab9c110d9bc8207a6 SHA512 9b76a7c8c62cb67b64a0008f80a82eeecccd20267ddba67d4d96a768815466c305f154769947bb9526e02c7a1696faaf69e94b90007603b185589be0c7c2a5d8
diff --git a/net-mail/notmuch/notmuch-0.25.3.ebuild b/net-mail/notmuch/notmuch-0.25.3.ebuild
deleted file mode 100644
index 96cc26fe756..00000000000
--- a/net-mail/notmuch/notmuch-0.25.3.ebuild
+++ /dev/null
@@ -1,208 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
- distutils-r1 toolchain-funcs
-
-DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
-HOMEPAGE="https://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
-
-LICENSE="GPL-3"
-# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
-# meant to be binary backward compatible.
-SLOT="0/5"
-KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
-REQUIRED_USE="
- nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
- "
-IUSE="crypt doc emacs mutt nmbug python test valgrind"
-
-CDEPEND="
- !!<app-shells/bash-completion-1.9
- >=dev-libs/glib-2.22:2
- >=dev-libs/gmime-2.6.20-r2:2.6
- >=dev-libs/xapian-1.2.7-r2:=
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=sys-libs/zlib-1.2.5.2
- sys-libs/talloc
- crypt? ( >=dev-libs/gmime-2.6.20-r2:2.6[smime] )
- emacs? ( >=virtual/emacs-23 )
- python? ( ${PYTHON_DEPS} )
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
- >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
- crypt? ( app-crypt/gnupg dev-libs/openssl ) )
- valgrind? ( dev-util/valgrind )
- "
-RDEPEND="${CDEPEND}
- crypt? ( app-crypt/gnupg )
- nmbug? ( dev-vcs/git )
- mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
- dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
- virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
- virtual/perl-Pod-Parser )
- "
-
-DOCS=( AUTHORS NEWS README )
-SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
-
-bindings() {
- local ret=0
-
- if use $1; then
- pushd bindings/$1 || die
- shift
- "$@"
- ret=$?
- popd || die
- fi
-
- return $ret
-}
-
-pkg_pretend() {
- if has_version '<net-mail/notmuch-0.18'; then
- ewarn
- ewarn "There are few not backward compatible changes between"
- ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
- ewarn "(0.18 section) for details before first use!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_unpack() {
- unpack "${P}".tar.gz
- if use test; then
- mkdir -p "${S}"/test/test-databases || die
- cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
- fi
-}
-
-src_prepare() {
- default
-
- bindings python distutils-r1_src_prepare
- bindings python mv README README-python || die
- mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
-
- # assure that new Makefile.config will be generated
- rm -f Makefile.config || die
-
- if use test; then
- append-cflags -g
- append-cxxflags -g
- fi
-
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
-}
-
-src_configure() {
- local myeconfargs=(
- --bashcompletiondir="$(get_bashcompdir)"
- --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
- --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
- --without-desktop
- --without-ruby
- --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- $(use_with emacs)
- $(use_with doc api-docs)
- )
- tc-export CC CXX
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- V=1 default
- bindings python distutils-r1_src_compile
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- emake notmuch-mutt.1
- popd || die
- fi
-
- if use doc; then
- pydocs() {
- pushd docs || die
- emake html
- rm -r html/_sources || die
- rm html/{objects.inv,.buildinfo} || die
- mkdir -p ../html && mv html ../html/python || die
- popd || die
- }
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
- fi
-}
-
-src_test() {
- pax-mark -m notmuch
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
- pax-mark -ze notmuch
-}
-
-src_install() {
- default
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use nmbug; then
- dobin devel/nmbug/nmbug
- dobin devel/nmbug/notmuch-report
- fi
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- dobin notmuch-mutt
- doman notmuch-mutt.1
- insinto /etc/mutt
- doins notmuch-mutt.rc
- dodoc README-mutt
- popd || die
- fi
-
- DOCS="" bindings python distutils-r1_src_install
- use doc && bindings python dodoc -r html
-}
-
-pkg_preinst() {
- if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
- elog "To enable notmuch support in mutt, add the following line into"
- elog "your mutt config file, please:"
- elog ""
- elog " source /etc/mutt/notmuch-mutt.rc"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- if has_version '<dev-libs/xapian-1.4'; then
- elog "Regular expression searches supported for from: and subject:"
- elog "require >=dev-libs/xapian-1.4."
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/net-mail/notmuch/notmuch-0.26.1.ebuild b/net-mail/notmuch/notmuch-0.26.1.ebuild
deleted file mode 100644
index dba91fb9d2f..00000000000
--- a/net-mail/notmuch/notmuch-0.26.1.ebuild
+++ /dev/null
@@ -1,208 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
- distutils-r1 toolchain-funcs
-
-DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
-HOMEPAGE="https://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
-
-LICENSE="GPL-3"
-# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
-# meant to be binary backward compatible.
-SLOT="0/5"
-KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
-REQUIRED_USE="
- nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
- "
-IUSE="crypt doc emacs mutt nmbug python test valgrind"
-
-CDEPEND="
- !!<app-shells/bash-completion-1.9
- >=dev-libs/glib-2.22:2
- >=dev-libs/gmime-2.6.21:2.6
- >=dev-libs/xapian-1.2.7-r2:=
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=sys-libs/zlib-1.2.5.2
- sys-libs/talloc
- crypt? ( >=dev-libs/gmime-2.6.21:2.6[smime] )
- emacs? ( >=virtual/emacs-23 )
- python? ( ${PYTHON_DEPS} )
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
- >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
- crypt? ( app-crypt/gnupg dev-libs/openssl ) )
- valgrind? ( dev-util/valgrind )
- "
-RDEPEND="${CDEPEND}
- crypt? ( app-crypt/gnupg )
- nmbug? ( dev-vcs/git )
- mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
- dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
- virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
- virtual/perl-Pod-Parser )
- "
-
-DOCS=( AUTHORS NEWS README )
-SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
-
-bindings() {
- local ret=0
-
- if use $1; then
- pushd bindings/$1 || die
- shift
- "$@"
- ret=$?
- popd || die
- fi
-
- return $ret
-}
-
-pkg_pretend() {
- if has_version '<net-mail/notmuch-0.18'; then
- ewarn
- ewarn "There are few not backward compatible changes between"
- ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
- ewarn "(0.18 section) for details before first use!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_unpack() {
- unpack "${P}".tar.gz
- if use test; then
- mkdir -p "${S}"/test/test-databases || die
- cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
- fi
-}
-
-src_prepare() {
- default
-
- bindings python distutils-r1_src_prepare
- bindings python mv README README-python || die
- mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
-
- # assure that new Makefile.config will be generated
- rm -f Makefile.config || die
-
- if use test; then
- append-cflags -g
- append-cxxflags -g
- fi
-
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
-}
-
-src_configure() {
- local myeconfargs=(
- --bashcompletiondir="$(get_bashcompdir)"
- --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
- --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
- --without-desktop
- --without-ruby
- --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- $(use_with emacs)
- $(use_with doc api-docs)
- )
- tc-export CC CXX
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- V=1 default
- bindings python distutils-r1_src_compile
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- emake notmuch-mutt.1
- popd || die
- fi
-
- if use doc; then
- pydocs() {
- pushd docs || die
- emake html
- rm -r html/_sources || die
- rm html/{objects.inv,.buildinfo} || die
- mkdir -p ../html && mv html ../html/python || die
- popd || die
- }
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
- fi
-}
-
-src_test() {
- pax-mark -m notmuch
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
- pax-mark -ze notmuch
-}
-
-src_install() {
- default
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use nmbug; then
- dobin devel/nmbug/nmbug
- dobin devel/nmbug/notmuch-report
- fi
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- dobin notmuch-mutt
- doman notmuch-mutt.1
- insinto /etc/mutt
- doins notmuch-mutt.rc
- dodoc README-mutt
- popd || die
- fi
-
- DOCS="" bindings python distutils-r1_src_install
- use doc && bindings python dodoc -r html
-}
-
-pkg_preinst() {
- if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
- elog "To enable notmuch support in mutt, add the following line into"
- elog "your mutt config file, please:"
- elog ""
- elog " source /etc/mutt/notmuch-mutt.rc"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- if has_version '<dev-libs/xapian-1.4'; then
- elog "Regular expression searches supported for from: and subject:"
- elog "require >=dev-libs/xapian-1.4."
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/net-mail/notmuch/notmuch-0.26.2.ebuild b/net-mail/notmuch/notmuch-0.26.2.ebuild
deleted file mode 100644
index dba91fb9d2f..00000000000
--- a/net-mail/notmuch/notmuch-0.26.2.ebuild
+++ /dev/null
@@ -1,208 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
- distutils-r1 toolchain-funcs
-
-DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
-HOMEPAGE="https://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
-
-LICENSE="GPL-3"
-# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
-# meant to be binary backward compatible.
-SLOT="0/5"
-KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
-REQUIRED_USE="
- nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
- "
-IUSE="crypt doc emacs mutt nmbug python test valgrind"
-
-CDEPEND="
- !!<app-shells/bash-completion-1.9
- >=dev-libs/glib-2.22:2
- >=dev-libs/gmime-2.6.21:2.6
- >=dev-libs/xapian-1.2.7-r2:=
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=sys-libs/zlib-1.2.5.2
- sys-libs/talloc
- crypt? ( >=dev-libs/gmime-2.6.21:2.6[smime] )
- emacs? ( >=virtual/emacs-23 )
- python? ( ${PYTHON_DEPS} )
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
- >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
- crypt? ( app-crypt/gnupg dev-libs/openssl ) )
- valgrind? ( dev-util/valgrind )
- "
-RDEPEND="${CDEPEND}
- crypt? ( app-crypt/gnupg )
- nmbug? ( dev-vcs/git )
- mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
- dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
- virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
- virtual/perl-Pod-Parser )
- "
-
-DOCS=( AUTHORS NEWS README )
-SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
-
-bindings() {
- local ret=0
-
- if use $1; then
- pushd bindings/$1 || die
- shift
- "$@"
- ret=$?
- popd || die
- fi
-
- return $ret
-}
-
-pkg_pretend() {
- if has_version '<net-mail/notmuch-0.18'; then
- ewarn
- ewarn "There are few not backward compatible changes between"
- ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
- ewarn "(0.18 section) for details before first use!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_unpack() {
- unpack "${P}".tar.gz
- if use test; then
- mkdir -p "${S}"/test/test-databases || die
- cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
- fi
-}
-
-src_prepare() {
- default
-
- bindings python distutils-r1_src_prepare
- bindings python mv README README-python || die
- mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
-
- # assure that new Makefile.config will be generated
- rm -f Makefile.config || die
-
- if use test; then
- append-cflags -g
- append-cxxflags -g
- fi
-
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
-}
-
-src_configure() {
- local myeconfargs=(
- --bashcompletiondir="$(get_bashcompdir)"
- --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
- --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
- --without-desktop
- --without-ruby
- --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- $(use_with emacs)
- $(use_with doc api-docs)
- )
- tc-export CC CXX
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- V=1 default
- bindings python distutils-r1_src_compile
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- emake notmuch-mutt.1
- popd || die
- fi
-
- if use doc; then
- pydocs() {
- pushd docs || die
- emake html
- rm -r html/_sources || die
- rm html/{objects.inv,.buildinfo} || die
- mkdir -p ../html && mv html ../html/python || die
- popd || die
- }
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
- fi
-}
-
-src_test() {
- pax-mark -m notmuch
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
- pax-mark -ze notmuch
-}
-
-src_install() {
- default
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use nmbug; then
- dobin devel/nmbug/nmbug
- dobin devel/nmbug/notmuch-report
- fi
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- dobin notmuch-mutt
- doman notmuch-mutt.1
- insinto /etc/mutt
- doins notmuch-mutt.rc
- dodoc README-mutt
- popd || die
- fi
-
- DOCS="" bindings python distutils-r1_src_install
- use doc && bindings python dodoc -r html
-}
-
-pkg_preinst() {
- if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
- elog "To enable notmuch support in mutt, add the following line into"
- elog "your mutt config file, please:"
- elog ""
- elog " source /etc/mutt/notmuch-mutt.rc"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- if has_version '<dev-libs/xapian-1.4'; then
- elog "Regular expression searches supported for from: and subject:"
- elog "require >=dev-libs/xapian-1.4."
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/net-mail/notmuch/notmuch-0.27.ebuild b/net-mail/notmuch/notmuch-0.27.ebuild
deleted file mode 100644
index 0f3d94a5325..00000000000
--- a/net-mail/notmuch/notmuch-0.27.ebuild
+++ /dev/null
@@ -1,215 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
- distutils-r1 toolchain-funcs
-
-DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
-HOMEPAGE="https://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
-
-LICENSE="GPL-3"
-# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
-# meant to be binary backward compatible.
-SLOT="0/5"
-KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
-REQUIRED_USE="
- nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
- "
-IUSE="crypt doc emacs mutt nmbug python test valgrind"
-
-CDEPEND="
- !!<app-shells/bash-completion-1.9
- >=dev-libs/glib-2.22:2
- || (
- >=dev-libs/gmime-3.0.3:3.0
- >=dev-libs/gmime-2.6.21:2.6
- )
- >=dev-libs/xapian-1.2.7-r2:=
- dev-python/sphinx[${PYTHON_USEDEP}]
- sys-apps/texinfo
- >=sys-libs/zlib-1.2.5.2
- sys-libs/talloc
- crypt? ( || (
- >=dev-libs/gmime-3.0.3:3.0[crypt]
- >=dev-libs/gmime-2.6.21:2.6[smime]
- ) )
- emacs? ( >=virtual/emacs-23 )
- python? ( ${PYTHON_DEPS} )
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
- >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
- crypt? ( app-crypt/gnupg dev-libs/openssl ) )
- valgrind? ( dev-util/valgrind )
- "
-RDEPEND="${CDEPEND}
- crypt? ( app-crypt/gnupg )
- nmbug? ( dev-vcs/git )
- mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
- dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
- virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
- virtual/perl-Pod-Parser )
- "
-
-DOCS=( AUTHORS NEWS README )
-SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
-
-bindings() {
- local ret=0
-
- if use $1; then
- pushd bindings/$1 || die
- shift
- "$@"
- ret=$?
- popd || die
- fi
-
- return $ret
-}
-
-pkg_pretend() {
- if has_version '<net-mail/notmuch-0.18'; then
- ewarn
- ewarn "There are few not backward compatible changes between"
- ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
- ewarn "(0.18 section) for details before first use!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_unpack() {
- unpack "${P}".tar.gz
- if use test; then
- mkdir -p "${S}"/test/test-databases || die
- cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
- fi
-}
-
-src_prepare() {
- default
-
- bindings python distutils-r1_src_prepare
- bindings python mv README README-python || die
- mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
-
- # assure that new Makefile.config will be generated
- rm -f Makefile.config || die
-
- if use test; then
- append-cflags -g
- append-cxxflags -g
- fi
-
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
-}
-
-src_configure() {
- local myeconfargs=(
- --bashcompletiondir="$(get_bashcompdir)"
- --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
- --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
- --without-desktop
- --without-ruby
- --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- $(use_with emacs)
- $(use_with doc api-docs)
- )
- tc-export CC CXX
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- V=1 default
- bindings python distutils-r1_src_compile
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- emake notmuch-mutt.1
- popd || die
- fi
-
- if use doc; then
- pydocs() {
- pushd docs || die
- emake html
- rm -r html/_sources || die
- rm html/{objects.inv,.buildinfo} || die
- mkdir -p ../html && mv html ../html/python || die
- popd || die
- }
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
- fi
-}
-
-src_test() {
- pax-mark -m notmuch
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
- pax-mark -ze notmuch
-}
-
-src_install() {
- default
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use nmbug; then
- dobin devel/nmbug/nmbug
- dobin devel/nmbug/notmuch-report
- fi
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- dobin notmuch-mutt
- doman notmuch-mutt.1
- insinto /etc/mutt
- doins notmuch-mutt.rc
- dodoc README-mutt
- popd || die
- fi
-
- DOCS="" bindings python distutils-r1_src_install
- use doc && bindings python dodoc -r html
-}
-
-pkg_preinst() {
- if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
- elog "To enable notmuch support in mutt, add the following line into"
- elog "your mutt config file, please:"
- elog ""
- elog " source /etc/mutt/notmuch-mutt.rc"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- if has_version '<dev-libs/xapian-1.4'; then
- elog "Regular expression searches supported for from: and subject:"
- elog "require >=dev-libs/xapian-1.4."
- fi
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/net-mail/notmuch/notmuch-0.28.3.ebuild b/net-mail/notmuch/notmuch-0.28.3.ebuild
deleted file mode 100644
index 95e5689f032..00000000000
--- a/net-mail/notmuch/notmuch-0.28.3.ebuild
+++ /dev/null
@@ -1,231 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
- distutils-r1 toolchain-funcs
-
-DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
-HOMEPAGE="https://notmuchmail.org/"
-SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
- test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
-
-LICENSE="GPL-3"
-# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
-# meant to be binary backward compatible.
-SLOT="0/5"
-KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
-REQUIRED_USE="
- nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
- "
-IUSE="crypt doc emacs mutt nmbug python test valgrind"
-
-CDEPEND="
- !!<app-shells/bash-completion-1.9
- >=dev-libs/glib-2.22:2
- >=dev-libs/gmime-3.0.3:3.0
- >=dev-libs/xapian-1.4.8:=
- dev-python/sphinx[${PYTHON_USEDEP}]
- sys-apps/texinfo
- >=sys-libs/zlib-1.2.5.2
- sys-libs/talloc
- crypt? ( dev-libs/gmime:3.0[crypt] )
- emacs? ( >=virtual/emacs-23 )
- python? ( ${PYTHON_DEPS} )
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-python/mock[${PYTHON_USEDEP}]
- )
- test? (
- app-misc/dtach
- || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
- sys-devel/gdb
- crypt? ( app-crypt/gnupg dev-libs/openssl )
- )
- valgrind? ( dev-util/valgrind )
- "
-RDEPEND="${CDEPEND}
- crypt? ( app-crypt/gnupg )
- nmbug? ( dev-vcs/git )
- mutt? (
- dev-perl/File-Which
- dev-perl/Mail-Box
- dev-perl/MailTools
- dev-perl/String-ShellQuote
- dev-perl/Term-ReadLine-Gnu
- virtual/perl-Digest-SHA
- virtual/perl-File-Path
- virtual/perl-Getopt-Long
- virtual/perl-Pod-Parser
- )
- "
-
-DOCS=( AUTHORS NEWS README )
-SITEFILE="50${PN}-gentoo.el"
-MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
-PATCHES=(
- "${FILESDIR}"/0001-Use-loopback-IP-address-rather-than-name.patch
- "${FILESDIR}"/0002-Fix-jobserver-unavailable-warning.patch
-)
-
-bindings() {
- local ret=0
-
- if use $1; then
- pushd bindings/$1 || die
- shift
- "$@"
- ret=$?
- popd || die
- fi
-
- return $ret
-}
-
-pkg_pretend() {
- if has_version '<net-mail/notmuch-0.18'; then
- ewarn
- ewarn "There are few not backward compatible changes between"
- ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
- ewarn "(0.18 section) for details before first use!"
- ewarn
- fi
-}
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_unpack() {
- unpack "${P}".tar.gz
- if use test; then
- mkdir -p "${S}"/test/test-databases || die
- cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
- fi
-}
-
-src_prepare() {
- default
-
- bindings python distutils-r1_src_prepare
- bindings python mv README README-python || die
- mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
-
- # assure that new Makefile.config will be generated
- rm -f Makefile.config || die
-
- sed -e 's@^install: all install-man install-info$@install: all install-info@' -i Makefile.local
-
- if use test; then
- append-cflags -g
- append-cxxflags -g
- fi
-
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
-}
-
-src_configure() {
- python_setup # for sphinx
-
- local myeconfargs=(
- --bashcompletiondir="$(get_bashcompdir)"
- --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
- --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
- --without-desktop
- --without-ruby
- --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- $(use_with emacs)
- $(use_with doc api-docs)
- )
- tc-export CC CXX
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- python_setup # for sphinx
-
- V=1 default
- bindings python distutils-r1_src_compile
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- emake notmuch-mutt.1
- popd || die
- fi
-
- if use doc; then
- pydocs() {
- pushd docs || die
- emake html
- rm -r html/_sources || die
- rm html/{objects.inv,.buildinfo} || die
- mkdir -p ../html && mv html ../html/python || die
- popd || die
- }
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
- fi
-}
-
-src_test() {
- pax-mark -m notmuch
- LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
- pax-mark -ze notmuch
-}
-
-src_install() {
- default
-
- if use doc; then
- doman doc/_build/man/man?/*.?
- fi
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use nmbug; then
- dobin devel/nmbug/nmbug
- dobin devel/nmbug/notmuch-report
- fi
-
- if use mutt; then
- pushd contrib/notmuch-mutt || die
- dobin notmuch-mutt
- doman notmuch-mutt.1
- insinto /etc/mutt
- doins notmuch-mutt.rc
- dodoc README-mutt
- popd || die
- fi
-
- DOCS="" bindings python distutils-r1_src_install
- use doc && bindings python dodoc -r html
-}
-
-pkg_preinst() {
- if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
- elog "To enable notmuch support in mutt, add the following line into"
- elog "your mutt config file, please:"
- elog ""
- elog " source /etc/mutt/notmuch-mutt.rc"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}