summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-10 17:00:01 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-10 17:00:27 -0400
commit955bc8b81f435b139f97835f40aae860221bf13e (patch)
tree06f59b073c248ec0fc32615e084135e3ce169165 /net-mail/offlineimap
parentprofiles: mask net-misc/quickshare for removal (diff)
downloadgentoo-955bc8b81f435b139f97835f40aae860221bf13e.tar.gz
gentoo-955bc8b81f435b139f97835f40aae860221bf13e.tar.bz2
gentoo-955bc8b81f435b139f97835f40aae860221bf13e.zip
net-mail/offlineimap: version bump to 7.0.5
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.0.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index c341a490d2f9..9eecaa624517 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -2,3 +2,4 @@ DIST offlineimap-6.5.6.tar.gz 187801 SHA256 650fa588bdf86624575a5196fa12e9059b74
DIST offlineimap-6.5.7.tar.gz 666620 SHA256 b7de52c7d8995e0657bb55da13531c8d6f96d828217159477c685ae408e390a3 SHA512 eb2d7c627b1a5563cb685549eeaaef2cd164e69ab5c541ee64b2d081dfe5493cd51de449e6283447e8132503545f7f37cb6bf7e6764b626f243e502cf77bda4f WHIRLPOOL dbedde3030f1483dda00ee56d2a735c6d131f65dcafac37f476b136de86dbd0d76d87b8701c99e642f050a181f6bb657be9bbae44e2f289137e785759136395f
DIST offlineimap-7.0.3.tar.gz 688967 SHA256 db002ba68ac5ce9336487741d9828e33dd435ee33dc5009ae91c3586d1b4507e SHA512 5ebb0411810b617f7b878df147d10bedf1a9d928645f8080f6d81683f621f503bda3ecc50dbaa86fe0d8b500e355236eebced3833313abb694b0593e626be330 WHIRLPOOL 3e4b3b42f732771e5b1d680dac12a49e2dac2c0e45174e3b40fef961f8917280d76612a048121a7f379edb014f553966f6b40df362a65a93dcf2f752666b8ca3
DIST offlineimap-7.0.4.tar.gz 689027 SHA256 3f848027a5b9865061f9ff56bc8a0ee6d7370f53fe5bb5a76e3e9220fea63ebc SHA512 29b22d5cf8deea937c6eb461b9a7e8211792e761374407ae6a17eb53a6a9a0f8ce6e43b84b90470802112389b50018cd6ee8ca85f7e0b3744720707e35a9119b WHIRLPOOL 3aa9a4e401e6851d806bff9a8a95f5bd37ce1ab16ccb5b9baa0ec2eefdb559489203927b5e3de6ad010b54c3ab6785662c979287cd706f7f05ec989ab6c8eaaf
+DIST offlineimap-7.0.5.tar.gz 689611 SHA256 76668c032d3e1c845addaf99b7f4dc61bbb2e06038a85322347d46d2233e9517 SHA512 f489468266455346f9bce30796b4fb270a61caf66dada22b21e5408b9207e41ae437e271a808662fe0105e30d670273c5f102b51c2b5b497665dc0ab3601e386 WHIRLPOOL e0bf449497810ed6035d5f3ad5d32db7f7d18f71d95af242895007d41bf2670ed85941bbd97357302039f5df2459e005806d3bff798f24ab61f75668416f2901
diff --git a/net-mail/offlineimap/offlineimap-7.0.5.ebuild b/net-mail/offlineimap/offlineimap-7.0.5.ebuild
new file mode 100644
index 000000000000..2915dc79919a
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.0.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}