summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-15 08:13:10 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-15 08:59:14 -0400
commit9d1239a0e53bdb804bb726542bc25542d504a7c2 (patch)
treeeea939b3718a9ed707d3b96175deb4f6b6bc0deb /net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild
parentnet-mail/mailshears: new EAPI=7 revision with ruby25 support. (diff)
downloadgentoo-9d1239a0e53bdb804bb726542bc25542d504a7c2.tar.gz
gentoo-9d1239a0e53bdb804bb726542bc25542d504a7c2.tar.bz2
gentoo-9d1239a0e53bdb804bb726542bc25542d504a7c2.zip
net-mail/postfix-logwatch: new revision with a new patch.
The -r4 revision includes a patch to ignore the "DATA without valid RCPT" notices that postscreen emits. The patch hasn't been upstreamed because we're basically upstream at this point. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild')
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild
new file mode 100644
index 000000000000..e4fe1d212ae6
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://logreporters.sourceforge.net/"
+SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}/unescaped-left-brace.patch"
+ "${FILESDIR}/redundant-argument-to-sprintf.patch"
+ "${FILESDIR}/multi-digit-enhanced-status.patch"
+ "${FILESDIR}/all-server-ports-busy-lines.patch"
+ "${FILESDIR}/data-without-valid-rcpt.patch"
+)
+
+src_prepare() {
+ default
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_compile() {
+ # The default make target just outputs instructions. We don't want
+ # the user to see these, so we avoid the default emake.
+ :
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}