summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-23 04:13:04 +0000
committerSam James <sam@gentoo.org>2022-11-23 04:13:04 +0000
commit3047a3a2b723c5572d6120512450e0cf9eca7395 (patch)
tree25977a194f4cb3d4f98646fbe926bd0aca242d83 /net-mail
parentdev-libs/libucl: add github upstream metadata (diff)
downloadgentoo-3047a3a2b723c5572d6120512450e0cf9eca7395.tar.gz
gentoo-3047a3a2b723c5572d6120512450e0cf9eca7395.tar.bz2
gentoo-3047a3a2b723c5572d6120512450e0cf9eca7395.zip
net-mail/sendEmail: fix openssl 1.1 compat
Closes: https://bugs.gentoo.org/698322 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sendEmail/files/1.56-openssl-1.1.patch12
-rw-r--r--net-mail/sendEmail/sendEmail-1.56-r3.ebuild31
2 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/sendEmail/files/1.56-openssl-1.1.patch b/net-mail/sendEmail/files/1.56-openssl-1.1.patch
new file mode 100644
index 000000000000..ed5046451994
--- /dev/null
+++ b/net-mail/sendEmail/files/1.56-openssl-1.1.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/698322
+--- a/sendEmail
++++ b/sendEmail
+@@ -1903,7 +1903,7 @@
+ if ($conf{'tls_server'} == 1 and $conf{'tls_client'} == 1 and $opt{'tls'} =~ /^(yes|auto)$/) {
+ printmsg("DEBUG => Starting TLS", 2);
+ if (SMTPchat('STARTTLS')) { quit($conf{'error'}, 1); }
+- if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3', SSL_verify_mode => 0x00)) {
++ if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'TLSv1', SSL_verify_mode => 0x00)) {
+ quit("ERROR => TLS setup failed: " . IO::Socket::SSL::errstr(), 1);
+ }
+ printmsg("DEBUG => TLS: Using cipher: ". $SERVER->get_cipher(), 3);
diff --git a/net-mail/sendEmail/sendEmail-1.56-r3.ebuild b/net-mail/sendEmail/sendEmail-1.56-r3.ebuild
new file mode 100644
index 000000000000..7e5d25812ad0
--- /dev/null
+++ b/net-mail/sendEmail/sendEmail-1.56-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="Command line based, SMTP email agent"
+HOMEPAGE="http://caspian.dotconf.net/menu/Software/SendEmail/"
+SRC_URI="http://caspian.dotconf.net/menu/Software/SendEmail/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ dev-lang/perl
+ ssl? ( dev-perl/IO-Socket-SSL )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-overzealous-version-check.patch
+ "${FILESDIR}"/${PV}-overzealous-verify-mode-check.patch
+ "${FILESDIR}"/${PV}-openssl-1.1.patch
+)
+
+src_install() {
+ dobin sendEmail
+ dodoc CHANGELOG README TODO
+}