summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-03-28 07:31:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-03-28 05:42:58 -0400
commit36a179cdf70a44c0a2530fc2e1b49e7eb76df89f (patch)
treec96c169685becab0145cc233cd63410086083750 /net-misc/bfgminer
parentdev-perl/Module-Install: amd64/ia64/sparc/x86 stable, (ALLARCHES policy) wrt ... (diff)
downloadgentoo-36a179cdf70a44c0a2530fc2e1b49e7eb76df89f.tar.gz
gentoo-36a179cdf70a44c0a2530fc2e1b49e7eb76df89f.tar.bz2
gentoo-36a179cdf70a44c0a2530fc2e1b49e7eb76df89f.zip
net-misc/bfgminer: version bump to 5.4.2
Diffstat (limited to 'net-misc/bfgminer')
-rw-r--r--net-misc/bfgminer/Manifest1
-rw-r--r--net-misc/bfgminer/bfgminer-5.4.2.ebuild195
2 files changed, 196 insertions, 0 deletions
diff --git a/net-misc/bfgminer/Manifest b/net-misc/bfgminer/Manifest
index 1de77716f770..d12685bc2038 100644
--- a/net-misc/bfgminer/Manifest
+++ b/net-misc/bfgminer/Manifest
@@ -5,3 +5,4 @@ DIST bfgminer-4.10.4.tar.xz 988348 SHA256 93c7e5f3170b39353fa4e924268a2497810df6
DIST bfgminer-5.3.0.tar.xz 1017536 SHA256 d48fa6e51ff70ee1a85f77334a24f842ca6774c073c2d864fe739f07093ef77f SHA512 935b2a0595a2230f8ba9f832a280f52418c1b50b884010bebd2059cbef83d28c535d8d0b3cd7abe5b2420f6dc9fa8e9e0e32839ccdb6cd002a1e874dc5b1841a WHIRLPOOL 0244c9cf2a8928590f69819cfaa222498ae9e0b65aba4c0bc3fc751b7712e9284110ef238dd3bdeaa0562f4eaa292b4257e4d509966ff8e92731dd3f1d9f8ecc
DIST bfgminer-5.4.0.tar.xz 1037568 SHA256 c265e060919545bd2cdb187de0549b372413c49ca02c5bd5621ef9a91b9f5c0c SHA512 26d49e0a8b336c6dcfbae7abb4d5fc97707dffc0cb9d790984d02c4557d8383120b58c8a3e08ce7cc4f5bbfc051d01d518181eab4344b57d119527dfb1d75f84 WHIRLPOOL 2299b8a4082a59541f13cd04cb516b40d599f3080c70c7020e4581bb4ed583902d2221fd418cd13b8d6edcaaf3290db4f03e8e4fc6073ca31a33786b1da547bd
DIST bfgminer-5.4.1.tar.xz 1037828 SHA256 1a0c3e43741d9061aa0b5257353a812b84632fc8ac7d5ec84d91fb134803cc0c SHA512 3ef88991c18743bfe90749e488ae512a7d10b33ef22d4b1bd6ebfeb3e19cbdb6886f20b1b625b9003cca5b417d8cb814143941d8e2b982552ffb623a4f0e0959 WHIRLPOOL 132d2a8c0ca23e11232af8644e4ab77dee6b15ae64a6a9a1ae1c8efae0c3332c84f133777256f7975d63e5b55d0436d7e7c504d99c491d9879c7598f68e863bc
+DIST bfgminer-5.4.2.tar.xz 1039200 SHA256 7030632a08cfc5a3fdca485fd8d7213d8f41560134c54d356426b974d91ce01a SHA512 b5ae8ae44df166d5576f89683ce9ee0832ca1f506b2522da7e3cd432abc5e218e9080e2a79f4da29e40db0d3179e63c9a8907d5d6b60d5d4895d6cac2b15d8ca WHIRLPOOL b6472c13e65dc9be18bbc760a1c9f84a70a25d695408d52c8ef9de461e6c7539a9915d85cced4b09c797686499280ad5109d9332a28f56ea4a9e3c0babf05394
diff --git a/net-misc/bfgminer/bfgminer-5.4.2.ebuild b/net-misc/bfgminer/bfgminer-5.4.2.ebuild
new file mode 100644
index 000000000000..12c5b797bc53
--- /dev/null
+++ b/net-misc/bfgminer/bfgminer-5.4.2.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Modular Bitcoin ASIC/FPGA/GPU/CPU miner in C"
+HOMEPAGE="https://bitcointalk.org/?topic=168174"
+SRC_URI="http://luke.dashjr.org/programs/bitcoin/files/${PN}/${PV}/${P}.txz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# TODO: knc (needs i2c-tools header)
+# TODO: kncasic & titan (need systemwide knc-asic install)
+# TODO: minergate (needs actual miner_gate)
+IUSE="adl antminer avalon avalonmm bfsb bfx bifury bigpic bitforce bitfury cointerra cpumining drillbit dualminer examples gridseed hardened hashbuster hashbuster2 hashfast icarus jingtian keccak klondike +libusb littlefury lm_sensors metabank minion modminer nanofury ncurses opencl proxy proxy_getwork proxy_stratum rockminer screen scrypt +sha256d twinfury +udev udev-broad-rules unicode x6500 zeusminer ztex"
+REQUIRED_USE='
+ || ( keccak scrypt sha256d )
+ || ( antminer avalon avalonmm bfsb bfx bifury bigpic bitforce bitfury cointerra cpumining drillbit dualminer gridseed hashbuster hashbuster2 hashfast icarus klondike littlefury metabank modminer nanofury opencl proxy twinfury x6500 zeusminer ztex )
+ adl? ( opencl )
+ antminer? ( sha256d )
+ avalon? ( sha256d )
+ avalonmm? ( sha256d )
+ bfsb? ( sha256d bitfury )
+ bfx? ( sha256d bitfury libusb )
+ bifury? ( sha256d )
+ bigpic? ( sha256d bitfury )
+ bitforce? ( sha256d )
+ bitfury? ( sha256d )
+ cointerra? ( sha256d )
+ drillbit? ( sha256d bitfury )
+ dualminer? ( || ( sha256d scrypt ) icarus )
+ gridseed? ( scrypt )
+ hashbuster? ( sha256d bitfury )
+ hashbuster2? ( sha256d bitfury libusb )
+ hashfast? ( sha256d )
+ icarus? ( || ( scrypt sha256d ) )
+ jingtian? ( sha256d )
+ keccak? ( || ( cpumining opencl proxy ) )
+ klondike? ( sha256d libusb )
+ littlefury? ( sha256d bitfury )
+ lm_sensors? ( opencl )
+ metabank? ( sha256d bitfury )
+ minion? ( sha256d )
+ modminer? ( sha256d )
+ nanofury? ( sha256d bitfury )
+ scrypt? ( || ( cpumining dualminer gridseed opencl proxy zeusminer ) )
+ sha256d? ( || ( antminer avalon avalonmm bfx bifury bitforce bfsb bigpic bitfury cointerra cpumining drillbit dualminer hashbuster hashbuster2 hashfast icarus jingtian klondike littlefury metabank modminer nanofury opencl proxy rockminer twinfury x6500 ztex ) )
+ twinfury? ( bitfury )
+ unicode? ( ncurses )
+ proxy? ( || ( proxy_getwork proxy_stratum ) )
+ proxy_getwork? ( proxy )
+ proxy_stratum? ( proxy )
+ rockminer? ( sha256d )
+ twinfury? ( sha256d )
+ x6500? ( sha256d libusb )
+ zeusminer? ( scrypt icarus )
+ ztex? ( sha256d libusb )
+'
+
+DEPEND='
+ net-misc/curl
+ ncurses? (
+ sys-libs/ncurses:=[unicode?]
+ )
+ >=dev-libs/jansson-2
+ dev-libs/libbase58
+ net-libs/libblkmaker
+ udev? (
+ virtual/udev
+ )
+ hashbuster? (
+ dev-libs/hidapi
+ )
+ libusb? (
+ virtual/libusb:1
+ )
+ lm_sensors? (
+ sys-apps/lm_sensors
+ )
+ nanofury? (
+ dev-libs/hidapi
+ )
+ proxy_getwork? (
+ net-libs/libmicrohttpd
+ )
+ proxy_stratum? (
+ dev-libs/libevent
+ )
+ screen? (
+ app-misc/screen
+ || (
+ >=sys-apps/coreutils-8.15
+ sys-freebsd/freebsd-bin
+ app-misc/realpath
+ )
+ )
+'
+RDEPEND="${DEPEND}
+ opencl? (
+ || (
+ virtual/opencl
+ dev-util/nvidia-cuda-sdk[opencl]
+ )
+ )
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/uthash-1.9.7
+ sys-apps/sed
+ cpumining? (
+ amd64? (
+ >=dev-lang/yasm-1.0.1
+ )
+ x86? (
+ >=dev-lang/yasm-1.0.1
+ )
+ )
+"
+
+src_configure() {
+ local CFLAGS="${CFLAGS}"
+ local with_curses
+ use hardened && CFLAGS="${CFLAGS} -nopie"
+
+ if use ncurses; then
+ if use unicode; then
+ with_curses='--with-curses=ncursesw'
+ else
+ with_curses='--with-curses=ncurses'
+ fi
+ else
+ with_curses='--without-curses'
+ fi
+
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable adl) \
+ $(use_enable antminer) \
+ $(use_enable avalon) \
+ $(use_enable avalonmm) \
+ $(use_enable bifury) \
+ $(use_enable bitforce) \
+ $(use_enable bfsb) \
+ $(use_enable bfx) \
+ $(use_enable bigpic) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable cpumining) \
+ $(use_enable drillbit) \
+ $(use_enable dualminer) \
+ $(use_enable gridseed) \
+ $(use_enable hashbuster) \
+ $(use_enable hashbuster2 hashbusterusb) \
+ $(use_enable hashfast) \
+ $(use_enable icarus) \
+ $(use_enable jingtian) \
+ $(use_enable keccak) \
+ $(use_enable klondike) \
+ $(use_enable littlefury) \
+ $(use_enable metabank) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable nanofury) \
+ $(use_enable opencl) \
+ $(use_enable rockminer) \
+ $(use_enable scrypt) \
+ $(use_enable sha256d) \
+ $(use_enable twinfury) \
+ --with-system-libblkmaker \
+ $with_curses \
+ $(use_with udev libudev) \
+ $(use_enable udev-broad-rules broad-udevrules) \
+ $(use_with lm_sensors sensors) \
+ $(use_with proxy_getwork libmicrohttpd) \
+ $(use_with proxy_stratum libevent) \
+ $(use_enable x6500) \
+ $(use_enable zeusminer) \
+ $(use_enable ztex)
+}
+
+src_install() {
+ emake install DESTDIR="$D"
+ if ! use examples; then
+ rm -r "${D}/usr/share/doc/${PF}/rpc-examples"
+ fi
+ if ! use screen; then
+ rm "${D}/usr/bin/start-bfgminer.sh"
+ fi
+}