summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-15 15:04:02 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-15 15:05:31 +0200
commit14908c53c0d65e090817fa78352d95e7f79d3883 (patch)
tree8ffb2731c17aafafd47341973b3441b913dcaefc /net-misc/cni-plugins
parentdev-php/pecl-apcu: Drop old (diff)
downloadgentoo-14908c53c0d65e090817fa78352d95e7f79d3883.tar.gz
gentoo-14908c53c0d65e090817fa78352d95e7f79d3883.tar.bz2
gentoo-14908c53c0d65e090817fa78352d95e7f79d3883.zip
net-misc/cni-plugins: Version bump to 0.8.2
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'net-misc/cni-plugins')
-rw-r--r--net-misc/cni-plugins/Manifest1
-rw-r--r--net-misc/cni-plugins/cni-plugins-0.8.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/cni-plugins/Manifest b/net-misc/cni-plugins/Manifest
index 08bf68992563..f90d55e46bb3 100644
--- a/net-misc/cni-plugins/Manifest
+++ b/net-misc/cni-plugins/Manifest
@@ -1,3 +1,4 @@
DIST cni-plugins-0.7.5.tar.gz 862670 BLAKE2B 17734beabde562cfd52efd479cb24805681a3d8a8abd4fd9fdcf9dbd891b2d5b3026b84a880355388c893db147fd0952786a86716438e140a46cc9a2dfffe0c2 SHA512 7ab43f88b4763907f56ff26d684385e5a3f6314ffb4bcbe356ec33a014fc15207392bd26e2d3041e117c604a386d21841a37d093b04e003303554b03721b32c6
DIST cni-plugins-0.7.6.tar.gz 862694 BLAKE2B 4c66d80be260217f977f6f80ecd36ec8e3209b57ad34e1bfb03dc5df453ead6aeac24e2852a068430e94a83fc314f92bb9dac41432e16851508e170fa4e77c58 SHA512 28baaa9793dcec4d9417d6beaf4d85cb1eb433f401b3f7d905b2a60709825de0e9ac80a713d8944433e72c7381d502b14aff85c3dc5d665bfca3160f1bfcc13d
DIST cni-plugins-0.8.1.tar.gz 3253670 BLAKE2B 7de5b53e310b496137c0ea0d6b4d22d5604e49fb4ada456eaad377a0b20d0b8883e7420a8d5f8cf92922e98b493608d495126772fd4205e4efb42b784fe3cea7 SHA512 ed57162fc3d014c897ee2f7f82b738624ca42ad7c238ac6ac5c1eb9ac865fe27f8ded1510cfb131f7b43e44f6cd0366ab83011386bcb6add36ea11235767760f
+DIST cni-plugins-0.8.2.tar.gz 1997790 BLAKE2B a3c0196c589a3a77de100a87ca8d3eb952478190c78dc50bc7b65d6229ec33593fe77be4a8c5b593d9ea8bb806f9b8d04768bc52b689b006640cfa34c176a0a1 SHA512 383540232593c7ef8c28f83e660a58ae6dd2592c6d97a43c8fc1f046a3fa448911d4066ec0a6a7d7e770a1a2dceee7c31d742100b0871e07d691fe6bdffd42f9
diff --git a/net-misc/cni-plugins/cni-plugins-0.8.2.ebuild b/net-misc/cni-plugins/cni-plugins-0.8.2.ebuild
new file mode 100644
index 000000000000..4fd45539a5a6
--- /dev/null
+++ b/net-misc/cni-plugins/cni-plugins-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="Standard networking plugins for container networking"
+EGO_PN="github.com/containernetworking/plugins"
+HOMEPAGE="https://github.com/containernetworking/plugins"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+CONFIG_CHECK="~BRIDGE_VLAN_FILTERING"
+
+src_compile() {
+ pushd src || die
+ local i
+ for i in plugins/{meta/{bandwidth,firewall,flannel,portmap,sbr,tuning},main/{bridge,host-device,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local,static},sample}; do
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${WORKDIR}/${P}" go install -v "${EGO_PN}/${i}" || die
+ done
+ popd || die
+}
+
+src_install() {
+ exeinto /opt/cni/bin
+ doexe bin/*
+ pushd src/${EGO_PN} || die
+ dodoc README.md
+ local i
+ for i in plugins/{meta/{bandwidth,firewall,flannel,portmap,sbr,tuning},main/{bridge,host-device,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local,static},sample}; do
+ newdoc README.md ${i##*/}.README.md
+ done
+ popd || die
+}