summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-28 23:00:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-28 23:03:07 +0200
commitce6c054200b64ef3c19251efd8236e915cd99d5b (patch)
treebf299779bc92c0d2f8fd59b2e50a928a9509627e /net-misc/gallery-dl/gallery-dl-1.22.3.ebuild
parentapp-admin/salt: remove unused patch (diff)
downloadgentoo-ce6c054200b64ef3c19251efd8236e915cd99d5b.tar.gz
gentoo-ce6c054200b64ef3c19251efd8236e915cd99d5b.tar.bz2
gentoo-ce6c054200b64ef3c19251efd8236e915cd99d5b.zip
net-misc/gallery-dl: bump to 1.22.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-1.22.3.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.22.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.22.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.22.3.ebuild
new file mode 100644
index 000000000000..60c3846252ce
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.22.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,ssl,xml"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}