summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 21:20:55 +0000
committerSam James <sam@gentoo.org>2020-09-15 21:46:11 +0000
commit99c4005cc8ecf754da7dca31b2702e3c63f0164b (patch)
tree5a1840cc15975ab164b10cf60e0fc7d389084a2f /net-misc/gsasl
parentnet-vpn/corkscrew: EAPI7 bump (diff)
downloadgentoo-99c4005cc8ecf754da7dca31b2702e3c63f0164b.tar.gz
gentoo-99c4005cc8ecf754da7dca31b2702e3c63f0164b.tar.bz2
gentoo-99c4005cc8ecf754da7dca31b2702e3c63f0164b.zip
net-misc/gsasl: bump to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/gsasl')
-rw-r--r--net-misc/gsasl/files/gsasl-1.8.0-sasl-gss-extra.patch (renamed from net-misc/gsasl/files/gsasl-gss-extra.patch)4
-rw-r--r--net-misc/gsasl/gsasl-1.8.0-r1.ebuild35
2 files changed, 28 insertions, 11 deletions
diff --git a/net-misc/gsasl/files/gsasl-gss-extra.patch b/net-misc/gsasl/files/gsasl-1.8.0-sasl-gss-extra.patch
index e08a36ae5779..a3eec016e40c 100644
--- a/net-misc/gsasl/files/gsasl-gss-extra.patch
+++ b/net-misc/gsasl/files/gsasl-1.8.0-sasl-gss-extra.patch
@@ -1,6 +1,6 @@
Based on gentoo bug #359005
---- lib/gl/m4/gss-extra.m4.orig 2010-12-14 12:57:08.000000000 +0000
-+++ lib/gl/m4/gss-extra.m4 2011-11-05 21:11:54.000000000 +0000
+--- a/lib/gl/m4/gss-extra.m4 2010-12-14 12:57:08.000000000 +0000
++++ b/lib/gl/m4/gss-extra.m4 2011-11-05 21:11:54.000000000 +0000
@@ -19,7 +19,16 @@
AC_CHECK_FUNCS([gss_decapsulate_token])
AC_CHECK_FUNCS([gss_oid_equal])
diff --git a/net-misc/gsasl/gsasl-1.8.0-r1.ebuild b/net-misc/gsasl/gsasl-1.8.0-r1.ebuild
index 9fb42b266213..a1e9339e1b73 100644
--- a/net-misc/gsasl/gsasl-1.8.0-r1.ebuild
+++ b/net-misc/gsasl/gsasl-1.8.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="The GNU SASL client, server, and library"
HOMEPAGE="https://www.gnu.org/software/gsasl/"
@@ -14,28 +14,42 @@ KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc gcrypt idn kerberos nls ntlm static-libs +threads"
DEPEND="
- gcrypt? ( dev-libs/libgcrypt:0 )
- idn? ( net-dns/libidn )
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ idn? ( net-dns/libidn:= )
kerberos? ( virtual/krb5 )
nls? ( >=sys-devel/gettext-0.18.1 )
ntlm? ( net-libs/libntlm )
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.0-sasl-gss-extra.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-gss-extra.patch"
+ default
+
sed -i -e '/gl_WARN_ADD(\[-Werror/d' \
-e 's/ -Werror//' configure.ac || die
sed -i -e 's/ -Werror//' lib/configure.ac || die
+
eautoreconf
}
src_configure() {
local krb5_impl
+
if use kerberos; then
krb5_impl="--with-gssapi-impl="
- krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
+
+ # These are the two providers of virtual/krb5
+ if has_version app-crypt/mit-krb5; then
+ krb5_impl+="mit"
+ else
+ krb5_impl+="heimdal"
+ fi
fi
+
econf \
--enable-client \
--enable-server \
@@ -58,14 +72,17 @@ src_configure() {
src_install() {
default
+
if ! use static-libs; then
- rm -f "${D}"/usr/lib*/lib*.la
+ rm -f "${ED}"/usr/lib*/lib*.la || die
fi
+
doman doc/gsasl.1 doc/man/*.3
if use doc; then
dodoc doc/*.{eps,ps,pdf}
- dohtml doc/*.html
+ docinto html
+ dodoc doc/*.html
docinto examples
dodoc examples/*.c
fi