summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-10-13 17:21:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-13 19:55:14 +0300
commitf7c58ca64f4cfcc675b692787369b6d4a5813722 (patch)
treec1835869bb88952405d817f487e3361e5c6243a8 /net-misc/httpie/httpie-1.0.3.ebuild
parentnet-misc/httpie: Remove obsolete ebuilds (diff)
downloadgentoo-f7c58ca64f4cfcc675b692787369b6d4a5813722.tar.gz
gentoo-f7c58ca64f4cfcc675b692787369b6d4a5813722.tar.bz2
gentoo-f7c58ca64f4cfcc675b692787369b6d4a5813722.zip
net-misc/httpie: Bump to version 1.0.3
Closes: https://bugs.gentoo.org/696486 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/13173 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/httpie/httpie-1.0.3.ebuild')
-rw-r--r--net-misc/httpie/httpie-1.0.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/httpie/httpie-1.0.3.ebuild b/net-misc/httpie/httpie-1.0.3.ebuild
new file mode 100644
index 000000000000..7849e8a95d9b
--- /dev/null
+++ b/net-misc/httpie/httpie-1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.19.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Extend list of expected strings in test
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.2-fix-test_ssl.patch"
+ "${FILESDIR}/${PN}-1.0.3-test_binary.patch"
+ "${FILESDIR}/${PN}-1.0.3-test_stream.patch"
+)
+
+python_test() {
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}