summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-28 15:21:40 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-28 15:22:14 +0100
commita5cea554030ff6d137320b761c749af3e2b251f4 (patch)
tree3ca2f12e96eee2670f56ac0d94e623886b3f7f2d /net-misc/httpstat/httpstat-1.3.1.ebuild
parentMove {dev-python → net-misc}/httpstat (diff)
downloadgentoo-a5cea554030ff6d137320b761c749af3e2b251f4.tar.gz
gentoo-a5cea554030ff6d137320b761c749af3e2b251f4.tar.bz2
gentoo-a5cea554030ff6d137320b761c749af3e2b251f4.zip
net-misc/httpstat: bump to v1.3.1
Closes: https://bugs.gentoo.org/761948 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/httpstat/httpstat-1.3.1.ebuild')
-rw-r--r--net-misc/httpstat/httpstat-1.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/httpstat/httpstat-1.3.1.ebuild b/net-misc/httpstat/httpstat-1.3.1.ebuild
new file mode 100644
index 000000000000..975c753128f4
--- /dev/null
+++ b/net-misc/httpstat/httpstat-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}