summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ipsvd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ipsvd')
-rw-r--r--net-misc/ipsvd/Manifest1
-rw-r--r--net-misc/ipsvd/files/ipsvd-1.0.0-fix-parallel-make.diff42
-rw-r--r--net-misc/ipsvd/ipsvd-1.0.0-r1.ebuild50
-rw-r--r--net-misc/ipsvd/metadata.xml28
4 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/ipsvd/Manifest b/net-misc/ipsvd/Manifest
new file mode 100644
index 000000000000..fc4e90df855e
--- /dev/null
+++ b/net-misc/ipsvd/Manifest
@@ -0,0 +1 @@
+DIST ipsvd-1.0.0.tar.gz 77903 SHA256 ef7a725bc85acb5d09ab57658385bb470b3e4da5a4ffc88b5da6c6bd37d01fad
diff --git a/net-misc/ipsvd/files/ipsvd-1.0.0-fix-parallel-make.diff b/net-misc/ipsvd/files/ipsvd-1.0.0-fix-parallel-make.diff
new file mode 100644
index 000000000000..0b29a8e8cbb1
--- /dev/null
+++ b/net-misc/ipsvd/files/ipsvd-1.0.0-fix-parallel-make.diff
@@ -0,0 +1,42 @@
+--- Makefile.orig 2011-01-21 00:43:02.000000000 +0100
++++ Makefile 2011-01-21 00:47:27.000000000 +0100
+@@ -61,7 +61,7 @@
+ check-ipsvd-cdb: load check-ipsvd-cdb.o uint32_unpack.o unix.a byte.a
+ ./load check-ipsvd-cdb uint32_unpack.o unix.a byte.a
+
+-tcpsvd.o: compile sysdeps tcpsvd.c ipsvd_log.h
++tcpsvd.o: compile sysdeps tcpsvd.c ipsvd_log.h iopause.h
+ ./compile tcpsvd.c
+
+ sslsvd.o: compile sysdeps tcpsvd.c ssl_io.c ipsvd_log.h matrixssl
+@@ -70,7 +70,7 @@
+ ssl_io.o: compile sysdeps ssl_io.c matrixssl
+ ./compile -I./matrixssl ssl_io.c
+
+-udpsvd.o: compile sysdeps udpsvd.c ipsvd_log.h
++udpsvd.o: compile sysdeps udpsvd.c ipsvd_log.h iopause.h
+ ./compile udpsvd.c
+
+ ipsvd-cdb.o: compile sysdeps ipsvd-cdb.c
+@@ -94,10 +94,10 @@
+ ipsvd_fmt.o: compile ipsvd_fmt.c
+ ./compile ipsvd_fmt.c
+
+-ipsvd_check.o: compile ipsvd_check.c uint64.h
++ipsvd_check.o: compile ipsvd_check.c uint64.h iopause.h
+ ./compile ipsvd_check.c
+
+-ipsvd_hostname.o: compile ipsvd_hostname.c uint64.h
++ipsvd_hostname.o: compile ipsvd_hostname.c uint64.h iopause.h
+ ./compile ipsvd_hostname.c
+
+ ipsvd_phcc.o: compile ipsvd_phcc.c
+@@ -274,7 +274,7 @@
+ ./compile dns_rcrw.c
+
+ dns_resolve.o: compile dns_resolve.c iopause.h taia.h tai.h uint64.h taia.h \
+- byte.h dns.h stralloc.h gen_alloc.h iopause.h taia.h
++ byte.h dns.h stralloc.h gen_alloc.h taia.h
+ ./compile dns_resolve.c
+
+ dns_sortip.o: compile dns_sortip.c byte.h dns.h stralloc.h gen_alloc.h \
diff --git a/net-misc/ipsvd/ipsvd-1.0.0-r1.ebuild b/net-misc/ipsvd/ipsvd-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..2d4bf6bdcfd0
--- /dev/null
+++ b/net-misc/ipsvd/ipsvd-1.0.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="ipsvd is a set of internet protocol service daemons for Unix"
+HOMEPAGE="http://smarden.org/ipsvd/"
+SRC_URI="http://smarden.org/ipsvd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/net/${P}"
+
+src_prepare() {
+ cd "${S}"/src
+ epatch "${FILESDIR}"/${P}-fix-parallel-make.diff
+}
+
+src_configure() {
+ cd "${S}"/src
+ if use static ; then
+ append-ldflags -static
+ fi
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin src/{tcpsvd,udpsvd,ipsvd-cdb} || die "dobin"
+ dodoc package/{CHANGES,README}
+
+ dohtml doc/*.html
+ doman man/ipsvd-instruct.5 man/ipsvd.7 man/udpsvd.8 \
+ man/tcpsvd.8 man/ipsvd-cdb.8
+}
diff --git a/net-misc/ipsvd/metadata.xml b/net-misc/ipsvd/metadata.xml
new file mode 100644
index 000000000000..7af589e8bf54
--- /dev/null
+++ b/net-misc/ipsvd/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+ipsvd is a set of internet protocol service daemons for Unix. It currently
+includes a TCP/IP service daemon, an SSLv3 TCP/IP service daemon (Linux and
+MacOSX), and a UDP/IP service daemon.
+
+An internet protocol service (ipsv) daemon waits for incoming connections on a
+local socket; for new connections, it conditionally runs an arbitrary program
+with standard input reading from the socket, and standard output writing to the
+socket (if connected), to handle the connection. Standard error is used for
+logging.
+
+ipsv daemons can be told to read and follow pre-defined instructions on how to
+handle incoming connections; based on the client's IP address or hostname, they
+can run different programs, set a different environment, deny a connection, or
+set a per host concurrency limit.
+
+Normally the ipsv daemons are run by a supervisor process, such as runsv from
+the runit package, or supervise from the daemontools package.
+
+ipsvd can be used to run services normally run by inetd, xinetd, or tcpserver.
+</longdescription>
+</pkgmetadata>