summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-11 08:59:11 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-11 09:01:36 +0200
commit74859bee8af53b1fc6cba8bc3a434cf79e305809 (patch)
tree96cf9103598c66a82090073a40e6ccb4fc11311b /net-misc/miniupnpd
parentwww-plugins/adobe-flash: Old. (diff)
downloadgentoo-74859bee8af53b1fc6cba8bc3a434cf79e305809.tar.gz
gentoo-74859bee8af53b1fc6cba8bc3a434cf79e305809.tar.bz2
gentoo-74859bee8af53b1fc6cba8bc3a434cf79e305809.zip
net-misc/miniupnpd: Version bump to 2.0.20180410
Diffstat (limited to 'net-misc/miniupnpd')
-rw-r--r--net-misc/miniupnpd/Manifest1
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.0.20180410.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index 05c1f6c5168f..c35776822bad 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -1,3 +1,4 @@
DIST miniupnpd-2.0.20171212.tar.gz 222617 BLAKE2B 6ac33048b18d9f8aeb5103f57c9982fec956a61155f8592118c38dea70801597d9e867690ef2f1cdfaf848a25d7ddb4891b3ebf37cd391b33518d6b02e6f9b4a SHA512 3ab81c840953736c662bcb6f074421052a846c7827768acd7a961a23906b9e3d3389f5b593fb6f8011c8e717dae6cd3907b6d34e7904d560378671a7fc1dd3b2
DIST miniupnpd-2.0.20180203.tar.gz 223084 BLAKE2B 14d7b1f8136be5e211ee2e5374b8ee77dfeb3e64e1308f918d9334a8600234e38581caa293b613cd3736d4a8cfc196a54839cffa8091a36961f4e0e79c727455 SHA512 ef02e33cd93225992c193a13be2320de02255610532de77cf704573384c777d82a4cb89c295982bb660ce056e38ef341223ab362bab74b2cb6954ed4e62b0219
DIST miniupnpd-2.0.20180222.tar.gz 223697 BLAKE2B f551c9219a3a0a0eda905c953c5f9f45df3f192d3d253111cb35ce51351561ae2547351cb901b91eafc1765bd89b75760063e109bacfae625ff8090563913883 SHA512 a7ee306ccac0673e55780129b3c61de025ec63a653383ae475f08695a95647ae83e5e5978ce6ee166e8d0270a5bd08250613593acaabd0b730178ca2e52dc482
+DIST miniupnpd-2.0.20180410.tar.gz 224736 BLAKE2B 76bb4eba8cd3985ff46b1e46543018171a44cee636affb6db75c7b4bfcfa5ef19a678a23467280cf7d199b8fe332cfae6595848c4a2446da2095aecadb82d5f6 SHA512 4a3392b3883e72689e6160941b80533f7254dbaf54407fe2899caef8848d7dbe82ece6079fc39446c162053c1ea1dc10912af0a31d71eb16fbfbec0029dbc645
diff --git a/net-misc/miniupnpd/miniupnpd-2.0.20180410.ebuild b/net-misc/miniupnpd/miniupnpd-2.0.20180410.ebuild
new file mode 100644
index 000000000000..9f786c4d43a2
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.0.20180410.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+leasefile igd2 ipv6 pcp-peer portinuse strict"
+
+RDEPEND=">=net-firewall/iptables-1.4.6:0=[ipv6?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ dev-libs/gmp:0=
+ sys-apps/util-linux
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ sys-apps/lsb-release"
+
+src_prepare() {
+ default
+ mv Makefile.linux Makefile || die
+}
+
+src_configure() {
+ local -a opts
+ opts=(
+ --vendorcfg
+ $(usex igd2 '--igd2' '')
+ $(usex ipv6 '--ipv6' '')
+ $(usex leasefile '--leasefile' '')
+ $(usex portinuse '--portinuse' '')
+ $(usex pcp-peer '--pcp-peer' '')
+ $(usex strict '--strict' '')
+ )
+
+ emake CONFIG_OPTIONS="${opts[*]}" config.h
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d-r1 ${PN}
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}