summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-21 10:00:19 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-21 10:29:31 +0100
commitff67bf533c42c23a7b862aacf372aa667ce6c631 (patch)
treef6bd0d9cd8565808c8b699f62e30076ed0bd7a78 /net-misc/miniupnpd
parentnet-misc/miniupnpd: Remove old (diff)
downloadgentoo-ff67bf533c42c23a7b862aacf372aa667ce6c631.tar.gz
gentoo-ff67bf533c42c23a7b862aacf372aa667ce6c631.tar.bz2
gentoo-ff67bf533c42c23a7b862aacf372aa667ce6c631.zip
net-misc/miniupnpd: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/miniupnpd')
-rw-r--r--net-misc/miniupnpd/Manifest2
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.2.1.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index eddcbe775bff..d39cff455b06 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -1,2 +1,4 @@
DIST miniupnpd-2.2.0.tar.gz 249858 BLAKE2B ef216c7703cb9806a3719b247d67c5c844879308eafbef0936fc501305dbdada7b32e6fc212e50ee093c6f5728709da3d2d5114e89de52a124c229c63ee03563 SHA512 ac8bc3c140f369d0f92d203b94a4f73dde682a486c4395cd25aafda3461577b4a2a1d3160cf8bd37fa8520cda4f86cbdaec925b2ef4e9054e7bf10e04a227d3c
DIST miniupnpd-2.2.0.tar.gz.sig 543 BLAKE2B 11778dd70128ece1f80144bb229176c53f3cd89847a8eedd4fe1b75ac55d986ae7c4689edf40f80c4605ba42260bc41f8fd069e99b8c249226ab9e2981d15412 SHA512 5e0e053a2a3ab876da001589677b0f5e3a4df8511ea5185dbbaee9b80928f9cb9705029f1c83bd9d26b144e39721fce1c4c8c33983956b6731ae654bc094063c
+DIST miniupnpd-2.2.1.tar.gz 250023 BLAKE2B 67418a8480f7d3ac3d51a9c18fdcce4a85c33ff6c373051e1f9df121b00d936f02038ed0a5a5a848b7b2c145aa08dc1e2b954b211cc79fae1de09075f55a9f21 SHA512 211b608472a72065d892e9197f8bdd8c82e44296bb692244ec5e83ca9b076cbcc3426c806ff27d5e805505b1c82b1a7afd7b4030ddecdb60aa85c37062c10c8a
+DIST miniupnpd-2.2.1.tar.gz.sig 543 BLAKE2B fac8c2fd5c50e3201c5fc490d91aed5752bf70297bed101cb3d5ec53d891fdc8f893b3d83e0cf064eb9e9bf16ae9504a849187e18eabc8ed12055574d1e551f5 SHA512 da5b52b1c62bf433a165acf87a64195e27c71c98dfa086cfde19f7b1c4046a62926cca5eb2d10f4260eb1b97c428ba08b4b7fcbf280c2a7009c86279a7563e0f
diff --git a/net-misc/miniupnpd/miniupnpd-2.2.1.ebuild b/net-misc/miniupnpd/miniupnpd-2.2.1.ebuild
new file mode 100644
index 000000000000..1c2981def4c4
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.2.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs verify-sig
+
+MY_P=${P/_rc/-RC}
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${MY_P}.tar.gz
+ verify-sig? ( http://miniupnp.free.fr/files/${MY_P}.tar.gz.sig )"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+leasefile igd2 ipv6 nftables pcp-peer portinuse strict"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ sys-apps/util-linux:=
+ dev-libs/openssl:0=
+ !nftables? (
+ >=net-firewall/iptables-1.4.6:0=[ipv6?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ )
+ nftables? (
+ net-firewall/nftables
+ net-libs/libnftnl:=
+ net-libs/libmnl:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/lsb-release
+ verify-sig? ( app-crypt/openpgp-keys-miniupnp )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/miniupnp.asc
+
+src_configure() {
+ local opts=(
+ --vendorcfg
+ $(usex igd2 '--igd2' '')
+ $(usex ipv6 '--ipv6' '')
+ $(usex leasefile '--leasefile' '')
+ $(usex portinuse '--portinuse' '')
+ $(usex pcp-peer '--pcp-peer' '')
+ $(usex strict '--strict' '')
+ --firewall=$(usex nftables nftables iptables)
+ )
+
+ # custom script
+ ./configure "${opts[@]}" || die
+ # prevent gzipping manpage
+ sed -i -e '/gzip/d' Makefile || die
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ local confd_seds=()
+ if use nftables; then
+ confd_seds+=( -e 's/^iptables_scripts=/#&/' )
+ else
+ confd_seds+=( -e 's/^nftables_scripts=/#&/' )
+ fi
+ if ! use ipv6 || use nftables; then
+ confd_seds+=( -e 's/^ip6tables_scripts=/#&/' )
+ fi
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r2 ${PN}
+ newconfd - ${PN} < <(sed "${confd_seds[@]}" \
+ "${FILESDIR}"/${PN}-conf.d-r2 || die)
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}