summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-29 23:15:28 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-29 23:34:11 +0100
commit66dddc6c6d6d3a8592466703976e976d58c387a1 (patch)
tree2ed6ca226f5a833d5f63cb7e438a60037c1f1a79 /net-misc/mosh/mosh-1.2.5-r1.ebuild
parentwww-client/chromium: fix warnings about _FORTIFY_SOURCE being redefined (diff)
downloadgentoo-66dddc6c6d6d3a8592466703976e976d58c387a1.tar.gz
gentoo-66dddc6c6d6d3a8592466703976e976d58c387a1.tar.bz2
gentoo-66dddc6c6d6d3a8592466703976e976d58c387a1.zip
net-misc/mosh: Drop old versions.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/mosh/mosh-1.2.5-r1.ebuild')
-rw-r--r--net-misc/mosh/mosh-1.2.5-r1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-misc/mosh/mosh-1.2.5-r1.ebuild b/net-misc/mosh/mosh-1.2.5-r1.ebuild
deleted file mode 100644
index e6bc6b42ffbc..000000000000
--- a/net-misc/mosh/mosh-1.2.5-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools bash-completion-r1 eutils vcs-snapshot
-
-DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
-HOMEPAGE="http://mosh.mit.edu"
-SRC_URI="http://mosh.mit.edu/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
-IUSE="+client examples +mosh-hardening +server ufw +utempter"
-
-REQUIRED_USE="|| ( client server )
- examples? ( client )"
-
-RDEPEND="dev-libs/protobuf
- sys-libs/ncurses:0=
- virtual/ssh
- client? (
- dev-lang/perl
- dev-perl/IO-Tty
- )
- utempter? (
- sys-libs/libutempter
- )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# [0] - avoid sandbox-violation calling git describe in Makefile
-PATCHES=(
- "${FILESDIR}"/${P}-git-version.patch
-)
-
-src_prepare() {
- # apply patches.
- epatch "${PATCHES[@]}"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-completion \
- $(use_enable client) \
- $(use_enable server) \
- $(use_enable examples) \
- $(use_enable ufw) \
- $(use_enable mosh-hardening hardening) \
- $(use_with utempter)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- default
-
- for myprog in $(find src/examples -type f -perm /0111) ; do
- newbin ${myprog} ${PN}-$(basename ${myprog})
- elog "${myprog} installed as ${PN}-$(basename ${myprog})"
- done
-
- # bug 477384
- dobashcomp conf/bash-completion/completions/mosh
-}