summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netkit-timed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netkit-timed')
-rw-r--r--net-misc/netkit-timed/Manifest1
-rw-r--r--net-misc/netkit-timed/files/0.17-CFLAG-DEF-fix.patch55
-rw-r--r--net-misc/netkit-timed/files/0.17-timed-opt-parsing.patch12
-rw-r--r--net-misc/netkit-timed/files/timed.rc620
-rw-r--r--net-misc/netkit-timed/metadata.xml8
-rw-r--r--net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild42
6 files changed, 138 insertions, 0 deletions
diff --git a/net-misc/netkit-timed/Manifest b/net-misc/netkit-timed/Manifest
new file mode 100644
index 000000000000..9939a9b2a303
--- /dev/null
+++ b/net-misc/netkit-timed/Manifest
@@ -0,0 +1 @@
+DIST netkit-timed-0.17.tar.gz 48655 SHA256 3be296794158639a350fd71506ffdad9ebd5d2a2640bbf533147e95d55d592fe
diff --git a/net-misc/netkit-timed/files/0.17-CFLAG-DEF-fix.patch b/net-misc/netkit-timed/files/0.17-CFLAG-DEF-fix.patch
new file mode 100644
index 000000000000..6d3fbf704ba5
--- /dev/null
+++ b/net-misc/netkit-timed/files/0.17-CFLAG-DEF-fix.patch
@@ -0,0 +1,55 @@
+diff -ru netkit-timed-0.17/configure netkit-timed-0.17.fixed/configure
+--- netkit-timed-0.17/configure 2000-07-23 15:12:26.000000000 +0930
++++ netkit-timed-0.17.fixed/configure 2004-08-07 09:22:47.860505136 +0930
+@@ -115,39 +115,6 @@
+ echo 'no'
+ fi
+
+-if [ x$DEBUG = x ]; then
+- echo -n "Checking if $CC accepts -O2... "
+- if (
+- $CC -O2 __conftest.c -o __conftest
+- ) >/dev/null 2>&1; then
+- echo 'yes'
+- CFLAGS="$CFLAGS -O2"
+- else
+- echo 'no'
+- echo -n "Checking if $CC accepts -O... "
+- if (
+- $CC -O __conftest.c -o __conftest
+- ) >/dev/null 2>&1; then
+- echo 'yes'
+- CFLAGS="$CFLAGS -O"
+- else
+- echo 'no'
+- fi
+- fi
+-
+-else
+- echo -n "Checking if $CC accepts -g... "
+- if (
+- $CC -g __conftest.c -o __conftest
+- ) >/dev/null 2>&1; then
+- echo 'yes'
+- CFLAGS="$CFLAGS -g"
+- else
+- echo 'no'
+- fi
+-
+-fi
+-
+ LDFLAGS=
+ LIBS=
+
+diff -ru netkit-timed-0.17/timed/timed/timed.c netkit-timed-0.17.fixed/timed/timed/timed.c
+--- netkit-timed-0.17/timed/timed/timed.c 1999-12-13 03:35:07.000000000 +0930
++++ netkit-timed-0.17.fixed/timed/timed/timed.c 2004-08-07 09:26:32.299385240 +0930
+@@ -898,7 +898,7 @@
+ void
+ get_goodgroup(int force)
+ {
+-# define NG_DELAY (30*60*CLK_TCK) /* 30 minutes */
++# define NG_DELAY (30*60*CLOCKS_PER_SEC) /* 30 minutes */
+ static unsigned long last_update = -NG_DELAY;
+ unsigned long new_update;
+ /* struct hosttbl *htp; */
diff --git a/net-misc/netkit-timed/files/0.17-timed-opt-parsing.patch b/net-misc/netkit-timed/files/0.17-timed-opt-parsing.patch
new file mode 100644
index 000000000000..5b5855478d5a
--- /dev/null
+++ b/net-misc/netkit-timed/files/0.17-timed-opt-parsing.patch
@@ -0,0 +1,12 @@
+diff -ur netkit-timed-0.17.orig/timed/timed/timed.c netkit-timed-0.17/timed/timed/timed.c
+--- netkit-timed-0.17.orig/timed/timed/timed.c 2006-07-28 00:12:03.000000000 -0700
++++ netkit-timed-0.17/timed/timed/timed.c 2006-07-28 00:12:52.000000000 -0700
+@@ -158,7 +158,7 @@
+ struct nets *nt;
+ struct sockaddr_in server;
+ u_short port;
+- char c;
++ signed char c;
+ #ifdef sgi
+ FILE *timetrim_st;
+ #endif
diff --git a/net-misc/netkit-timed/files/timed.rc6 b/net-misc/netkit-timed/files/timed.rc6
new file mode 100644
index 000000000000..f6345262c2cb
--- /dev/null
+++ b/net-misc/netkit-timed/files/timed.rc6
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting timed"
+ start-stop-daemon --start --quiet --exec /usr/sbin/timed
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping timed"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/timed
+ eend $?
+}
diff --git a/net-misc/netkit-timed/metadata.xml b/net-misc/netkit-timed/metadata.xml
new file mode 100644
index 000000000000..f9d50da18d39
--- /dev/null
+++ b/net-misc/netkit-timed/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild b/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild
new file mode 100644
index 000000000000..a745dd2f0bf2
--- /dev/null
+++ b/net-misc/netkit-timed/netkit-timed-0.17-r9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+DESCRIPTION="Netkit - timed"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+LICENSE="BSD GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.17-CFLAG-DEF-fix.patch
+ epatch "${FILESDIR}"/0.17-timed-opt-parsing.patch
+ sed -i configure \
+ -e '/^LDFLAGS=/d' \
+ || die "sed configure"
+}
+
+src_configure() {
+ # Note this is not an autoconf configure script. econf fails
+ append-flags -DCLK_TCK=CLOCKS_PER_SEC
+ ./configure --prefix=/usr --with-c-compiler=$(tc-getCC) || die "bad configure"
+}
+
+src_install() {
+ dosbin timed/timed/timed || die
+ doman timed/timed/timed.8 || die
+ dosbin timed/timedc/timedc || die
+ doman timed/timedc/timedc.8 || die
+ dodoc README ChangeLog BUGS || die
+
+ newinitd "${FILESDIR}"/timed.rc6 timed || die
+}