summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-11-08 13:55:53 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-11-08 13:57:51 +0100
commitb7f4405d0aad895d17346e9ab22eb9538f12e3d2 (patch)
treedda0ff6e27c6f405e1231d882bc7fe7ae4b67caf /net-misc/nx
parentdev-ml/facile-1.1.3-r0: alpha stable (diff)
downloadgentoo-b7f4405d0aad895d17346e9ab22eb9538f12e3d2.tar.gz
gentoo-b7f4405d0aad895d17346e9ab22eb9538f12e3d2.tar.bz2
gentoo-b7f4405d0aad895d17346e9ab22eb9538f12e3d2.zip
net-misc/nx: 3.5.0.33 bump
Update ebuild EAPI, safe directory changes Follow upstream compilation steps Limit X11 elements build list Drop obsolete patches and warning Disable SunRPC build, not used for NX and not supporting libtirpc Bug: https://bugs.gentoo.org/370767 Bug: https://bugs.gentoo.org/630492 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'net-misc/nx')
-rw-r--r--net-misc/nx/Manifest1
-rw-r--r--net-misc/nx/nx-3.5.0.33.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-misc/nx/Manifest b/net-misc/nx/Manifest
index b398152fae02..4427289794d4 100644
--- a/net-misc/nx/Manifest
+++ b/net-misc/nx/Manifest
@@ -1,2 +1,3 @@
DIST nx-libs-3.5.0.30-full.tar.gz 6639925 SHA256 60bf86a41f6e7a04a17d5fb471f77a37045c11e06e5e0786b3dc959bb6a3fc5a SHA512 223c73de1b8988d17a555a7dd56c14ddc27855b7c1d9a9b28c053161a707520c1fcef697c3d9148222dae23e1465e72821455271477ac835d5cc63498b45e005 WHIRLPOOL eebd82ff2e7b434840c1f2a451edfdf454903a28b4d9861d1c568308443bff6a05082cd73a446049c840d75bb9b107aab16c6c85fa48529b445ee3b3ac77eb24
DIST nx-libs-3.5.0.32-full.tar.gz 6801696 SHA256 be166390ed7c08b96bd62f1e93910d720d105c679481bc389e833003da2a226d SHA512 8b4a042993d45e1aee3e13e8b86f68cd5b2a8b52e9299de6129abd8e3bb89d73cf2b44b03d3c7fabbd8329abc06dc912ac95bbf936b6478b05fc202cc29a090f WHIRLPOOL 5d97b83ad66ee51b676e15102f0fade974a619840b1e180607062e6694e7eebddf3bceb85324bc59c976d468b283eaa4e99c0a609b707cdae03096d92fab81e5
+DIST nx-libs-3.5.0.33-full.tar.gz 6811378 SHA256 378665a8098398d6fb642559cc59d23902d3b212aa05de4973a13ac9b325a06a SHA512 cfaa201e5422ddd8d1f12d3f0711d6d7a05fcd92379e5108c7c066ce8ae748f2f80f3bbbbba093d73cfe671fffc912443eb3ced0eeca1ab5a221c46488aa8bc5 WHIRLPOOL 9686ccafdadeb5d8b1fcd0a0ae3bd3e0e5f1a966094fef0efbb050bb883375dd0d17909727dbb8cb3d1bbb7225d523695b1829bef4d8e3074eef67d2e1e1d1ef
diff --git a/net-misc/nx/nx-3.5.0.33.ebuild b/net-misc/nx/nx-3.5.0.33.ebuild
new file mode 100644
index 000000000000..7a8bdd99cf2a
--- /dev/null
+++ b/net-misc/nx/nx-3.5.0.33.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="NX compression technology core libraries"
+HOMEPAGE="http://www.x2go.org/doku.php/wiki:libs:nx-libs"
+
+SRC_URI="http://code.x2go.org/releases/source/nx-libs/nx-libs-${PV}-full.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="elibc_glibc"
+
+RDEPEND="media-libs/freetype:2
+ >=media-libs/libpng-1.2.8:*
+ >=sys-libs/zlib-1.2.3
+ virtual/jpeg:*"
+
+DEPEND="${RDEPEND}
+ x11-libs/libfontenc
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/inputproto"
+
+S=${WORKDIR}/nx-libs-${PV}
+
+src_prepare() {
+ default
+
+ # run autoreconf in all neeed folders
+ for i in nxcomp nxcompext nxcompshad nxproxy; do
+ pushd "${S}"/${i} || die
+ eautoreconf
+ popd
+ done
+
+ # From xorg-x11-6.9.0-r3.ebuild
+ pushd "${S}/nx-X11" || die
+ HOSTCONF="config/cf/host.def"
+ echo "#define CcCmd $(tc-getCC)" >> ${HOSTCONF}
+ echo "#define OptimizedCDebugFlags ${CFLAGS} GccAliasingArgs" >> ${HOSTCONF}
+ echo "#define OptimizedCplusplusDebugFlags ${CXXFLAGS} GccAliasingArgs" >> ${HOSTCONF}
+ # Respect LDFLAGS
+ echo "#define ExtraLoadFlags ${LDFLAGS}" >> ${HOSTCONF}
+ echo "#define SharedLibraryLoadFlags -shared ${LDFLAGS}" >> ${HOSTCONF}
+ # Disable SunRPC, #370767
+ echo "#define HasSecureRPC NO" >> ${HOSTCONF}
+
+}
+
+src_configure() {
+ for i in nxcomp nxproxy; do
+ pushd "${S}"/${i} || die
+ econf
+ popd
+ done
+
+ emake -C nx-X11 BuildEnv
+}
+
+src_compile() {
+ emake -C nxcomp
+
+ emake -C nx-X11/lib
+
+ for i in nxcompext nxcompshad ; do
+ pushd "${S}"/${i} || die
+ # Configuration can only run after X11 lib compilation
+ econf
+ emake
+ popd
+ done
+
+ pushd "${S}"/nx-X11 || die
+ emake -C programs/Xserver
+ emake -C programs/nxauth
+ popd
+
+ emake -C nxproxy
+}
+
+src_install() {
+ dobin "${S}"/nx-X11/programs/Xserver/nxagent
+ dobin "${S}"/nx-X11/programs/nxauth/nxauth
+ dobin "${S}"/nxproxy/nxproxy
+
+ for lib in X11 Xau Xcomposite Xdamage Xdmcp Xext Xfixes Xinerama Xpm Xrandr Xrender Xtst;
+ do
+ dolib.so "${S}"/nx-X11/lib/${lib}/libNX_${lib}.so*
+ done
+
+ dolib.so "${S}"/nxcomp/libXcomp.so*
+ dolib.so "${S}"/nxcompext/libXcompext.so*
+ dolib.so "${S}"/nxcompshad/libXcompshad.so*
+
+ insinto /etc/nxagent
+ newins etc/keystrokes.cfg keystroke.cfg
+ doicon nx-X11/programs/Xserver/hw/nxagent/x2go.xpm
+}