summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/openrdate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/openrdate')
-rw-r--r--net-misc/openrdate/Manifest1
-rw-r--r--net-misc/openrdate/files/openrdate-1.1.3-rename.patch29
-rw-r--r--net-misc/openrdate/files/openrdate-confd13
-rw-r--r--net-misc/openrdate/files/openrdate-initd27
-rw-r--r--net-misc/openrdate/metadata.xml10
-rw-r--r--net-misc/openrdate/openrdate-1.2.ebuild33
6 files changed, 113 insertions, 0 deletions
diff --git a/net-misc/openrdate/Manifest b/net-misc/openrdate/Manifest
new file mode 100644
index 000000000000..d79aaccd519f
--- /dev/null
+++ b/net-misc/openrdate/Manifest
@@ -0,0 +1 @@
+DIST openrdate-1.2.tar.gz 118030 SHA256 2921fc96d4ca676190d6ffd45fa80e107c1fe12291c0c4f64827c29639863332
diff --git a/net-misc/openrdate/files/openrdate-1.1.3-rename.patch b/net-misc/openrdate/files/openrdate-1.1.3-rename.patch
new file mode 100644
index 000000000000..5f4774c3be4e
--- /dev/null
+++ b/net-misc/openrdate/files/openrdate-1.1.3-rename.patch
@@ -0,0 +1,29 @@
+Name the binary 'openrdate' as so not to conflict with the pre-existing ancient
+rdate.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar openrdate-1.1.3.orig/Makefile.am openrdate-1.1.3/Makefile.am
+--- openrdate-1.1.3.orig/Makefile.am 2007-11-10 21:15:31.000000000 -0800
++++ openrdate-1.1.3/Makefile.am 2008-06-18 14:27:40.001963783 -0700
+@@ -1,15 +1,15 @@
+ SUBDIRS = src
+
+-bin_PROGRAMS = rdate
++bin_PROGRAMS = openrdate
+
+-rdate_SOURCES= \
++openrdate_SOURCES= \
+ src/rdate.c
+
+-rdate_LDADD= \
++openrdate_LDADD= \
+ src/librdate.a
+
+ man_MANS= \
+- docs/rdate.8
++ docs/openrdate.8
+
+ EXTRA_DIST= \
+- docs/rdate.8
++ $(man_MANS)
diff --git a/net-misc/openrdate/files/openrdate-confd b/net-misc/openrdate/files/openrdate-confd
new file mode 100644
index 000000000000..0760ecb43ba8
--- /dev/null
+++ b/net-misc/openrdate/files/openrdate-confd
@@ -0,0 +1,13 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# the NTP or RFC868/time server to get the date from
+RDATE_SERVER="pool.ntp.org"
+
+# Options to pass to rdate
+# "-s" is mandatory to set the system time, and
+# is passed regardless of this variable.
+# "-n" says that we are using an NTP server instead of a RFC868/time server.
+# "-c" is for leap seconds, which is needed on NTP servers.
+OPENRDATE_OPTS="-n -c"
diff --git a/net-misc/openrdate/files/openrdate-initd b/net-misc/openrdate/files/openrdate-initd
new file mode 100644
index 000000000000..40a64ab802c0
--- /dev/null
+++ b/net-misc/openrdate/files/openrdate-initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ before cron
+ need net
+ use dns
+}
+
+checkconfig() {
+ if [ -z "${RDATE_SERVER}" ] ; then
+ eerror "Please edit /etc/conf.d/openrdate"
+ eerror "I need to know what server to use!"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Setting clock via openrdate"
+ /usr/bin/openrdate -s ${OPENRDATE_OPTS} ${RDATE_SERVER} > /dev/null
+ eend $? "Failed to set clock via openrdate"
+}
diff --git a/net-misc/openrdate/metadata.xml b/net-misc/openrdate/metadata.xml
new file mode 100644
index 000000000000..3aaf73907939
--- /dev/null
+++ b/net-misc/openrdate/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">openrdate</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/openrdate/openrdate-1.2.ebuild b/net-misc/openrdate/openrdate-1.2.ebuild
new file mode 100644
index 000000000000..a59fe3f3f448
--- /dev/null
+++ b/net-misc/openrdate/openrdate-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+WANT_AUTOMAKE=1.9
+
+inherit autotools eutils
+
+DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
+HOMEPAGE="http://sourceforge.net/projects/openrdate/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.1.3-rename.patch
+ eautomake
+ mv docs/{,open}rdate.8
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ newinitd "${FILESDIR}"/openrdate-initd openrdate
+ newconfd "${FILESDIR}"/openrdate-confd openrdate
+}