summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-05-04 13:00:10 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-05-04 13:00:10 -0400
commite3278c05c4781b31b185b6d8daa0d3e65e413521 (patch)
tree05567928900bdea480fec0fcf00e304c55fb03d1 /net-misc/openssh
parentvirtual/libiconv: Add ~riscv keyword (diff)
downloadgentoo-e3278c05c4781b31b185b6d8daa0d3e65e413521.tar.gz
gentoo-e3278c05c4781b31b185b6d8daa0d3e65e413521.tar.bz2
gentoo-e3278c05c4781b31b185b6d8daa0d3e65e413521.zip
net-misc/openssh: stackprotector is broken on musl ppc
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/openssh-7.9_p1-r4.ebuild4
-rw-r--r--net-misc/openssh/openssh-8.0_p1-r1.ebuild4
-rw-r--r--net-misc/openssh/openssh-8.0_p1.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/net-misc/openssh/openssh-7.9_p1-r4.ebuild b/net-misc/openssh/openssh-7.9_p1-r4.ebuild
index 22614b8fc65..de21ccc51cb 100644
--- a/net-misc/openssh/openssh-7.9_p1-r4.ebuild
+++ b/net-misc/openssh/openssh-7.9_p1-r4.ebuild
@@ -300,8 +300,8 @@ src_configure() {
$(use_with !elibc_Cygwin hardening) #659210
)
- # stackprotect is broken on musl x86
- use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+ # stackprotect is broken on musl x86 and ppc
+ use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )
diff --git a/net-misc/openssh/openssh-8.0_p1-r1.ebuild b/net-misc/openssh/openssh-8.0_p1-r1.ebuild
index b0bcb15646d..c541630005b 100644
--- a/net-misc/openssh/openssh-8.0_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-8.0_p1-r1.ebuild
@@ -293,8 +293,8 @@ src_configure() {
$(use_with !elibc_Cygwin hardening) #659210
)
- # stackprotect is broken on musl x86
- use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+ # stackprotect is broken on musl x86 and ppc
+ use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )
diff --git a/net-misc/openssh/openssh-8.0_p1.ebuild b/net-misc/openssh/openssh-8.0_p1.ebuild
index 8c02120a21f..c468c3f26f8 100644
--- a/net-misc/openssh/openssh-8.0_p1.ebuild
+++ b/net-misc/openssh/openssh-8.0_p1.ebuild
@@ -293,8 +293,8 @@ src_configure() {
$(use_with !elibc_Cygwin hardening) #659210
)
- # stackprotect is broken on musl x86
- use elibc_musl && use x86 && myconf+=( --without-stackprotect )
+ # stackprotect is broken on musl x86 and ppc
+ use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )