summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-06-02 12:14:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-06-02 12:14:52 -0500
commit0d74f18fa38281b3391a535b0b8d1d44eab260a6 (patch)
treee93e7f8ad46bb285f5e1d611e3a1ea82372d836d /net-misc/openvswitch
parentapp-crypt/acme: add missing nose testdep (diff)
downloadgentoo-0d74f18fa38281b3391a535b0b8d1d44eab260a6.tar.gz
gentoo-0d74f18fa38281b3391a535b0b8d1d44eab260a6.tar.bz2
gentoo-0d74f18fa38281b3391a535b0b8d1d44eab260a6.zip
net-misc/openvswitch: 2.10.2 and 2.11.1 bump
Bug: https://bugs.gentoo.org/687186 Package-Manager: Portage-2.3.66, Repoman-2.3.13 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/Manifest2
-rw-r--r--net-misc/openvswitch/openvswitch-2.10.2.ebuild147
-rw-r--r--net-misc/openvswitch/openvswitch-2.11.1.ebuild147
3 files changed, 296 insertions, 0 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index 3df07d1580f2..67563a392efa 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -1,3 +1,5 @@
DIST openvswitch-2.10.0.tar.gz 7528705 BLAKE2B a04e6e823a40e9a3a2d2ffd79a881b1f1e2063333a911b9b213eb1ae10d35c4716778e9897f264216889fd7db75b4f89c3e05b34040ce01ab29f0844b4b0cbb2 SHA512 f118c1c4ab4e126c3343023b03007ca9819c3c5a5ea42eaffaabdc7c50ecddede3e258574dbe0de95ed3be2e3d101612f5bdb423a7adb679987f4e501183a216
DIST openvswitch-2.10.1.tar.gz 7522058 BLAKE2B 0f4eef6bf376cc23de4061c04787663f31458d98ac9ffb76627d5a7bb9422ee5f1d99e5c6024ad078c1b6128fb1b9ac99ea9e7107803fd2fdf6cb09bff6b0ef3 SHA512 3634bd3e978110cb9e11191a88e4232a7af152a6ddf46e8a32e50e07de866be782b7e753d26b81183ec107816e5af4109badf8f2067a61fd9506ccf81e748e44
+DIST openvswitch-2.10.2.tar.gz 7561889 BLAKE2B a53dd7db7dcab5098af81671cb265861d3af79cce53436d75e0c3d8a38ce408a142f99b936a66c8bf0f3b317970ad8c1ef84bacc2e573e9b8c21b70aab1de485 SHA512 fd64ae814d85d3002d655a330268cfd6be79db6f954c132d3bfafc7dac23533918b642d0ed454e760f5820804bdff64f73ee8c36afc25a6810ef4c7aab748ba1
+DIST openvswitch-2.11.1.tar.gz 7682693 BLAKE2B f25a537d9ad4051db0049f7ba8442564fdc890035ce3984e1754b9dd916e0b78bea133331b5f4bc3a85d8b8a902ab210703feb0b7cce279803f642f9ee9f87bf SHA512 de016a1acfbae34d2062f4ac23b9b0782016fef4c0575b2714435380439f19613881173fb2c876afe86317a5c0327908704e540322d80f9f7da9f59bea7b1789
DIST openvswitch-2.8.1.tar.gz 6746474 BLAKE2B b41c77e7653a621c4954a8d752d569971f67db7e09a586da5e57ca4b6882ba3c478437ba8ac47b151c08068fa9c1cdb0f74f8630821e5d721ceb2accef75a3a1 SHA512 b9e90b49bb91aef80942b146e7e324b74f8961342dcc7836f2551ea976a69d66506a3a739bcb01a926b3b3874c7e4312de02965738a1536a342ab95f935d92f7
diff --git a/net-misc/openvswitch/openvswitch-2.10.2.ebuild b/net-misc/openvswitch/openvswitch-2.10.2.ebuild
new file mode 100644
index 000000000000..9fa8277073f0
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.10.2.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit autotools eutils linux-info linux-mod python-r1 systemd
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="https://www.openvswitch.org"
+SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug modules monitor +ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ ${PYTHON_DEPS}
+ ~dev-python/ovs-2.10.0[${PYTHON_USEDEP}]
+ || (
+ dev-python/twisted[conch,${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ )
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ debug? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-apps/util-linux[caps]
+ virtual/pkgconfig"
+
+PATCHES="${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ # docs state 4.17.x code states 4.15.x
+ kernel_is le 4 17 999 || die "Linux >= 3.10.0 and <= 4.12 required for userspace modules"
+ linux-mod_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+ eautoreconf
+ default
+}
+
+src_configure() {
+ set_arch_to_kernel
+ # monitor is statically enabled for bug 596206
+ # use monitor || export ovs_cv_python="no"
+ # pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ # flake8 is primarily a style guide tool, running it as part of the tests
+ # in Gentoo does not make much sense, only breaks them: bug 607280
+ export ovs_cv_flake8="no"
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ econf ${linux_config} \
+ --with-rundir=/var/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ default
+
+ local SCRIPT
+ if use monitor; then
+ for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
+ sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
+ python_foreach_impl python_doscript utilities/"${SCRIPT}"
+ done
+ rm -r "${ED%/}"/usr/share/openvswitch/python || die
+ fi
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED%/}"/var/run || die
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
+ systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
+ systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ # only needed on non-systemd, but helps anyway
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EROOT%/}"/var/lib/openvswitch/conf.db
+ if [[ -e "${db}" ]] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ ovsdb-tool convert "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ ovsdb-tool create "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
+ fi
+}
diff --git a/net-misc/openvswitch/openvswitch-2.11.1.ebuild b/net-misc/openvswitch/openvswitch-2.11.1.ebuild
new file mode 100644
index 000000000000..a36bb2cdaa1c
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.11.1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit autotools eutils linux-info linux-mod python-r1 systemd
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="https://www.openvswitch.org"
+SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug modules monitor +ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ ${PYTHON_DEPS}
+ ~dev-python/ovs-2.10.0[${PYTHON_USEDEP}]
+ || (
+ dev-python/twisted[conch,${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ )
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ debug? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-apps/util-linux[caps]
+ virtual/pkgconfig"
+
+PATCHES="${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 4.8 required for userspace modules"
+ # docs state 4.17.x code states 4.15.x
+ kernel_is le 4 18 999 || die "Linux >= 3.10.0 and <= 4.18 required for userspace modules"
+ linux-mod_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+ eautoreconf
+ default
+}
+
+src_configure() {
+ set_arch_to_kernel
+ # monitor is statically enabled for bug 596206
+ # use monitor || export ovs_cv_python="no"
+ # pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ # flake8 is primarily a style guide tool, running it as part of the tests
+ # in Gentoo does not make much sense, only breaks them: bug 607280
+ export ovs_cv_flake8="no"
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ econf ${linux_config} \
+ --with-rundir=/var/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ default
+
+ local SCRIPT
+ if use monitor; then
+ for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
+ sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
+ python_foreach_impl python_doscript utilities/"${SCRIPT}"
+ done
+ rm -r "${ED%/}"/usr/share/openvswitch/python || die
+ fi
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED%/}"/var/run || die
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
+ systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
+ systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
+ systemd_newtmpfilesd "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ # only needed on non-systemd, but helps anyway
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EROOT%/}"/var/lib/openvswitch/conf.db
+ if [[ -e "${db}" ]] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ ovsdb-tool convert "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ ovsdb-tool create "${db}" \
+ "${EROOT%/}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
+ fi
+}