summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-31 05:00:07 +0100
committerSam James <sam@gentoo.org>2022-08-31 05:00:07 +0100
commit911a412a193cc5b347d57e2e662722a568412bf7 (patch)
tree7ae7c6a690fea01b22d94afd4d27f15362a02a37 /net-misc/udpcast/udpcast-20211207.ebuild
parentnet-proxy/squid: use Bash tests (diff)
downloadgentoo-911a412a193cc5b347d57e2e662722a568412bf7.tar.gz
gentoo-911a412a193cc5b347d57e2e662722a568412bf7.tar.bz2
gentoo-911a412a193cc5b347d57e2e662722a568412bf7.zip
net-misc/udpcast: add 20211207
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/udpcast/udpcast-20211207.ebuild')
-rw-r--r--net-misc/udpcast/udpcast-20211207.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/udpcast/udpcast-20211207.ebuild b/net-misc/udpcast/udpcast-20211207.ebuild
new file mode 100644
index 000000000000..e2165f829f27
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20211207.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="https://www.udpcast.linux.lu/"
+SRC_URI="https://www.udpcast.linux.lu/download/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_configure() {
+ use hardened || append-cppflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}