summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-12-13 13:36:58 +0500
committerPatrice Clement <monsieurp@gentoo.org>2018-01-14 16:48:25 +0100
commitcc01d01149ea12e1382cdac085c7240e65fe9240 (patch)
tree1eb7b3e33ee9d9f1d1b13f05f8a5d282f5738cb3 /net-misc/uftp
parentnet-misc/uftp: fix slot dependency. (diff)
downloadgentoo-cc01d01149ea12e1382cdac085c7240e65fe9240.tar.gz
gentoo-cc01d01149ea12e1382cdac085c7240e65fe9240.tar.bz2
gentoo-cc01d01149ea12e1382cdac085c7240e65fe9240.zip
net-misc/uftp: version bump to 4.9.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-misc/uftp')
-rw-r--r--net-misc/uftp/Manifest1
-rw-r--r--net-misc/uftp/files/uftp-4.9.4_makefile.patch41
-rw-r--r--net-misc/uftp/uftp-4.9.4.ebuild53
3 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/uftp/Manifest b/net-misc/uftp/Manifest
index 314b37d4cc4f..34c587c98ead 100644
--- a/net-misc/uftp/Manifest
+++ b/net-misc/uftp/Manifest
@@ -1 +1,2 @@
DIST uftp-3.7.1.tar 849920 BLAKE2B 32a2ccca01f4b8ee205301a2bb4ac30da4f17bf0d8a24f885ec40a430b2cc478efcd504ba118ef7f55c43ef53a6fb3e6caa2e2cebda93c254ab289a8683488a6 SHA512 93fefe1d4c5310bfa6470a78011e63aea8cc9cf59a73ea24920d3ad8c835476bbc410b3669ee79c847eba7d21d61f600e09529d5e6f2ed24076f663a34d99c15
+DIST uftp-4.9.4.tar.gz 243819 BLAKE2B b7aa75f8db82480912dd4cf8199dce7e8170db837853f16a2d8e5a4b7cf190416b7a2a23e170a4837f59a7bba030b0434383bceae9b253eb1d2fc13f6fcd26e7 SHA512 f3c799265a55e0cb536f17be3a0ebfad5f81284255083ebe9a12fda4b5ce8407f05a710cb32a41f3dccbc0ac90367c44d4b67058bdbeaa4f2f8efe732463ebf0
diff --git a/net-misc/uftp/files/uftp-4.9.4_makefile.patch b/net-misc/uftp/files/uftp-4.9.4_makefile.patch
new file mode 100644
index 000000000000..5a131c350a56
--- /dev/null
+++ b/net-misc/uftp/files/uftp-4.9.4_makefile.patch
@@ -0,0 +1,41 @@
+diff -Nuar uftp-4.9.4-orig/makefile uftp-4.9.4/makefile
+--- uftp-4.9.4-orig/makefile 2017-12-13 13:15:53.873252064 +0500
++++ uftp-4.9.4/makefile 2017-12-13 13:25:44.092223428 +0500
+@@ -42,24 +42,24 @@
+ endif
+
+ # defaults
+-OPTIONS=-g -Wall $(ENC_OPTS)
++OPTIONS=-Wall $(ENC_OPTS)
+ LDLIBS=-lc -lm $(CRYPT_LIB)
+ MTFLAGS=
+
+ # FreeBSD
+ ifeq ("FreeBSD", "$(UNAME_S)")
+-OPTIONS=-g -Wall -DHAS_GETIFADDRS -DNO_DUAL -DSOCKADDR_LEN $(ENC_OPTS)
++OPTIONS=-DHAS_GETIFADDRS -DNO_DUAL -DSOCKADDR_LEN $(ENC_OPTS)
+ endif
+
+ # OSX, aka Darwin
+ ifeq ("Darwin", "$(UNAME_S)")
+-OPTIONS=-g -Wall -DHAS_GETIFADDRS $(ENC_OPTS)
++OPTIONS=-Wall -DHAS_GETIFADDRS $(ENC_OPTS)
+ endif
+
+ # Sun
+ ifeq ("SunOS", "$(UNAME_S)")
+ CC = cc
+-OPTIONS=-g -DBSD_COMP -DNO_DUAL -DNO_RECVMSG $(ENC_OPTS)
++OPTIONS=-DBSD_COMP -DNO_DUAL -DNO_RECVMSG $(ENC_OPTS)
+ LDLIBS=-lnsl -lsocket -lm $(CRYPT_LIB)
+ CFLAGS+=`getconf LFS_CFLAGS`
+ OPENSSL=/usr/sfw
+@@ -68,7 +68,7 @@
+
+ # Linux
+ ifeq ("Linux", "$(UNAME_S)")
+-OPTIONS=-g -Wall -Wextra -Wno-unused-parameter -Wno-sign-compare -Wformat=2 -Wwrite-strings -Wpointer-arith -Wcast-qual -Wshadow -Wno-missing-field-initializers -Wstrict-prototypes -Winline -Wbad-function-cast -DHAS_GETIFADDRS $(ENC_OPTS)
++OPTIONS=-Wall -Wextra -Wno-unused-parameter -Wno-sign-compare -Wformat=2 -Wwrite-strings -Wpointer-arith -Wcast-qual -Wshadow -Wno-missing-field-initializers -Wstrict-prototypes -Winline -Wbad-function-cast -DHAS_GETIFADDRS $(ENC_OPTS)
+ LDLIBS=-lm $(CRYPT_LIB)
+ CFLAGS+=`getconf LFS_CFLAGS`
+ endif
diff --git a/net-misc/uftp/uftp-4.9.4.ebuild b/net-misc/uftp/uftp-4.9.4.ebuild
new file mode 100644
index 000000000000..ffc9e730c616
--- /dev/null
+++ b/net-misc/uftp/uftp-4.9.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Encrypted UDP based FTP with multicast"
+HOMEPAGE="http://uftp-multicast.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-multicast/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+server ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_makefile.patch"
+ default
+}
+
+src_compile() {
+ use ssl || local opt="NO_ENCRYPTION=1"
+ emake CC=$(tc-getCC) $opt uftp uftp_keymgt
+ use server && emake CC=$(tc-getCC) $opt uftpd uftpproxyd
+}
+
+src_install() {
+ dobin uftp uftp_keymgt
+ dodoc {Changes,protocol,ReadMe}.txt
+ doman uftp.1 uftp_keymgt.1
+
+ if use server ; then
+ dosbin uftpd uftpproxyd
+ newinitd "${FILESDIR}/uftpd.init" uftpd
+ newconfd "${FILESDIR}/uftpd.conf" uftpd
+ newinitd "${FILESDIR}/uftpproxyd.init" uftpproxyd
+ newconfd "${FILESDIR}/uftpproxyd.conf" uftpproxyd
+ doman uftpd.1 uftpproxyd.1
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotate" uftpd
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn "Please note, uftpd 4.x server is not backward compatible with"
+ ewarn "uftp 3.x clients! Please upgrade clients before servers."
+ fi
+}