summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 10:41:02 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 14:44:58 +0100
commit185d61b14a0d29857707b77b352c768d6cffd18a (patch)
tree3ddbaab6edbea4f3d4db0b59259e8a17ee20386e /net-misc/vino
parentnet-misc/vino: Version bump (diff)
downloadgentoo-185d61b14a0d29857707b77b352c768d6cffd18a.tar.gz
gentoo-185d61b14a0d29857707b77b352c768d6cffd18a.tar.bz2
gentoo-185d61b14a0d29857707b77b352c768d6cffd18a.zip
net-misc/vino: Drop old
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-misc/vino')
-rw-r--r--net-misc/vino/metadata.xml2
-rw-r--r--net-misc/vino/vino-3.16.0.ebuild67
2 files changed, 0 insertions, 69 deletions
diff --git a/net-misc/vino/metadata.xml b/net-misc/vino/metadata.xml
index 326077bc407..f140c75c3b9 100644
--- a/net-misc/vino/metadata.xml
+++ b/net-misc/vino/metadata.xml
@@ -3,8 +3,6 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
- <flag name="libsecret">Enable app-crypt/libsecret support to store
- login credentials.</flag>
<flag name="telepathy">Enable desktop sharing through a telepathy client</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/vino/vino-3.16.0.ebuild b/net-misc/vino/vino-3.16.0.ebuild
deleted file mode 100644
index 7abe1c029ea..00000000000
--- a/net-misc/vino/vino-3.16.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-
-inherit gnome2
-
-DESCRIPTION="An integrated VNC server for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/Vino"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="crypt libsecret ipv6 jpeg ssl +telepathy zeroconf +zlib"
-# bug #394611; tight encoding requires zlib encoding
-REQUIRED_USE="jpeg? ( zlib )"
-
-# cairo used in vino-fb
-# libSM and libICE used in eggsmclient-xsmp
-RDEPEND="
- >=dev-libs/glib-2.26:2
- >=dev-libs/libgcrypt-1.1.90:0=
- >=x11-libs/gtk+-3:3
-
- dev-libs/dbus-glib
- x11-libs/cairo:=
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXtst
- x11-libs/pango[X]
-
- >=x11-libs/libnotify-0.7.0:=
-
- crypt? ( >=dev-libs/libgcrypt-1.1.90:0= )
- jpeg? ( virtual/jpeg:0= )
- libsecret? ( app-crypt/libsecret )
- ssl? ( >=net-libs/gnutls-2.2.0:= )
- telepathy? ( >=net-libs/telepathy-glib-0.18 )
- zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
- zlib? ( sys-libs/zlib:= )
-"
-DEPEND="${RDEPEND}
- >=dev-lang/perl-5
- >=dev-util/intltool-0.50
- virtual/pkgconfig
- app-crypt/libsecret
-"
-# libsecret is always required at build time per bug 322763
-
-src_configure() {
- gnome2_src_configure \
- --with-gcrypt \
- $(use_enable ipv6) \
- $(use_with crypt gcrypt) \
- $(use_with jpeg) \
- $(use_with libsecret secret) \
- $(use_with ssl gnutls) \
- $(use_with telepathy) \
- $(use_with zeroconf avahi) \
- $(use_with zlib)
-}