summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/wput
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/wput')
-rw-r--r--net-misc/wput/Manifest1
-rw-r--r--net-misc/wput/files/wput-0.6-gentoo.diff18
-rw-r--r--net-misc/wput/files/wput-0.6-respectldflags.patch13
-rw-r--r--net-misc/wput/metadata.xml11
-rw-r--r--net-misc/wput/wput-0.6.1.ebuild40
5 files changed, 83 insertions, 0 deletions
diff --git a/net-misc/wput/Manifest b/net-misc/wput/Manifest
new file mode 100644
index 000000000000..669dc9936820
--- /dev/null
+++ b/net-misc/wput/Manifest
@@ -0,0 +1 @@
+DIST wput-0.6.1.tgz 312342 SHA256 67125acab1d520e5d2a0429cd9cf7fc379987f30d5bbed0b0e97b92b554fcc13
diff --git a/net-misc/wput/files/wput-0.6-gentoo.diff b/net-misc/wput/files/wput-0.6-gentoo.diff
new file mode 100644
index 000000000000..312172348d02
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6-gentoo.diff
@@ -0,0 +1,18 @@
+diff -urN wput/Makefile.in wput/Makefile.in
+--- wput/Makefile.in 2006-04-04 18:16:52.000000000 +0100
++++ wput/Makefile.in 2006-11-07 17:31:10.000000000 +0000
+@@ -15,8 +15,12 @@
+
+ install: all
+ cd po && $(MAKE) $(MAKEDEFS) $@
+- install -m0755 wput $(bindir)
+- install -m0644 doc/wput.1.gz $(mandir)
++
++ install -d $(DESTDIR)/$(bindir)
++ install -m0755 wput $(DESTDIR)/$(bindir)
++ install -d $(DESTDIR)/$(mandir)
++ install -m0644 doc/wput.1.gz $(DESTDIR)/$(mandir)
++
+ @echo "----------------"
+ @echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
+ @echo "Further documentation is located in the doc/USAGE.* files."
diff --git a/net-misc/wput/files/wput-0.6-respectldflags.patch b/net-misc/wput/files/wput-0.6-respectldflags.patch
new file mode 100644
index 000000000000..d2b460b339b3
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6-respectldflags.patch
@@ -0,0 +1,13 @@
+Index: wput/src/Makefile.in
+===================================================================
+--- wput.orig/src/Makefile.in
++++ wput/src/Makefile.in
+@@ -23,7 +23,7 @@ ftplib.o: socketlib.h ftplib.h
+ ftp-ls.o: ftp.h wget.h url.h
+
+ wput: $(OBJ)
+- $(CC) -o $(EXE) $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(EXE) $(OBJ) $(LIBS)
+ clean:
+ rm -f *.o *~ *.bak ../wput getopt/*.o
+ win-clean: clean
diff --git a/net-misc/wput/metadata.xml b/net-misc/wput/metadata.xml
new file mode 100644
index 000000000000..e705eb72f8d0
--- /dev/null
+++ b/net-misc/wput/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">wput</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/wput/wput-0.6.1.ebuild b/net-misc/wput/wput-0.6.1.ebuild
new file mode 100644
index 000000000000..21c59d63ff03
--- /dev/null
+++ b/net-misc/wput/wput-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A tiny, wget-alike program, that is designed to upload files/whole directories to remote ftp-servers"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="debug nls ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6-gentoo.diff"
+ # Fix bug 126828
+ epatch "${FILESDIR}/wput-0.6-respectldflags.patch"
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-memdbg=yes" || myconf="--enable-g-switch=no"
+ econf ${myconf} \
+ $(use_enable nls) \
+ $(use_with ssl) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL TODO
+}