summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-17 07:58:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-17 08:21:25 +0200
commit1b5ee8ece0caf51bedd65fa7f0c3b6958e8f4cef (patch)
tree6eadd1826dd3f419baf5b5f8b24836c443d8f9a3 /net-misc/youtube-dl
parentdev-python/sqlalchemy: Bump to 1.4.9 (diff)
downloadgentoo-1b5ee8ece0caf51bedd65fa7f0c3b6958e8f4cef.tar.gz
gentoo-1b5ee8ece0caf51bedd65fa7f0c3b6958e8f4cef.tar.bz2
gentoo-1b5ee8ece0caf51bedd65fa7f0c3b6958e8f4cef.zip
net-misc/youtube-dl: Bump to 2021.04.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.04.17.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 0b6eb9e2c6fd..9306c16e00c8 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,2 +1,3 @@
DIST youtube-dl-2021.04.01.tar.gz 3315743 BLAKE2B 01cd9496116215dd95083060f61134b32b139be1c6002e79a51c7b7f33f933d172608a7d57e95f00f1c14f0c71f4d7a60fcea67c5535c74d73d635e23e7058dc SHA512 138307b14b9ca18a1d55d16d4ae5d179e3244a9e270dedd732a14bb9250665741a9a90ecb1887308dcebfc2e448df28a505168b2b3afed7caeddacf4da8bce53
DIST youtube-dl-2021.04.07.tar.gz 3324661 BLAKE2B c560b6b07bc3ba0c9b7233a634bfae617f604ed5e019e22aefc90e9221a8cd358b937f727b706bba6e9bb6f0a18a8ebd28d5c1f0be383d9dca2c692266cdf222 SHA512 aabf6a1ceefe9101c710bbb45b91e6253a1256343513d841f7901d2be32521a001dac15f5bf13ac94beaf4638dce691f2a157a6172d89047ce2248d06bcafbf8
+DIST youtube-dl-2021.04.17.tar.gz 3331721 BLAKE2B 6b7be0fcb85222d287848cfa40da1dee3f689c59388bbc5d32c335b54cbd0e5ec54c86caf358418641c429d37ae28575858486d4db798d72225a4f5c6e064ac8 SHA512 cb8c76063fc3bd66d07995a669fcf29e5b766c4deb05c9d82fc9795ac3a090a4ae2ee152f150208eae22b93157c286c615044f8f5b0a47798266ab219b49632e
diff --git a/net-misc/youtube-dl/youtube-dl-2021.04.17.ebuild b/net-misc/youtube-dl/youtube-dl-2021.04.17.ebuild
new file mode 100644
index 000000000000..9b024e43dbba
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.04.17.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}