summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-03-06 00:35:48 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-03-06 00:35:48 +0100
commit293f431a83dccb097afbbd39140aa4d4a39e08e9 (patch)
tree1a6e73b0b12c5febdda81dfe4618f4a46d271cc1 /net-misc
parentnet-misc/nextcloud-client: fix compilation with Qt 5.12 (diff)
downloadgentoo-293f431a83dccb097afbbd39140aa4d4a39e08e9.tar.gz
gentoo-293f431a83dccb097afbbd39140aa4d4a39e08e9.tar.bz2
gentoo-293f431a83dccb097afbbd39140aa4d4a39e08e9.zip
net-misc/owncloud-client: drop old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/owncloud-client/Manifest2
-rw-r--r--net-misc/owncloud-client/owncloud-client-2.5.0.10650.ebuild91
-rw-r--r--net-misc/owncloud-client/owncloud-client-2.5.1.10973.ebuild91
3 files changed, 0 insertions, 184 deletions
diff --git a/net-misc/owncloud-client/Manifest b/net-misc/owncloud-client/Manifest
index b054cd089332..4304673a3ee4 100644
--- a/net-misc/owncloud-client/Manifest
+++ b/net-misc/owncloud-client/Manifest
@@ -1,3 +1 @@
-DIST owncloudclient-2.5.0.10650.tar.xz 16651172 BLAKE2B 98b928963f3327bdcddaaa61eadcd73422e982cda11c4a4791987eb34ce692258af47649dcaddaefd01097bbc3aa514a56726dce52ce6f51eb61bdf493bca37a SHA512 61f355e514306ce0dec628ac8af7ba004158a890bc40c3905e5aa7705aff753a3a723ba4a0727625327b399cc71bb6c1ad2b415acc760c551eea1bf2590392f7
-DIST owncloudclient-2.5.1.10973.tar.xz 16662564 BLAKE2B b0c58fee00e366c2a2e0c7b316fc098558758fc3644fdd5a0f39e29dc853030f1df504536a6725a3557e08024346ed9c3fa3d54e35a4d5d452afd1a34ff6fb62 SHA512 11a16f2a2656517f6c89433d8f5e9e44d61be7cc45eb702fe118a000e32ec2f2c53bab75e2d226bc50106c3be975b34b1bafedbaed757d0c3bd8cb025facf47a
DIST owncloudclient-2.5.3.11470.tar.xz 16719780 BLAKE2B 0c10d95ef2d851ba3f728dfe1c55c4143cf9d1542c1f9e77904324f598ecbfa29e54119d12ebef78b8eafa1188e7359ce11d01034ff34a55a80d31d1d3b1db35 SHA512 331d8e8e71d64cf9c958f9391001c6fdff45795e7caad2ce7bf6802c4f0959adf694712cd298fb8702cd4e93577282957cabc61ccc5f4f3a57edc9ddf1c7c2a0
diff --git a/net-misc/owncloud-client/owncloud-client-2.5.0.10650.ebuild b/net-misc/owncloud-client/owncloud-client-2.5.0.10650.ebuild
deleted file mode 100644
index c65369cdae40..000000000000
--- a/net-misc/owncloud-client/owncloud-client-2.5.0.10650.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils gnome2-utils
-
-DESCRIPTION="Synchronize files from ownCloud Server with your computer"
-HOMEPAGE="https://owncloud.org/"
-SRC_URI="https://download.owncloud.com/desktop/stable/${P/-}.tar.xz"
-
-LICENSE="CC-BY-3.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc dolphin nautilus shibboleth test"
-
-COMMON_DEPEND=">=dev-db/sqlite-3.4:3
- dev-libs/qtkeychain[qt5(+)]
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- sys-fs/inotify-tools
- dolphin? (
- kde-frameworks/kcoreaddons:5
- kde-frameworks/kio:5
- )
- nautilus? ( dev-python/nautilus-python )
- shibboleth? ( dev-qt/qtwebkit:5 )
-"
-RDEPEND="${COMMON_DEPEND}
- !net-misc/ocsync
- !net-misc/nextcloud-client
-"
-DEPEND="${COMMON_DEPEND}
- dev-qt/linguist-tools:5
- doc? (
- dev-python/sphinx
- dev-tex/latexmk
- dev-texlive/texlive-latexextra
- virtual/latex-base
- )
- dolphin? ( kde-frameworks/extra-cmake-modules )
- test? (
- dev-util/cmocka
- dev-qt/qttest:5
- )
-"
-
-S=${WORKDIR}/${P/-}
-
-src_prepare() {
- # Keep tests in ${T}
- sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
-
- if ! use nautilus; then
- pushd shell_integration > /dev/null || die
- cmake_comment_add_subdirectory nautilus
- popd > /dev/null || die
- fi
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
- -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
- -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
- -DNO_SHIBBOLETH=$(usex !shibboleth)
- -DUNIT_TESTING=$(usex test)
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if ! use doc ; then
- elog "Documentation and man pages not installed"
- elog "Enable doc USE-flag to generate them"
- fi
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/net-misc/owncloud-client/owncloud-client-2.5.1.10973.ebuild b/net-misc/owncloud-client/owncloud-client-2.5.1.10973.ebuild
deleted file mode 100644
index c65369cdae40..000000000000
--- a/net-misc/owncloud-client/owncloud-client-2.5.1.10973.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils gnome2-utils
-
-DESCRIPTION="Synchronize files from ownCloud Server with your computer"
-HOMEPAGE="https://owncloud.org/"
-SRC_URI="https://download.owncloud.com/desktop/stable/${P/-}.tar.xz"
-
-LICENSE="CC-BY-3.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc dolphin nautilus shibboleth test"
-
-COMMON_DEPEND=">=dev-db/sqlite-3.4:3
- dev-libs/qtkeychain[qt5(+)]
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- sys-fs/inotify-tools
- dolphin? (
- kde-frameworks/kcoreaddons:5
- kde-frameworks/kio:5
- )
- nautilus? ( dev-python/nautilus-python )
- shibboleth? ( dev-qt/qtwebkit:5 )
-"
-RDEPEND="${COMMON_DEPEND}
- !net-misc/ocsync
- !net-misc/nextcloud-client
-"
-DEPEND="${COMMON_DEPEND}
- dev-qt/linguist-tools:5
- doc? (
- dev-python/sphinx
- dev-tex/latexmk
- dev-texlive/texlive-latexextra
- virtual/latex-base
- )
- dolphin? ( kde-frameworks/extra-cmake-modules )
- test? (
- dev-util/cmocka
- dev-qt/qttest:5
- )
-"
-
-S=${WORKDIR}/${P/-}
-
-src_prepare() {
- # Keep tests in ${T}
- sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
-
- if ! use nautilus; then
- pushd shell_integration > /dev/null || die
- cmake_comment_add_subdirectory nautilus
- popd > /dev/null || die
- fi
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
- -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
- -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
- -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
- -DNO_SHIBBOLETH=$(usex !shibboleth)
- -DUNIT_TESTING=$(usex test)
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- if ! use doc ; then
- elog "Documentation and man pages not installed"
- elog "Enable doc USE-flag to generate them"
- fi
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}