summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-06-27 06:28:53 -0500
committerBen Kohler <bkohler@gentoo.org>2020-06-27 06:30:00 -0500
commit4282fb89d694f550fb900f4ba51895396e12a4c7 (patch)
treef7d1182021927e3f3bdcb1f2df2b035db3116217 /net-misc
parentprofiles/updates: attempt fixing "OldPackageUpdate" CI issue (diff)
downloadgentoo-4282fb89d694f550fb900f4ba51895396e12a4c7.tar.gz
gentoo-4282fb89d694f550fb900f4ba51895396e12a4c7.tar.bz2
gentoo-4282fb89d694f550fb900f4ba51895396e12a4c7.zip
net-misc/remmina: backport examples patch
Closes: https://bugs.gentoo.org/729844 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/remmina/files/remmina-1.4.5-with-examples.patch37
-rw-r--r--net-misc/remmina/remmina-1.4.5.ebuild1
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/remmina/files/remmina-1.4.5-with-examples.patch b/net-misc/remmina/files/remmina-1.4.5-with-examples.patch
new file mode 100644
index 000000000000..10ac35744d7f
--- /dev/null
+++ b/net-misc/remmina/files/remmina-1.4.5-with-examples.patch
@@ -0,0 +1,37 @@
+--- /dev/null
++++ b/net-misc/remmina/files/remmina-1.4.6-with-examples.patch
+@@ -0,0 +1,34 @@
++diff -Nupr a/plugins/tool_hello_world/plugin.c b/plugins/tool_hello_world/plugin.c
++--- a/plugins/tool_hello_world/plugin.c 2020-06-08 22:07:44.000000000 +0200
+++++ b/plugins/tool_hello_world/plugin.c 2020-06-10 20:18:48.495507560 +0200
++@@ -42,17 +42,19 @@
++ #include <gdk/gdkx.h>
++
++ static RemminaPluginService *remmina_plugin_service = NULL;
+++#define remmina_plugin_debug(fmt, ...) remmina_plugin_service->_remmina_debug(__func__, fmt __VA_OPT__(,) __VA_ARGS__)
+++
++
++ static void remmina_plugin_tool_init(RemminaProtocolWidget *gp)
++ {
++ TRACE_CALL(__func__);
++- remmina_plugin_service->_debug("[%s] Plugin init", PLUGIN_NAME);
+++ remmina_plugin_debug("[%s] Plugin init", PLUGIN_NAME);
++ }
++
++ static gboolean remmina_plugin_tool_open_connection(RemminaProtocolWidget *gp)
++ {
++ TRACE_CALL(__func__);
++- remmina_plugin_service->_debug("[%s] Plugin open connection", PLUGIN_NAME);
+++ remmina_plugin_debug("[%s] Plugin open connection", PLUGIN_NAME);
++
++ GtkDialog *dialog;
++ dialog = GTK_DIALOG(gtk_message_dialog_new(NULL, GTK_DIALOG_MODAL | GTK_DIALOG_USE_HEADER_BAR,
++@@ -65,7 +67,7 @@ static gboolean remmina_plugin_tool_open
++ static gboolean remmina_plugin_tool_close_connection(RemminaProtocolWidget *gp)
++ {
++ TRACE_CALL(__func__);
++- remmina_plugin_service->_debug("[%s] Plugin close connection", PLUGIN_NAME);
+++ remmina_plugin_debug("[%s] Plugin close connection", PLUGIN_NAME);
++ remmina_plugin_service->protocol_plugin_emit_signal(gp, "disconnect");
++ return FALSE;
++ }
diff --git a/net-misc/remmina/remmina-1.4.5.ebuild b/net-misc/remmina/remmina-1.4.5.ebuild
index f247dfe1992a..04a7d55f4b70 100644
--- a/net-misc/remmina/remmina-1.4.5.ebuild
+++ b/net-misc/remmina/remmina-1.4.5.ebuild
@@ -58,6 +58,7 @@ DOCS=( AUTHORS CHANGELOG.md README.md THANKS.md )
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ eapply "${FILESDIR}"/${P}-with-examples.patch
cmake_src_prepare
xdg_src_prepare
}