summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-08 14:35:27 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-08 14:35:27 +0300
commit75e54be8d917a272d481589bf411fca63f7d8bf1 (patch)
tree8db266bf132497b55176efd9765e0a10feef2cf4 /net-misc
parentx11-libs/agg: Drop old (EAPI=2) (diff)
downloadgentoo-75e54be8d917a272d481589bf411fca63f7d8bf1.tar.gz
gentoo-75e54be8d917a272d481589bf411fca63f7d8bf1.tar.bz2
gentoo-75e54be8d917a272d481589bf411fca63f7d8bf1.zip
net-misc/liveice: revbump: EAPI=7
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/liveice/liveice-2000530-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/liveice/liveice-2000530-r2.ebuild b/net-misc/liveice/liveice-2000530-r2.ebuild
new file mode 100644
index 000000000000..5efefe357e32
--- /dev/null
+++ b/net-misc/liveice/liveice-2000530-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Live Source Client For IceCast"
+HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
+SRC_URI="http://star.arm.ac.uk/~spm/software/liveice.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="media-sound/lame
+ media-sound/mpg123"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+ # cannot use LDFLAGS directly as the Makefile uses it for LIBS
+ sed -i Makefile.in \
+ -e 's|-o liveice|$(LLFLAGS) &|' \
+ || die "sed Makefile.in"
+ tc-export CC
+}
+
+src_compile() {
+ emake LLFLAGS="${LDFLAGS}"
+}
+src_install() {
+ dobin liveice
+ dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt
+}