summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-15 19:25:09 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-15 19:25:17 +0100
commit94ae3ad228e9bbf5804932da02f665362bd73a9e (patch)
tree302723b32ba6fad35825a6275966e16821ee4f02 /net-misc
parentsys-kernel/genkernel: update live ebuild (diff)
downloadgentoo-94ae3ad228e9bbf5804932da02f665362bd73a9e.tar.gz
gentoo-94ae3ad228e9bbf5804932da02f665362bd73a9e.tar.bz2
gentoo-94ae3ad228e9bbf5804932da02f665362bd73a9e.zip
net-misc/ipv6calc: backport gcc-10 tweak
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/708056 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ipv6calc/files/ipv6calc-2.2.0-gcc-10.patch34
-rw-r--r--net-misc/ipv6calc/ipv6calc-2.2.0.ebuild4
2 files changed, 37 insertions, 1 deletions
diff --git a/net-misc/ipv6calc/files/ipv6calc-2.2.0-gcc-10.patch b/net-misc/ipv6calc/files/ipv6calc-2.2.0-gcc-10.patch
new file mode 100644
index 000000000000..4639fa7406f1
--- /dev/null
+++ b/net-misc/ipv6calc/files/ipv6calc-2.2.0-gcc-10.patch
@@ -0,0 +1,34 @@
+https://bugs.gentoo.org/708056
+
+From 8c7eea58f2034113ae91ff7adc2bda72465b7d1a Mon Sep 17 00:00:00 2001
+From: Peter Bieringer <pb@bieringer.de>
+Date: Fri, 24 Jan 2020 07:15:55 +0100
+Subject: [PATCH] ipv6logconv/ipv6logconv.{h,c}: fix multiple definition of
+ 'cache_lru_limit'
+
+--- a/ipv6logconv/ipv6logconv.c
++++ b/ipv6logconv/ipv6logconv.c
+@@ -58,7 +58,7 @@ static void lineparser(const long int outputtype);
+ /* LRU cache */
+
+ #define CACHE_LRU_SIZE 200
+-
++int cache_lru_limit;
+ static int cache_lru_max = 0;
+ static int cache_lru_last = 0;
+ static char cache_lru_key_token[CACHE_LRU_SIZE][NI_MAXHOST];
+--- a/ipv6logconv/ipv6logconv.h
++++ b/ipv6logconv/ipv6logconv.h
+@@ -20,8 +20,7 @@
+ #define DEBUG_ipv6logconv_general 0x00000001l
+ #define DEBUG_ipv6logconv_processing 0x00000002l
+
+-/* prototyping */
+-int cache_lru_limit;
++extern int cache_lru_limit;
+
+ extern int feature_reg;
+ extern int feature_ieee;
+--
+2.27.0
+
diff --git a/net-misc/ipv6calc/ipv6calc-2.2.0.ebuild b/net-misc/ipv6calc/ipv6calc-2.2.0.ebuild
index 65630c1080ec..36eb43a10612 100644
--- a/net-misc/ipv6calc/ipv6calc-2.2.0.ebuild
+++ b/net-misc/ipv6calc/ipv6calc-2.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
test? ( dev-perl/Digest-SHA1 )
"
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
#dev-perl/URI is needed for web interface, that is not installed now
src_configure() {