summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-24 18:41:12 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-24 18:44:48 +0200
commita4794af194c3693cacc83bbe8b5126e963b99cdc (patch)
tree61a647f6a8a92b1f3376cb431f47e2c6dcc028c9 /net-misc
parentsci-electronics/xcircuit: bump to last stable upstream version. drop old (diff)
downloadgentoo-a4794af194c3693cacc83bbe8b5126e963b99cdc.tar.gz
gentoo-a4794af194c3693cacc83bbe8b5126e963b99cdc.tar.bz2
gentoo-a4794af194c3693cacc83bbe8b5126e963b99cdc.zip
net-misc/apt-cacher-ng: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/apt-cacher-ng/Manifest1
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-0.9.3.2.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/net-misc/apt-cacher-ng/Manifest b/net-misc/apt-cacher-ng/Manifest
index 94f281c2160b..7b2b3be55513 100644
--- a/net-misc/apt-cacher-ng/Manifest
+++ b/net-misc/apt-cacher-ng/Manifest
@@ -1,2 +1,3 @@
DIST apt-cacher-ng_0.9.3.1.orig.tar.xz 307092 SHA256 2817fe4089f40029bd83f5739a69ecbef9d10cc8944294df865d06faf635de4b SHA512 2fc3bd6cf8298fccf04f583ce63cf1c6daf24a649ddb13b061bef15172d6e1c211293e552d79d40391aa0cb30d9a8810c66fb2ff379f5cc251974ed759fe7f07 WHIRLPOOL 2594033999c593fe81f016c044086696bde9ab0b26156cfbc6f453f1a4b18baecdedb0c7ed3ab7c9522bbf53a4557290756333c9a6eca95e8bc4857d2e8f04aa
+DIST apt-cacher-ng_0.9.3.2.orig.tar.xz 307564 SHA256 cc3ee1c0d657d51332f3ba092dad8bdc94284e07922a814762fbbdcc6b7a76af SHA512 d292a4d23658f4d71374c8c3218a5ff0ad9876ded73444b4e2e3205acc998c982d9519655ca08a99afe21506e82425252a4981485e28ec898f0b42cc55c91aa8 WHIRLPOOL 8223304a6428953278566c15dd43ce77f56ffa3a1a3956baca7ea554376ca528cf79cdabdf5cec0fd50ff8e745a98a32577ff7c8c9e055722dbb0d0075d47748
DIST apt-cacher-ng_0.9.3.orig.tar.xz 306284 SHA256 8f3b3b0e0937eb6ef65e5d0a982beacddb2f1c75989a0dde4d3760f078a0a7ad SHA512 7b8d71e4b7d436c2f38fb8f0e2ad8e929f39db47e276be91af7250509020fdee07d5cb1c5852db25fb725bd11953729c8059ad9f8f897d12b5263942b93476b6 WHIRLPOOL cc3f550bfbbf5c9ba27423fd47bba393277fa6830e214aaa23376622e3386c6dbcb927fcef6c86ab67579325e1a873e24ca9888f23bdfdbbb8a4549ef5fda699
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-0.9.3.2.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-0.9.3.2.ebuild
new file mode 100644
index 000000000000..2fc058217e13
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-0.9.3.2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils toolchain-funcs user
+
+DESCRIPTION="Yet another caching HTTP proxy for Debian/Ubuntu software packages"
+HOMEPAGE="
+ http://www.unix-ag.uni-kl.de/~bloch/acng/
+ http://packages.qa.debian.org/a/apt-cacher-ng.html
+"
+LICENSE="BSD-4 ZLIB public-domain"
+SLOT="0"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse systemd tcpd"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib
+ systemd? (
+ sys-apps/systemd
+ )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-util/cmake
+ >sys-devel/gcc-4.8
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-lang/perl
+ fuse? ( sys-fs/fuse )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+
+S=${WORKDIR}/${P/_}
+
+pkg_pretend() {
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+ elif [[ $(gcc-major-version) = 4 ]] && [[ $(gcc-minor-version) -lt 8 ]]; then
+ die "GCC 4.8 or greater is required but you have $(gcc-major-version).$(gcc-minor-version)"
+ fi
+}
+
+pkg_setup() {
+ # add new user & group for daemon
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_configure(){
+ mycmakeargs="-DCMAKE_INSTALL_PREFIX=/usr"
+ if use fuse; then
+ mycmakeargs="-DHAVE_FUSE_25=yes ${mycmakeargs}"
+ else
+ mycmakeargs="-DHAVE_FUSE_25=no ${mycmakeargs}"
+ fi
+ if use tcpd; then
+ mycmakeargs="-DHAVE_LIBWRAP=yes ${mycmakeargs}"
+ else
+ mycmakeargs="-DHAVE_LIBWRAP=no ${mycmakeargs}"
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ pushd ${CMAKE_BUILD_DIR}
+ dosbin ${PN}
+ if use fuse; then
+ dobin acngfs
+ fi
+ popd
+
+ newinitd "${FILESDIR}"/initd-r1 ${PN}
+ newconfd "${FILESDIR}"/confd ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate ${PN}
+
+ doman doc/man/${PN}*
+ if use fuse; then
+ doman doc/man/acngfs*
+ fi
+
+ # Documentation
+ dodoc README TODO VERSION INSTALL ChangeLog
+ if use doc; then
+ dodoc doc/*.pdf
+ dohtml doc/html/*
+ docinto examples/conf
+ dodoc conf/*
+ fi
+
+ # perl daily cron script
+ dosbin scripts/expire-caller.pl
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/cron.daily ${PN}
+
+ # default configuration
+ insinto /etc/${PN}
+ newins "${CMAKE_BUILD_DIR}"/conf/acng.conf ${PN}.conf
+ doins $( echo conf/* | sed 's|conf/acng.conf.in||g' )
+
+ keepdir /var/log/${PN}
+ # Some directories must exists
+ keepdir /var/log/${PN}
+ fowners -R ${PN}:${PN} \
+ /etc/${PN} \
+ /var/log/${PN}
+}