summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-12-26 12:23:53 +0100
committerJeroen Roovers <jer@gentoo.org>2015-12-26 12:24:27 +0100
commitb7b779c5f3ae69b1c8f0a241ddf70626590c4dd8 (patch)
tree0e6d5987d02bdb26aad805de79f09d92b9a5e354 /net-misc
parentgnome-extra/gnome-dvb-daemon: 0.2.90 adjust license (diff)
downloadgentoo-b7b779c5f3ae69b1c8f0a241ddf70626590c4dd8.tar.gz
gentoo-b7b779c5f3ae69b1c8f0a241ddf70626590c4dd8.tar.bz2
gentoo-b7b779c5f3ae69b1c8f0a241ddf70626590c4dd8.zip
net-misc/youtube-dl: Add live ebuild (bug #543188 by Leonardo Amaral).
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/youtube-dl-99999999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/youtube-dl-99999999.ebuild b/net-misc/youtube-dl/youtube-dl-99999999.ebuild
new file mode 100644
index 000000000000..aba829c27973
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-99999999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils git-r3
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+EGIT_REPO_URI="https://github.com/rg3/youtube-dl.git"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+src_compile() {
+ distutils-r1_src_compile
+ emake -C docs man
+ ${PYTHON} devscripts/bash-completion.py
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.md
+ doman docs/_build/man/${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}