summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-15 07:53:45 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-15 07:54:54 +0200
commitc5cffcd92e2a31e1ba4d10a00742536c6eac89f7 (patch)
tree79ef2e87d4bb00f05ce84c56e7784ae3dc0c0729 /net-misc
parentdev-util/cmake: Remove 3.3.2, 3.4.3 (diff)
downloadgentoo-c5cffcd92e2a31e1ba4d10a00742536c6eac89f7.tar.gz
gentoo-c5cffcd92e2a31e1ba4d10a00742536c6eac89f7.tar.bz2
gentoo-c5cffcd92e2a31e1ba4d10a00742536c6eac89f7.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.07.13.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index b4e1aa801cb9..c9ef96a6a772 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.07.09.1.tar.gz 2270473 SHA256 244585080738b4ea6374559c55a38d11577d36cccead6cf90a57c15e55500b36 SHA512 d6d77396fd347f0852dbe57208884200d588e7b8428c780b10670d08a3319c5fb791b6138e6cd9d52583db13f6a4cb1fcc4b119d2bc361753907cbe2712f1903 WHIRLPOOL 54660596a21b5d781692db5c7af076091fa157bf3eee17b7961e02129c38e60343abb4baa5bf33ef77ca7ac54d4960160c1d9ea98fc2afa7407603d74e2a1d3b
DIST youtube-dl-2016.07.11.tar.gz 2277011 SHA256 f661957cf1f52bfa7b621cf1b02c0200862a7931e92e25cd984a9c302c3e4d87 SHA512 7c112b238f65a7e4029204f06fa42c67c2fa5d370dc1d796c8fe83d0f585b355e2dfdebc8312bb082acbc72e98b0969b9894c0fba9297016eca2ac09d14b7c51 WHIRLPOOL 19b542560d7044783160671b40187b33b0034a5770bacef8c68d9e490e40bb1af47a1c4e7ebb2b1eb208963b6d3f8732899a2cf1c90e4ce7fbb347dc9dd2b5f6
+DIST youtube-dl-2016.07.13.tar.gz 2279744 SHA256 16cda6c8151445b90d3c43412788ff0bb7176e7d7d2a4325642b0e8113249443 SHA512 d0564f724e6b62ee65c48ee9db953101cc2045a2f4b66960be5be135bc61b0249553f74b6bd9f797cc6660109a4a266e43bf9a8646bbe3a8d806b5c022a96ee3 WHIRLPOOL 14720370cc11291d9f192d71ba3bdf241422e3331881e37f86165153f87ca636cc181ee2db8cc5cc9ed7b14c6eac0f2a910387159f421e5131cce4894fc92c82
diff --git a/net-misc/youtube-dl/youtube-dl-2016.07.13.ebuild b/net-misc/youtube-dl/youtube-dl-2016.07.13.ebuild
new file mode 100644
index 000000000000..9d7ca82d0e68
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.07.13.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+}