summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-18 14:10:49 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-18 14:10:49 +0200
commitf9d27f9ed4570c35a9dcb775bc31905b7da00f67 (patch)
treeb9548bc504daa0b6de946efe7ac890c90030f851 /net-misc
parentsci-physics/root: fix dependency on mpi, bug #818460 (diff)
downloadgentoo-f9d27f9ed4570c35a9dcb775bc31905b7da00f67.tar.gz
gentoo-f9d27f9ed4570c35a9dcb775bc31905b7da00f67.tar.bz2
gentoo-f9d27f9ed4570c35a9dcb775bc31905b7da00f67.zip
net-misc/mstpd: add 0.1.0
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mstpd/Manifest1
-rw-r--r--net-misc/mstpd/mstpd-0.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/mstpd/Manifest b/net-misc/mstpd/Manifest
index 364e28eec594..2df98bcbb1c8 100644
--- a/net-misc/mstpd/Manifest
+++ b/net-misc/mstpd/Manifest
@@ -1 +1,2 @@
DIST mstpd-0.0.9.tar.gz 113711 BLAKE2B 93ff0213a634fcbbb613c79227d737c3961f4de669e0ac2c7351fa1c22842669edc652ba0deb24917a44df5a465a4e905a98e46ab7ccc7e4ebfd13039e6acfe0 SHA512 1d4a926d8437b7c41c69d2a047718181ca6245f3150e4aeb631f437edaaafe0c40b29802a6c9ea38c9f1dfb1b94149934b473f550358be10bb796295fa632e1e
+DIST mstpd-0.1.0.tar.gz 115670 BLAKE2B d0b666f16941ebb161cf91ad849da9d8f1927e90052f02cbab759685864bdd6040525bcbb69ca3e602140fa7245f1a48eed00d7e8515eb849ae0bd586f41588d SHA512 c3f7e1045e89eaad05b212993e4fb79e3662d247e371340276c59b92e33c732a9d82ed3490ce3b51e79c666db9f999916667d2be5da1f928e1624b288b0295bb
diff --git a/net-misc/mstpd/mstpd-0.1.0.ebuild b/net-misc/mstpd/mstpd-0.1.0.ebuild
new file mode 100644
index 000000000000..c8603cd165e9
--- /dev/null
+++ b/net-misc/mstpd/mstpd-0.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1 systemd
+
+DESCRIPTION="Multiple spanning tree protocol daemon"
+HOMEPAGE="https://github.com/mstpd/mstpd"
+SRC_URI="https://github.com/mstpd/mstpd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir="$(get_bashcompdir)" \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)" \
+ --localstatedir="${EPREFIX}"/
+}
+
+src_install() {
+ default
+ dosym ../../sbin/bridge-stp /lib/mstpctl-utils/mstpctl_restart_config
+ dosym bridge-stp /sbin/mstp_restart
+}