summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-02-23 11:08:24 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-23 11:09:05 -0800
commit39a60ca58ef439b835ca2a03479d83f0eb333375 (patch)
tree4abbae12846ef8d47b58d4e80687fce03c3ce164 /net-nds/openldap
parentapp-editors/nano: version bump to 2.7.5 (diff)
downloadgentoo-39a60ca58ef439b835ca2a03479d83f0eb333375.tar.gz
gentoo-39a60ca58ef439b835ca2a03479d83f0eb333375.tar.bz2
gentoo-39a60ca58ef439b835ca2a03479d83f0eb333375.zip
net-nds/openldap: built_with_use -> has_version
Fixes: https://bugs.gentoo.org/show_bug.cgi?id=610448 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/openldap-2.3.43-r3.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.3.43-r4.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.4.44-r1.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.4.44.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/net-nds/openldap/openldap-2.3.43-r3.ebuild b/net-nds/openldap/openldap-2.3.43-r3.ebuild
index 7d5c8c02345..dda92d5efdd 100644
--- a/net-nds/openldap/openldap-2.3.43-r3.ebuild
+++ b/net-nds/openldap/openldap-2.3.43-r3.ebuild
@@ -180,7 +180,7 @@ pkg_setup() {
die "Please set ssl useflag"
fi
- if use minimal && has_version "net-nds/openldap" && built_with_use net-nds/openldap minimal ; then
+ if use minimal && has_version 'net-nds/openldap[minimal]' ; then
einfo
einfo "Skipping scan for previous datadirs as requested by minimal useflag"
einfo
diff --git a/net-nds/openldap/openldap-2.3.43-r4.ebuild b/net-nds/openldap/openldap-2.3.43-r4.ebuild
index e8c1aa5dbf5..c4c6745bdfc 100644
--- a/net-nds/openldap/openldap-2.3.43-r4.ebuild
+++ b/net-nds/openldap/openldap-2.3.43-r4.ebuild
@@ -180,7 +180,7 @@ pkg_setup() {
die "Please set ssl useflag"
fi
- if use minimal && has_version "net-nds/openldap" && built_with_use net-nds/openldap minimal ; then
+ if use minimal && has_version 'net-nds/openldap[minimal]' ; then
einfo
einfo "Skipping scan for previous datadirs as requested by minimal useflag"
einfo
diff --git a/net-nds/openldap/openldap-2.4.44-r1.ebuild b/net-nds/openldap/openldap-2.4.44-r1.ebuild
index aede7c1056b..2445bd5958f 100644
--- a/net-nds/openldap/openldap-2.4.44-r1.ebuild
+++ b/net-nds/openldap/openldap-2.4.44-r1.ebuild
@@ -297,7 +297,7 @@ pkg_setup() {
# Bug #322787
if use minimal && ! has_version "net-nds/openldap" ; then
einfo "No datadir scan needed, openldap not installed"
- elif use minimal && has_version "net-nds/openldap" && built_with_use net-nds/openldap minimal ; then
+ elif use minimal && has_version 'net-nds/openldap[minimal]' ; then
einfo "Skipping scan for previous datadirs as requested by minimal useflag"
else
openldap_find_versiontags
diff --git a/net-nds/openldap/openldap-2.4.44.ebuild b/net-nds/openldap/openldap-2.4.44.ebuild
index 47400ab6b25..ad16fcf5ec2 100644
--- a/net-nds/openldap/openldap-2.4.44.ebuild
+++ b/net-nds/openldap/openldap-2.4.44.ebuild
@@ -296,7 +296,7 @@ pkg_setup() {
# Bug #322787
if use minimal && ! has_version "net-nds/openldap" ; then
einfo "No datadir scan needed, openldap not installed"
- elif use minimal && has_version "net-nds/openldap" && built_with_use net-nds/openldap minimal ; then
+ elif use minimal && has_version 'net-nds/openldap[minimal]' ; then
einfo "Skipping scan for previous datadirs as requested by minimal useflag"
else
openldap_find_versiontags