summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-06-04 17:37:41 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-06-04 17:37:52 +1000
commit8d91ca78fd4248d6d9f13a9cef48b56d013e22d7 (patch)
tree3763d74e56b3b035e9ca7c0579d3b27d3698b6c7 /net-news
parentdev-python/django-openstack-auth: Version Bump (diff)
downloadgentoo-8d91ca78fd4248d6d9f13a9cef48b56d013e22d7.tar.gz
gentoo-8d91ca78fd4248d6d9f13a9cef48b56d013e22d7.tar.bz2
gentoo-8d91ca78fd4248d6d9f13a9cef48b56d013e22d7.zip
net-news/quiterss: remove phonon and qt4 USE flags
The qt4 USE flag depends on dev-qt/qtwebkit:4 which is ancient and will not see any future security updates, and the phonon USE flag does nothing for the qt5 build. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-news')
-rw-r--r--net-news/quiterss/metadata.xml4
-rw-r--r--net-news/quiterss/quiterss-0.18.4.ebuild36
2 files changed, 12 insertions, 28 deletions
diff --git a/net-news/quiterss/metadata.xml b/net-news/quiterss/metadata.xml
index 329100ec2fc..56fe54721bb 100644
--- a/net-news/quiterss/metadata.xml
+++ b/net-news/quiterss/metadata.xml
@@ -5,10 +5,6 @@
<email>qt@gentoo.org</email>
<name>Gentoo Qt Project</name>
</maintainer>
- <use>
- <flag name="phonon">Enable sound support via <pkg>media-libs/phonon</pkg>
- or <pkg>dev-qt/qtphonon</pkg></flag>
- </use>
<upstream>
<remote-id type="github">QuiteRSS/quiterss</remote-id>
</upstream>
diff --git a/net-news/quiterss/quiterss-0.18.4.ebuild b/net-news/quiterss/quiterss-0.18.4.ebuild
index 70273ffe420..76a7d9d1ffa 100644
--- a/net-news/quiterss/quiterss-0.18.4.ebuild
+++ b/net-news/quiterss/quiterss-0.18.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,25 +19,18 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="phonon qt5"
+IUSE=""
RDEPEND=">=dev-db/sqlite-3.11.1:3
- !qt5? ( dev-qt/qtcore:4[ssl]
- dev-qt/qtgui:4
- dev-qt/qtsingleapplication[X,qt4(+)]
- dev-qt/qtsql:4[sqlite]
- dev-qt/qtwebkit:4
- phonon? ( || ( media-libs/phonon[qt4] dev-qt/qtphonon:4 ) ) )
- qt5? ( dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtprintsupport:5
- dev-qt/qtsingleapplication[X,qt5(-)]
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtwebkit:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5 )"
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[X,qt5(-)]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -62,12 +55,7 @@ src_configure() {
PREFIX="${EPREFIX}/usr"
SYSTEMQTSA=1
)
- if use qt5; then
- eqmake5 "${myqmakeargs[@]}"
- else
- eqmake4 "${myqmakeargs[@]}" \
- $(usex phonon '' 'DISABLE_PHONON=1')
- fi
+ eqmake5 "${myqmakeargs[@]}"
}
src_install() {